Bug 1211015 - Saved session does NOT appear the same at kde restart
Summary: Saved session does NOT appear the same at kde restart
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kf5-kxmlgui
Version: 22
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Daniel Vrátil
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: RejectedBlocker
Keywords: Triaged
: 1218921 1228956 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-04-12 06:49 UTC by George R. Goffe
Modified: 2015-11-02 01:38 UTC (History)
19 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2015-05-26 03:46:03 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
KDE Software Compilation 346768 None None None Never

Description George R. Goffe 2015-04-12 06:49:23 UTC
Description of problem:

I have saved a session with Konsoles and Xosview. When I logout and log back in and start KDE, sometimes Xosview appears at other locations.

Version-Release number of selected component (if applicable):

kde at 14.12.3-2.fc22


How reproducible:

sometimes

Steps to Reproduce:
1.logout of KDE and log back in and start KDE
2.
3.

Actual results:

Most of the time the manually saved session is restored as requested. Sometimes, Xosview appears at other locations.

Expected results:


Additional info:

Comment 1 Rex Dieter 2015-04-22 20:20:47 UTC
triaging to plasma-workspace (owner of ksmserver)

Comment 2 Rex Dieter 2015-05-12 14:12:28 UTC
See also upstream bug tracking issue:
https://bugs.kde.org/show_bug.cgi?id=346768

Comment 3 Rex Dieter 2015-05-12 14:12:58 UTC
*** Bug 1218921 has been marked as a duplicate of this bug. ***

Comment 4 Fedora Blocker Bugs Application 2015-05-12 14:20:57 UTC
Proposed as a Freeze Exception for 22-final by Fedora user dmossor using the blocker tracking app because:

 Proposing as a Freeze Exception as this bug violates the Final Release Criteria - Default panel functionality.

"All elements of the default panel (or equivalent) configuration in all release-blocking desktops must function correctly in typical use. "

One of the key features of the desktop is to recall your configuration of the desktop, such as panel placement and configuration, after a logout or reboot. This bug prevents this data from being saved, so any customization of the desktop, to include panel configuration, is not saved.

Comment 5 Fedora Update System 2015-05-12 14:30:59 UTC
kf5-knotifyconfig-5.10.0-1.fc20, kf5-kross-5.10.0-1.fc20, kf5-krunner-5.10.0-1.fc20, kf5-kdnssd-5.10.0-1.fc20, kf5-kjs-5.10.0-1.fc20, kf5-ktextwidgets-5.10.0-1.fc20, kf5-karchive-5.10.0-1.fc20, kf5-kded-5.10.0-1.fc20, kf5-khtml-5.10.0-1.fc20, kf5-sonnet-5.10.0-1.fc20, kf5-kdoctools-5.10.0-1.fc20, kf5-plasma-5.10.0-1.fc20, kf5-kauth-5.10.0-1.fc20, kf5-kmediaplayer-5.10.0-1.fc20, kf5-kbookmarks-5.10.0-1.fc20, kf5-kitemviews-5.10.0-1.fc20, kf5-kcodecs-5.10.0-1.fc20, kf5-attica-5.10.0-1.fc20, kf5-kdesignerplugin-5.10.0-1.fc20, kf5-kdbusaddons-5.10.0-1.fc20, kf5-kdeclarative-5.10.0-1.fc20, extra-cmake-modules-5.10.0-1.fc20, kf5-kcoreaddons-5.10.0-1.fc20, kf5-kcompletion-5.10.0-1.fc20, kf5-ktexteditor-5.10.0-1.fc20, kf5-kpeople-5.10.0-1.fc20, kf5-kdewebkit-5.10.0-1.fc20, kf5-kjobwidgets-5.10.0-1.fc20, kf5-kio-5.10.0-1.fc20, kf5-kcmutils-5.10.0-1.fc20, kf5-kapidox-5.10.0-1.fc20, kf5-knewstuff-5.10.0-1.fc20, kf5-kxmlrpcclient-5.10.0-1.fc20, kf5-kdelibs4support-5.10.0-1.fc20, kf5-frameworkintegration-5.10.0-1.fc20, kf5-solid-5.10.0-1.fc20, kf5-modemmanager-qt-5.10.0-2.fc20, kf5-kwindowsystem-5.10.0-1.fc20, kf5-networkmanager-qt-5.10.0-1.fc20, kf5-kinit-5.10.0-1.fc20, kf5-kguiaddons-5.10.0-1.fc20, kf5-threadweaver-5.10.0-1.fc20, kf5-ki18n-5.10.0-1.fc20, kf5-kiconthemes-5.10.0-1.fc20, kf5-kplotting-5.10.0-1.fc20, kf5-kemoticons-5.10.0-1.fc20, kf5-kactivities-5.10.0-1.fc20, kf5-kservice-5.10.0-1.fc20, kf5-kconfigwidgets-5.10.0-1.fc20, kf5-kcrash-5.10.0-1.fc20, kf5-kpackage-5.10.0-1.fc20, kf5-5.10.0-1.fc20, kf5-knotifications-5.10.0-1.fc20, kf5-kunitconversion-5.10.0-1.fc20, kf5-kwidgetsaddons-5.10.0-1.fc20, kf5-kdesu-5.10.0-1.fc20, kf5-kjsembed-5.10.0-1.fc20, kf5-kitemmodels-5.10.0-1.fc20, kf5-kimageformats-5.10.0-1.fc20, kf5-kglobalaccel-5.10.0-1.fc20, kf5-kidletime-5.10.0-1.fc20, kf5-kpty-5.10.0-1.fc20, kf5-kparts-5.10.0-1.fc20, kf5-kwallet-5.10.0-1.fc20, kf5-kxmlgui-5.10.0-2.fc20, kf5-kconfig-5.10.0-3.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/kf5-knotifyconfig-5.10.0-1.fc20,kf5-kxmlrpcclient-5.10.0-1.fc20,kf5-kross-5.10.0-1.fc20,kf5-kdelibs4support-5.10.0-1.fc20,kf5-krunner-5.10.0-1.fc20,kf5-frameworkintegration-5.10.0-1.fc20,kf5-kdnssd-5.10.0-1.fc20,kf5-solid-5.10.0-1.fc20,kf5-kjs-5.10.0-1.fc20,kf5-modemmanager-qt-5.10.0-2.fc20,kf5-ktextwidgets-5.10.0-1.fc20,kf5-kwindowsystem-5.10.0-1.fc20,kf5-karchive-5.10.0-1.fc20,kf5-networkmanager-qt-5.10.0-1.fc20,kf5-kded-5.10.0-1.fc20,kf5-kinit-5.10.0-1.fc20,kf5-khtml-5.10.0-1.fc20,kf5-kguiaddons-5.10.0-1.fc20,kf5-sonnet-5.10.0-1.fc20,kf5-threadweaver-5.10.0-1.fc20,kf5-kdoctools-5.10.0-1.fc20,kf5-ki18n-5.10.0-1.fc20,kf5-plasma-5.10.0-1.fc20,kf5-kiconthemes-5.10.0-1.fc20,kf5-kauth-5.10.0-1.fc20,kf5-kplotting-5.10.0-1.fc20,kf5-kmediaplayer-5.10.0-1.fc20,kf5-kemoticons-5.10.0-1.fc20,kf5-kbookmarks-5.10.0-1.fc20,kf5-kactivities-5.10.0-1.fc20,kf5-kitemviews-5.10.0-1.fc20,kf5-kservice-5.10.0-1.fc20,kf5-kcodecs-5.10.0-1.fc20,kf5-kconfigwidgets-5.10.0-1.fc20,kf5-attica-5.10.0-1.fc20,kf5-kcrash-5.10.0-1.fc20,kf5-kdesignerplugin-5.10.0-1.fc20,kf5-kpackage-5.10.0-1.fc20,kf5-kdbusaddons-5.10.0-1.fc20,kf5-5.10.0-1.fc20,kf5-kdeclarative-5.10.0-1.fc20,kf5-knotifications-5.10.0-1.fc20,kf5-kxmlgui-5.10.0-2.fc20,kf5-kconfig-5.10.0-3.fc20,extra-cmake-modules-5.10.0-1.fc20,kf5-kunitconversion-5.10.0-1.fc20,kf5-kcoreaddons-5.10.0-1.fc20,kf5-kwidgetsaddons-5.10.0-1.fc20,kf5-kcompletion-5.10.0-1.fc20,kf5-kdesu-5.10.0-1.fc20,kf5-ktexteditor-5.10.0-1.fc20,kf5-kjsembed-5.10.0-1.fc20,kf5-kpeople-5.10.0-1.fc20,kf5-kitemmodels-5.10.0-1.fc20,kf5-kdewebkit-5.10.0-1.fc20,kf5-kimageformats-5.10.0-1.fc20,kf5-kjobwidgets-5.10.0-1.fc20,kf5-kglobalaccel-5.10.0-1.fc20,kf5-kio-5.10.0-1.fc20,kf5-kidletime-5.10.0-1.fc20,kf5-kcmutils-5.10.0-1.fc20,kf5-kpty-5.10.0-1.fc20,kf5-kapidox-5.10.0-1.fc20,kf5-kparts-5.10.0-1.fc20,kf5-knewstuff-5.10.0-1.fc20,kf5-kwallet-5.10.0-1.fc20

Comment 6 Fedora Update System 2015-05-12 14:35:20 UTC
kf5-kwindowsystem-5.10.0-1.fc22, kf5-kdelibs4support-5.10.0-1.fc22, kf5-kglobalaccel-5.10.0-1.fc22, kf5-kcoreaddons-5.10.0-1.fc22, kf5-kplotting-5.10.0-1.fc22, kf5-kinit-5.10.0-1.fc22, kf5-kcmutils-5.10.0-1.fc22, kf5-ki18n-5.10.0-1.fc22, kf5-kwallet-5.10.0-1.fc22, kf5-kded-5.10.0-1.fc22, kf5-kimageformats-5.10.0-1.fc22, kf5-kross-5.10.0-1.fc22, kf5-kdewebkit-5.10.0-1.fc22, kf5-ktextwidgets-5.10.0-1.fc22, kf5-kactivities-5.10.0-1.fc22, kf5-kjobwidgets-5.10.0-1.fc22, kf5-kcodecs-5.10.0-1.fc22, kf5-kconfigwidgets-5.10.0-1.fc22, kf5-kauth-5.10.0-1.fc22, kf5-solid-5.10.0-1.fc22, extra-cmake-modules-5.10.0-1.fc22, kf5-5.10.0-1.fc22, kf5-khtml-5.10.0-1.fc22, kf5-kpeople-5.10.0-1.fc22, kf5-kdbusaddons-5.10.0-1.fc22, kf5-kservice-5.10.0-1.fc22, kf5-kxmlrpcclient-5.10.0-1.fc22, kf5-modemmanager-qt-5.10.0-2.fc22, kf5-karchive-5.10.0-1.fc22, kf5-threadweaver-5.10.0-1.fc22, kf5-kparts-5.10.0-1.fc22, kf5-kbookmarks-5.10.0-1.fc22, kf5-kjsembed-5.10.0-1.fc22, kf5-kxmlgui-5.10.0-2.fc22, kf5-plasma-5.10.0-1.fc22, kf5-kcompletion-5.10.0-1.fc22, kf5-sonnet-5.10.0-1.fc22, kf5-kio-5.10.0-1.fc22, kf5-kdeclarative-5.10.0-1.fc22, kf5-networkmanager-qt-5.10.0-2.fc22, kf5-krunner-5.10.0-1.fc22, kf5-knotifications-5.10.0-1.fc22, kf5-knewstuff-5.10.0-1.fc22, kf5-kunitconversion-5.10.0-1.fc22, kf5-kpackage-5.10.0-1.fc22, kf5-kjs-5.10.0-1.fc22, kf5-frameworkintegration-5.10.0-1.fc22, kf5-knotifyconfig-5.10.0-1.fc22, kf5-kguiaddons-5.10.0-1.fc22, kf5-kdoctools-5.10.0-1.fc22, kf5-attica-5.10.0-1.fc22, kf5-ktexteditor-5.10.0-1.fc22, kf5-kwidgetsaddons-5.10.0-1.fc22, kf5-kidletime-5.10.0-1.fc22, kf5-kdesu-5.10.0-1.fc22, kf5-kapidox-5.10.0-1.fc22, kf5-kmediaplayer-5.10.0-1.fc22, kf5-kdesignerplugin-5.10.0-1.fc22, kf5-kitemmodels-5.10.0-1.fc22, kf5-kiconthemes-5.10.0-1.fc22, kf5-kcrash-5.10.0-1.fc22, kf5-kpty-5.10.0-1.fc22, kf5-kitemviews-5.10.0-1.fc22, kf5-kemoticons-5.10.0-1.fc22, kf5-kdnssd-5.10.0-1.fc22, kf5-kconfig-5.10.0-3.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/kf5-plasma-5.10.0-1.fc22,kf5-kwindowsystem-5.10.0-1.fc22,kf5-kcompletion-5.10.0-1.fc22,kf5-kdelibs4support-5.10.0-1.fc22,kf5-sonnet-5.10.0-1.fc22,kf5-kglobalaccel-5.10.0-1.fc22,kf5-kio-5.10.0-1.fc22,kf5-kcoreaddons-5.10.0-1.fc22,kf5-kdeclarative-5.10.0-1.fc22,kf5-kplotting-5.10.0-1.fc22,kf5-networkmanager-qt-5.10.0-2.fc22,kf5-kinit-5.10.0-1.fc22,kf5-krunner-5.10.0-1.fc22,kf5-kcmutils-5.10.0-1.fc22,kf5-knotifications-5.10.0-1.fc22,kf5-ki18n-5.10.0-1.fc22,kf5-knewstuff-5.10.0-1.fc22,kf5-kwallet-5.10.0-1.fc22,kf5-kunitconversion-5.10.0-1.fc22,kf5-kded-5.10.0-1.fc22,kf5-kpackage-5.10.0-1.fc22,kf5-kimageformats-5.10.0-1.fc22,kf5-kjs-5.10.0-1.fc22,kf5-kross-5.10.0-1.fc22,kf5-kxmlgui-5.10.0-2.fc22,kf5-kdewebkit-5.10.0-1.fc22,kf5-frameworkintegration-5.10.0-1.fc22,kf5-ktextwidgets-5.10.0-1.fc22,kf5-knotifyconfig-5.10.0-1.fc22,kf5-kactivities-5.10.0-1.fc22,kf5-kguiaddons-5.10.0-1.fc22,kf5-kjobwidgets-5.10.0-1.fc22,kf5-kdoctools-5.10.0-1.fc22,kf5-kcodecs-5.10.0-1.fc22,kf5-kconfig-5.10.0-3.fc22,kf5-kconfigwidgets-5.10.0-1.fc22,kf5-attica-5.10.0-1.fc22,kf5-kauth-5.10.0-1.fc22,kf5-ktexteditor-5.10.0-1.fc22,kf5-solid-5.10.0-1.fc22,kf5-kwidgetsaddons-5.10.0-1.fc22,extra-cmake-modules-5.10.0-1.fc22,kf5-kidletime-5.10.0-1.fc22,kf5-5.10.0-1.fc22,kf5-kdesu-5.10.0-1.fc22,kf5-khtml-5.10.0-1.fc22,kf5-kapidox-5.10.0-1.fc22,kf5-kpeople-5.10.0-1.fc22,kf5-kmediaplayer-5.10.0-1.fc22,kf5-kdbusaddons-5.10.0-1.fc22,kf5-kdesignerplugin-5.10.0-1.fc22,kf5-kservice-5.10.0-1.fc22,kf5-kitemmodels-5.10.0-1.fc22,kf5-kxmlrpcclient-5.10.0-1.fc22,kf5-kiconthemes-5.10.0-1.fc22,kf5-modemmanager-qt-5.10.0-2.fc22,kf5-kcrash-5.10.0-1.fc22,kf5-karchive-5.10.0-1.fc22,kf5-kpty-5.10.0-1.fc22,kf5-threadweaver-5.10.0-1.fc22,kf5-kitemviews-5.10.0-1.fc22,kf5-kparts-5.10.0-1.fc22,kf5-kemoticons-5.10.0-1.fc22,kf5-kbookmarks-5.10.0-1.fc22,kf5-kdnssd-5.10.0-1.fc22,kf5-kjsembed-5.10.0-1.fc22

Comment 7 Fedora Update System 2015-05-12 14:40:12 UTC
kf5-frameworkintegration-5.10.0-1.fc21, kf5-ktextwidgets-5.10.0-1.fc21, kf5-kross-5.10.0-1.fc21, kf5-kglobalaccel-5.10.0-1.fc21, kf5-kservice-5.10.0-1.fc21, kf5-kguiaddons-5.10.0-1.fc21, kf5-knotifications-5.10.0-1.fc21, kf5-solid-5.10.0-1.fc21, kf5-kjsembed-5.10.0-1.fc21, kf5-modemmanager-qt-5.10.0-2.fc21, kf5-kjs-5.10.0-1.fc21, kf5-kplotting-5.10.0-1.fc21, kf5-kcrash-5.10.0-1.fc21, kf5-khtml-5.10.0-1.fc21, kf5-kdewebkit-5.10.0-1.fc21, kf5-kwidgetsaddons-5.10.0-1.fc21, kf5-kdelibs4support-5.10.0-1.fc21, kf5-knewstuff-5.10.0-1.fc21, kf5-kdeclarative-5.10.0-1.fc21, kf5-attica-5.10.0-1.fc21, kf5-kapidox-5.10.0-1.fc21, kf5-threadweaver-5.10.0-1.fc21, kf5-kcompletion-5.10.0-1.fc21, kf5-kpty-5.10.0-1.fc21, kf5-kidletime-5.10.0-1.fc21, kf5-kxmlrpcclient-5.10.0-1.fc21, kf5-ki18n-5.10.0-1.fc21, kf5-kdesignerplugin-5.10.0-1.fc21, kf5-kpackage-5.10.0-1.fc21, kf5-kdbusaddons-5.10.0-1.fc21, kf5-kparts-5.10.0-1.fc21, kf5-kdesu-5.10.0-1.fc21, kf5-kmediaplayer-5.10.0-1.fc21, kf5-sonnet-5.10.0-1.fc21, kf5-kded-5.10.0-1.fc21, kf5-kcmutils-5.10.0-1.fc21, kf5-knotifyconfig-5.10.0-1.fc21, kf5-kjobwidgets-5.10.0-1.fc21, kf5-kdnssd-5.10.0-1.fc21, kf5-kunitconversion-5.10.0-1.fc21, kf5-kpeople-5.10.0-1.fc21, kf5-kdoctools-5.10.0-1.fc21, kf5-kbookmarks-5.10.0-1.fc21, kf5-kimageformats-5.10.0-1.fc21, kf5-ktexteditor-5.10.0-1.fc21, kf5-kio-5.10.0-1.fc21, kf5-kactivities-5.10.0-1.fc21, kf5-kiconthemes-5.10.0-1.fc21, kf5-kwallet-5.10.0-1.fc21, kf5-kitemmodels-5.10.0-1.fc21, kf5-plasma-5.10.0-1.fc21, kf5-kauth-5.10.0-1.fc21, kf5-karchive-5.10.0-1.fc21, extra-cmake-modules-5.10.0-1.fc21, kf5-kcodecs-5.10.0-1.fc21, kf5-kwindowsystem-5.10.0-1.fc21, kf5-krunner-5.10.0-1.fc21, kf5-kcoreaddons-5.10.0-1.fc21, kf5-networkmanager-qt-5.10.0-1.fc21, kf5-kitemviews-5.10.0-1.fc21, kf5-5.10.0-1.fc21, kf5-kxmlgui-5.10.0-2.fc21, kf5-kconfigwidgets-5.10.0-1.fc21, kf5-kemoticons-5.10.0-1.fc21, kf5-kinit-5.10.0-1.fc21, kf5-kconfig-5.10.0-3.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/kf5-frameworkintegration-5.10.0-1.fc21,kf5-ktextwidgets-5.10.0-1.fc21,kf5-kross-5.10.0-1.fc21,kf5-kglobalaccel-5.10.0-1.fc21,kf5-kservice-5.10.0-1.fc21,kf5-kguiaddons-5.10.0-1.fc21,kf5-knotifications-5.10.0-1.fc21,kf5-solid-5.10.0-1.fc21,kf5-kjsembed-5.10.0-1.fc21,kf5-modemmanager-qt-5.10.0-2.fc21,kf5-kxmlgui-5.10.0-2.fc21,kf5-kjs-5.10.0-1.fc21,kf5-kplotting-5.10.0-1.fc21,kf5-kcrash-5.10.0-1.fc21,kf5-khtml-5.10.0-1.fc21,kf5-kdewebkit-5.10.0-1.fc21,kf5-kwidgetsaddons-5.10.0-1.fc21,kf5-kdelibs4support-5.10.0-1.fc21,kf5-knewstuff-5.10.0-1.fc21,kf5-kdeclarative-5.10.0-1.fc21,kf5-attica-5.10.0-1.fc21,kf5-kapidox-5.10.0-1.fc21,kf5-threadweaver-5.10.0-1.fc21,kf5-kcompletion-5.10.0-1.fc21,kf5-kpty-5.10.0-1.fc21,kf5-kidletime-5.10.0-1.fc21,kf5-kxmlrpcclient-5.10.0-1.fc21,kf5-ki18n-5.10.0-1.fc21,kf5-kdesignerplugin-5.10.0-1.fc21,kf5-kpackage-5.10.0-1.fc21,kf5-kdbusaddons-5.10.0-1.fc21,kf5-kparts-5.10.0-1.fc21,kf5-kdesu-5.10.0-1.fc21,kf5-kmediaplayer-5.10.0-1.fc21,kf5-sonnet-5.10.0-1.fc21,kf5-kded-5.10.0-1.fc21,kf5-kcmutils-5.10.0-1.fc21,kf5-knotifyconfig-5.10.0-1.fc21,kf5-kjobwidgets-5.10.0-1.fc21,kf5-kdnssd-5.10.0-1.fc21,kf5-kunitconversion-5.10.0-1.fc21,kf5-kpeople-5.10.0-1.fc21,kf5-kdoctools-5.10.0-1.fc21,kf5-kconfig-5.10.0-3.fc21,kf5-kbookmarks-5.10.0-1.fc21,kf5-kimageformats-5.10.0-1.fc21,kf5-ktexteditor-5.10.0-1.fc21,kf5-kio-5.10.0-1.fc21,kf5-kactivities-5.10.0-1.fc21,kf5-kiconthemes-5.10.0-1.fc21,kf5-kwallet-5.10.0-1.fc21,kf5-kitemmodels-5.10.0-1.fc21,kf5-plasma-5.10.0-1.fc21,kf5-kauth-5.10.0-1.fc21,kf5-karchive-5.10.0-1.fc21,extra-cmake-modules-5.10.0-1.fc21,kf5-kcodecs-5.10.0-1.fc21,kf5-kwindowsystem-5.10.0-1.fc21,kf5-krunner-5.10.0-1.fc21,kf5-kcoreaddons-5.10.0-1.fc21,kf5-networkmanager-qt-5.10.0-1.fc21,kf5-kitemviews-5.10.0-1.fc21,kf5-5.10.0-1.fc21,kf5-kconfigwidgets-5.10.0-1.fc21,kf5-kinit-5.10.0-1.fc21,kf5-kemoticons-5.10.0-1.fc21

Comment 8 Ed Greshko 2015-05-12 22:45:34 UTC
If, and I say if since I've not tested, this fixes the session restore issues of Plasma 5 then to me it is a *must* for F22 release.

Comment 9 Fedora Update System 2015-05-13 08:19:46 UTC
Package kf5-kwindowsystem-5.10.0-1.fc22, kf5-kdelibs4support-5.10.0-1.fc22, kf5-kglobalaccel-5.10.0-1.fc22, kf5-kcoreaddons-5.10.0-1.fc22, kf5-kplotting-5.10.0-1.fc22, kf5-kinit-5.10.0-1.fc22, kf5-kcmutils-5.10.0-1.fc22, kf5-ki18n-5.10.0-1.fc22, kf5-kwallet-5.10.0-1.fc22, kf5-kded-5.10.0-1.fc22, kf5-kimageformats-5.10.0-1.fc22, kf5-kross-5.10.0-1.fc22, kf5-kdewebkit-5.10.0-1.fc22, kf5-ktextwidgets-5.10.0-1.fc22, kf5-kactivities-5.10.0-1.fc22, kf5-kjobwidgets-5.10.0-1.fc22, kf5-kcodecs-5.10.0-1.fc22, kf5-kconfigwidgets-5.10.0-1.fc22, kf5-kauth-5.10.0-1.fc22, kf5-solid-5.10.0-1.fc22, extra-cmake-modules-5.10.0-1.fc22, kf5-5.10.0-1.fc22, kf5-khtml-5.10.0-1.fc22, kf5-kpeople-5.10.0-1.fc22, kf5-kdbusaddons-5.10.0-1.fc22, kf5-kservice-5.10.0-1.fc22, kf5-kxmlrpcclient-5.10.0-1.fc22, kf5-modemmanager-qt-5.10.0-2.fc22, kf5-karchive-5.10.0-1.fc22, kf5-threadweaver-5.10.0-1.fc22, kf5-kparts-5.10.0-1.fc22, kf5-kbookmarks-5.10.0-1.fc22, kf5-kjsembed-5.10.0-1.fc22, kf5-kxmlgui-5.10.0-2.fc22, kf5-kcompletion-5.10.0-1.fc22, kf5-sonnet-5.10.0-1.fc22, kf5-kio-5.10.0-1.fc22, kf5-kdeclarative-5.10.0-1.fc22, kf5-networkmanager-qt-5.10.0-2.fc22, kf5-krunner-5.10.0-1.fc22, kf5-knotifications-5.10.0-1.fc22, kf5-knewstuff-5.10.0-1.fc22, kf5-kunitconversion-5.10.0-1.fc22, kf5-kpackage-5.10.0-1.fc22, kf5-kjs-5.10.0-1.fc22, kf5-frameworkintegration-5.10.0-1.fc22, kf5-knotifyconfig-5.10.0-1.fc22, kf5-kguiaddons-5.10.0-1.fc22, kf5-kdoctools-5.10.0-1.fc22, kf5-attica-5.10.0-1.fc22, kf5-ktexteditor-5.10.0-1.fc22, kf5-kwidgetsaddons-5.10.0-1.fc22, kf5-kidletime-5.10.0-1.fc22, kf5-kdesu-5.10.0-1.fc22, kf5-kapidox-5.10.0-1.fc22, kf5-kmediaplayer-5.10.0-1.fc22, kf5-kdesignerplugin-5.10.0-1.fc22, kf5-kitemmodels-5.10.0-1.fc22, kf5-kiconthemes-5.10.0-1.fc22, kf5-kcrash-5.10.0-1.fc22, kf5-kpty-5.10.0-1.fc22, kf5-kitemviews-5.10.0-1.fc22, kf5-kemoticons-5.10.0-1.fc22, kf5-kdnssd-5.10.0-1.fc22, kf5-kconfig-5.10.0-3.fc22, kf5-plasma-5.10.0-2.fc22:
* should fix your issue,
* was pushed to the Fedora 22 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing kf5-kwindowsystem-5.10.0-1.fc22 kf5-kdelibs4support-5.10.0-1.fc22 kf5-kglobalaccel-5.10.0-1.fc22 kf5-kcoreaddons-5.10.0-1.fc22 kf5-kplotting-5.10.0-1.fc22 kf5-kinit-5.10.0-1.fc22 kf5-kcmutils-5.10.0-1.fc22 kf5-ki18n-5.10.0-1.fc22 kf5-kwallet-5.10.0-1.fc22 kf5-kded-5.10.0-1.fc22 kf5-kimageformats-5.10.0-1.fc22 kf5-kross-5.10.0-1.fc22 kf5-kdewebkit-5.10.0-1.fc22 kf5-ktextwidgets-5.10.0-1.fc22 kf5-kactivities-5.10.0-1.fc22 kf5-kjobwidgets-5.10.0-1.fc22 kf5-kcodecs-5.10.0-1.fc22 kf5-kconfigwidgets-5.10.0-1.fc22 kf5-kauth-5.10.0-1.fc22 kf5-solid-5.10.0-1.fc22 extra-cmake-modules-5.10.0-1.fc22 kf5-5.10.0-1.fc22 kf5-khtml-5.10.0-1.fc22 kf5-kpeople-5.10.0-1.fc22 kf5-kdbusaddons-5.10.0-1.fc22 kf5-kservice-5.10.0-1.fc22 kf5-kxmlrpcclient-5.10.0-1.fc22 kf5-modemmanager-qt-5.10.0-2.fc22 kf5-karchive-5.10.0-1.fc22 kf5-threadweaver-5.10.0-1.fc22 kf5-kparts-5.10.0-1.fc22 kf5-kbookmarks-5.10.0-1.fc22 kf5-kjsembed-5.10.0-1.fc22 kf5-kxmlgui-5.10.0-2.fc22 kf5-kcompletion-5.10.0-1.fc22 kf5-sonnet-5.10.0-1.fc22 kf5-kio-5.10.0-1.fc22 kf5-kdeclarative-5.10.0-1.fc22 kf5-networkmanager-qt-5.10.0-2.fc22 kf5-krunner-5.10.0-1.fc22 kf5-knotifications-5.10.0-1.fc22 kf5-knewstuff-5.10.0-1.fc22 kf5-kunitconversion-5.10.0-1.fc22 kf5-kpackage-5.10.0-1.fc22 kf5-kjs-5.10.0-1.fc22 kf5-frameworkintegration-5.10.0-1.fc22 kf5-knotifyconfig-5.10.0-1.fc22 kf5-kguiaddons-5.10.0-1.fc22 kf5-kdoctools-5.10.0-1.fc22 kf5-attica-5.10.0-1.fc22 kf5-ktexteditor-5.10.0-1.fc22 kf5-kwidgetsaddons-5.10.0-1.fc22 kf5-kidletime-5.10.0-1.fc22 kf5-kdesu-5.10.0-1.fc22 kf5-kapidox-5.10.0-1.fc22 kf5-kmediaplayer-5.10.0-1.fc22 kf5-kdesignerplugin-5.10.0-1.fc22 kf5-kitemmodels-5.10.0-1.fc22 kf5-kiconthemes-5.10.0-1.fc22 kf5-kcrash-5.10.0-1.fc22 kf5-kpty-5.10.0-1.fc22 kf5-kitemviews-5.10.0-1.fc22 kf5-kemoticons-5.10.0-1.fc22 kf5-kdnssd-5.10.0-1.fc22 kf5-kconfig-5.10.0-3.fc22 kf5-plasma-5.10.0-2.fc22'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-8089/kf5-plasma-5.10.0-2.fc22,kf5-kwindowsystem-5.10.0-1.fc22,kf5-kcompletion-5.10.0-1.fc22,kf5-kdelibs4support-5.10.0-1.fc22,kf5-sonnet-5.10.0-1.fc22,kf5-kglobalaccel-5.10.0-1.fc22,kf5-kio-5.10.0-1.fc22,kf5-kcoreaddons-5.10.0-1.fc22,kf5-kdeclarative-5.10.0-1.fc22,kf5-kplotting-5.10.0-1.fc22,kf5-networkmanager-qt-5.10.0-2.fc22,kf5-kinit-5.10.0-1.fc22,kf5-krunner-5.10.0-1.fc22,kf5-kcmutils-5.10.0-1.fc22,kf5-knotifications-5.10.0-1.fc22,kf5-ki18n-5.10.0-1.fc22,kf5-knewstuff-5.10.0-1.fc22,kf5-kwallet-5.10.0-1.fc22,kf5-kunitconversion-5.10.0-1.fc22,kf5-kded-5.10.0-1.fc22,kf5-kpackage-5.10.0-1.fc22,kf5-kimageformats-5.10.0-1.fc22,kf5-kjs-5.10.0-1.fc22,kf5-kross-5.10.0-1.fc22,kf5-kxmlgui-5.10.0-2.fc22,kf5-kdewebkit-5.10.0-1.fc22,kf5-frameworkintegration-5.10.0-1.fc22,kf5-ktextwidgets-5.10.0-1.fc22,kf5-knotifyconfig-5.10.0-1.fc22,kf5-kactivities-5.10.0-1.fc22,kf5-kguiaddons-5.10.0-1.fc22,kf5-kjobwidgets-5.10.0-1.fc22,kf5-kdoctools-5.10.0-1.fc22,kf5-kcodecs-5.10.0-1.fc22,kf5-kconfig-5.10.0-3.fc22,kf5-kconfigwidgets-5.10.0-1.fc22,kf5-attica-5.10.0-1.fc22,kf5-kauth-5.10.0-1.fc22,kf5-ktexteditor-5.10.0-1.fc22,kf5-solid-5.10.0-1.fc22,kf5-kwidgetsaddons-5.10.0-1.fc22,extra-cmake-modules-5.10.0-1.fc22,kf5-kidletime-5.10.0-1.fc22,kf5-5.10.0-1.fc22,kf5-kdesu-5.10.0-1.fc22,kf5-khtml-5.10.0-1.fc22,kf5-kapidox-5.10.0-1.fc22,kf5-kpeople-5.10.0-1.fc22,kf5-kmediaplayer-5.10.0-1.fc22,kf5-kdbusaddons-5.10.0-1.fc22,kf5-kdesignerplugin-5.10.0-1.fc22,kf5-kservice-5.10.0-1.fc22,kf5-kitemmodels-5.10.0-1.fc22,kf5-kxmlrpcclient-5.10.0-1.fc22,kf5-kiconthemes-5.10.0-1.fc22,kf5-modemmanager-qt-5.10.0-2.fc22,kf5-kcrash-5.10.0-1.fc22,kf5-karchive-5.10.0-1.fc22,kf5-kpty-5.10.0-1.fc22,kf5-threadweaver-5.10.0-1.fc22,kf5-kitemviews-5.10.0-1.fc22,kf5-kparts-5.10.0-1.fc22,kf5-kemoticons-5.10.0-1.fc22,kf5-kbookmarks-5.10.0-1.fc22,kf5-kdnssd-5.10.0-1.fc22,kf5-kjsembed-5.10.0-1.fc22
then log in and leave karma (feedback).

Comment 10 Ed Greshko 2015-05-13 08:39:01 UTC
I am not certain if this bugzilla and fix is meant to address the scenario below.  But if it is suppose to address it, it is not fixed by updating the above packages.

I am using "folder view" as my desktop settings and I'm configured to restore from a "saved session".  I do the following....

1.  login
2.  start konsole, place it in the lower right edge of the screen and set it to "all desktops".  4 virtual desktops in use.
3.  start tbird, place in desktop 2 and align it to the left edge of the screen with a width which brings it into contact with the left edge of konsole.
4.  Go to "leave" and click on "Save Session" and the following files get modified...

[egreshko@f22-tc3 ~]$ find . -cmin -1
./.xsession-errors
./.config
./.config/ksmserverrc
./.config/session
./.config/session/kmix_1028c1d320b210000143113812800000013960009_1431501798_448141
./.config/session/konsole_1028c1d320b210000143122570000000015410009_1431501798_463485
./.cache/plasma_theme_polishedStones_v4.11.kcache

5.  Logout/Login
6.  konsole and tbird are started.  But they are both on Desktop 1 and they are out of position.

Comment 11 Rex Dieter 2015-05-13 18:09:04 UTC
OK, to be clear here (as I understand it), the session management issue is not fully fixed.  What is fixed in these latest patches are kde applications properly saving/restoring configuration as part of session management.  Note: configuration does not include window placement.

An example of what is (should be!) fixed: a saved konsole session will now restore proper size, and shells/tabs that were open.

Comment 12 Stephen Gallagher 2015-05-14 14:02:01 UTC
I'm honestly -1 Freeze Exception here. Desktop state restore isn't something I'd classify as critical to the release (particularly since it can and will be fixed in a post-release update) and the size of this update is particularly terrifying during freeze.

So essentially -1 Freeze Exception for the same reasons I voted nay for the GNOME 3.16.2 megaupdate (BZ #1221384)

Comment 13 Kamil Páral 2015-05-14 17:42:58 UTC
Discussed at the 2015-05-14 blocker review meeting.[1] Voted as RejectedFreezeException - in terms of this specific bug, session management is not commonly used on live images, as there is only one user and use is not usually long-term and persistence is rarely used these days. No other rationale for including this update was provided, but we will consider one if it is submitted soon

[1] http://meetbot.fedoraproject.org/fedora-blocker-review/2015-05-14

Comment 14 George R. Goffe 2015-05-15 14:46:29 UTC
Kamil et. al.

I agree with the logic behind NOT holding live images up for this bug... and probably NOT for the "real" release as well. When I install a brand new release, "yum/dnf update" is almost the VERY next thing I do. So, hold everything up for this bug almost makes no sense. I'm ok with waiting for this fix if it doesn't take too long to publish.

THANKS for all the cool code you guys do!

Regards,

George...

Comment 15 Kevin Kofler 2015-05-18 23:12:03 UTC
Reproposing, this time as a blocker (!), per the criterion "2.4.6 Default application functionality" ("All applications that can be launched using the standard graphical mechanism of a release-blocking desktop after a default installation of that desktop must start successfully and withstand a basic functionality test.") applied to the "Save Screen" menu entry.

Comment 16 Kevin Kofler 2015-05-18 23:13:51 UTC
And I would also like to point out that KF5.10 also includes translation updates, which was given as a justification for approving the GNOME 3.16.2 freeze exception.

Comment 17 Rex Dieter 2015-05-19 00:15:39 UTC
Re: comment #15
The Leave->Save Session menu item does not appear by default.  It's only present if user customizes session settings to "Restore Manually Saved Session".

Comment 18 Jaroslav Reznik 2015-05-19 10:11:48 UTC
(In reply to Kevin Kofler from comment #15)
> Reproposing, this time as a blocker (!), per the criterion "2.4.6 Default
> application functionality" ("All applications that can be launched using the
> standard graphical mechanism of a release-blocking desktop after a default
> installation of that desktop must start successfully and withstand a basic
> functionality test.") applied to the "Save Screen" menu entry.

"but we will consider one if it is submitted soon" and it didn't happen on time, we are really close to RC. As Rex pointed out, it's not default, session restore is not that needed for on Live. I'd be +1 FE last week but not this one unless we would have to slip - it would be nice to smaller 0 day update and this fixed, I'm running latest KF5 but it's just too late (now).

Comment 19 Stephen Gallagher 2015-05-19 13:59:19 UTC
I'm voting -1 blocker here. It's really unfortunate that this doesn't work now, but it's certainly not critical functionality (and as Rex notes, it's not default functionality either).

I'm -1 on Freeze Exception, since right now our plan is to build RC1 today and it (so far) looks like it may actually ship. I really don't want to introduce a potentially-destabilizing cluster of packages for KDE at the last second.

Comment 20 Kevin Fenzi 2015-05-19 14:48:48 UTC
-1 blocker, -1 FE for the same reasons as Stephen.

Comment 21 Petr Schindler 2015-05-19 15:01:05 UTC
-1/-1 from me too. Same reason as provided in comment 19.

Comment 22 Dennis Gilmore 2015-05-19 15:10:20 UTC
-1/-1 from me also.

Comment 23 Fedora Update System 2015-05-26 03:46:03 UTC
kf5-kwindowsystem-5.10.0-1.fc22, kf5-kdelibs4support-5.10.0-1.fc22, kf5-kglobalaccel-5.10.0-1.fc22, kf5-kcoreaddons-5.10.0-1.fc22, kf5-kplotting-5.10.0-1.fc22, kf5-kinit-5.10.0-1.fc22, kf5-kcmutils-5.10.0-1.fc22, kf5-ki18n-5.10.0-1.fc22, kf5-kwallet-5.10.0-1.fc22, kf5-kded-5.10.0-1.fc22, kf5-kimageformats-5.10.0-1.fc22, kf5-kross-5.10.0-1.fc22, kf5-kdewebkit-5.10.0-1.fc22, kf5-ktextwidgets-5.10.0-1.fc22, kf5-kactivities-5.10.0-1.fc22, kf5-kjobwidgets-5.10.0-1.fc22, kf5-kcodecs-5.10.0-1.fc22, kf5-kconfigwidgets-5.10.0-1.fc22, kf5-kauth-5.10.0-1.fc22, kf5-solid-5.10.0-1.fc22, extra-cmake-modules-5.10.0-1.fc22, kf5-5.10.0-1.fc22, kf5-khtml-5.10.0-1.fc22, kf5-kpeople-5.10.0-1.fc22, kf5-kdbusaddons-5.10.0-1.fc22, kf5-kservice-5.10.0-1.fc22, kf5-kxmlrpcclient-5.10.0-1.fc22, kf5-modemmanager-qt-5.10.0-2.fc22, kf5-karchive-5.10.0-1.fc22, kf5-threadweaver-5.10.0-1.fc22, kf5-kparts-5.10.0-1.fc22, kf5-kbookmarks-5.10.0-1.fc22, kf5-kjsembed-5.10.0-1.fc22, kf5-kxmlgui-5.10.0-2.fc22, kf5-kcompletion-5.10.0-1.fc22, kf5-sonnet-5.10.0-1.fc22, kf5-kio-5.10.0-1.fc22, kf5-kdeclarative-5.10.0-1.fc22, kf5-networkmanager-qt-5.10.0-2.fc22, kf5-krunner-5.10.0-1.fc22, kf5-knotifications-5.10.0-1.fc22, kf5-knewstuff-5.10.0-1.fc22, kf5-kunitconversion-5.10.0-1.fc22, kf5-kpackage-5.10.0-1.fc22, kf5-kjs-5.10.0-1.fc22, kf5-frameworkintegration-5.10.0-1.fc22, kf5-knotifyconfig-5.10.0-1.fc22, kf5-kguiaddons-5.10.0-1.fc22, kf5-kdoctools-5.10.0-1.fc22, kf5-attica-5.10.0-1.fc22, kf5-ktexteditor-5.10.0-1.fc22, kf5-kwidgetsaddons-5.10.0-1.fc22, kf5-kidletime-5.10.0-1.fc22, kf5-kdesu-5.10.0-1.fc22, kf5-kapidox-5.10.0-1.fc22, kf5-kmediaplayer-5.10.0-1.fc22, kf5-kdesignerplugin-5.10.0-1.fc22, kf5-kitemmodels-5.10.0-1.fc22, kf5-kiconthemes-5.10.0-1.fc22, kf5-kcrash-5.10.0-1.fc22, kf5-kpty-5.10.0-1.fc22, kf5-kitemviews-5.10.0-1.fc22, kf5-kemoticons-5.10.0-1.fc22, kf5-kdnssd-5.10.0-1.fc22, kf5-kconfig-5.10.0-3.fc22, kf5-plasma-5.10.0-2.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 24 Fedora Update System 2015-05-27 16:06:35 UTC
kf5-knotifyconfig-5.10.0-1.fc20, kf5-kross-5.10.0-1.fc20, kf5-krunner-5.10.0-1.fc20, kf5-kdnssd-5.10.0-1.fc20, kf5-kjs-5.10.0-1.fc20, kf5-ktextwidgets-5.10.0-1.fc20, kf5-karchive-5.10.0-1.fc20, kf5-kded-5.10.0-1.fc20, kf5-khtml-5.10.0-1.fc20, kf5-sonnet-5.10.0-1.fc20, kf5-kdoctools-5.10.0-1.fc20, kf5-kauth-5.10.0-1.fc20, kf5-kmediaplayer-5.10.0-1.fc20, kf5-kbookmarks-5.10.0-1.fc20, kf5-kitemviews-5.10.0-1.fc20, kf5-kcodecs-5.10.0-1.fc20, kf5-attica-5.10.0-1.fc20, kf5-kdesignerplugin-5.10.0-1.fc20, kf5-kdbusaddons-5.10.0-1.fc20, kf5-kdeclarative-5.10.0-1.fc20, extra-cmake-modules-5.10.0-1.fc20, kf5-kcoreaddons-5.10.0-1.fc20, kf5-kcompletion-5.10.0-1.fc20, kf5-ktexteditor-5.10.0-1.fc20, kf5-kpeople-5.10.0-1.fc20, kf5-kdewebkit-5.10.0-1.fc20, kf5-kjobwidgets-5.10.0-1.fc20, kf5-kio-5.10.0-1.fc20, kf5-kcmutils-5.10.0-1.fc20, kf5-kapidox-5.10.0-1.fc20, kf5-knewstuff-5.10.0-1.fc20, kf5-kxmlrpcclient-5.10.0-1.fc20, kf5-kdelibs4support-5.10.0-1.fc20, kf5-frameworkintegration-5.10.0-1.fc20, kf5-solid-5.10.0-1.fc20, kf5-modemmanager-qt-5.10.0-2.fc20, kf5-kwindowsystem-5.10.0-1.fc20, kf5-networkmanager-qt-5.10.0-1.fc20, kf5-kinit-5.10.0-1.fc20, kf5-kguiaddons-5.10.0-1.fc20, kf5-threadweaver-5.10.0-1.fc20, kf5-ki18n-5.10.0-1.fc20, kf5-kiconthemes-5.10.0-1.fc20, kf5-kplotting-5.10.0-1.fc20, kf5-kemoticons-5.10.0-1.fc20, kf5-kactivities-5.10.0-1.fc20, kf5-kservice-5.10.0-1.fc20, kf5-kconfigwidgets-5.10.0-1.fc20, kf5-kcrash-5.10.0-1.fc20, kf5-kpackage-5.10.0-1.fc20, kf5-5.10.0-1.fc20, kf5-knotifications-5.10.0-1.fc20, kf5-kunitconversion-5.10.0-1.fc20, kf5-kwidgetsaddons-5.10.0-1.fc20, kf5-kdesu-5.10.0-1.fc20, kf5-kjsembed-5.10.0-1.fc20, kf5-kitemmodels-5.10.0-1.fc20, kf5-kimageformats-5.10.0-1.fc20, kf5-kglobalaccel-5.10.0-1.fc20, kf5-kidletime-5.10.0-1.fc20, kf5-kpty-5.10.0-1.fc20, kf5-kparts-5.10.0-1.fc20, kf5-kwallet-5.10.0-1.fc20, kf5-kxmlgui-5.10.0-2.fc20, kf5-kconfig-5.10.0-3.fc20, kf5-plasma-5.10.0-2.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 25 Fedora Update System 2015-05-27 16:16:29 UTC
kf5-frameworkintegration-5.10.0-1.fc21, kf5-ktextwidgets-5.10.0-1.fc21, kf5-kross-5.10.0-1.fc21, kf5-kglobalaccel-5.10.0-1.fc21, kf5-kservice-5.10.0-1.fc21, kf5-kguiaddons-5.10.0-1.fc21, kf5-knotifications-5.10.0-1.fc21, kf5-solid-5.10.0-1.fc21, kf5-kjsembed-5.10.0-1.fc21, kf5-modemmanager-qt-5.10.0-2.fc21, kf5-kjs-5.10.0-1.fc21, kf5-kplotting-5.10.0-1.fc21, kf5-kcrash-5.10.0-1.fc21, kf5-khtml-5.10.0-1.fc21, kf5-kdewebkit-5.10.0-1.fc21, kf5-kwidgetsaddons-5.10.0-1.fc21, kf5-kdelibs4support-5.10.0-1.fc21, kf5-knewstuff-5.10.0-1.fc21, kf5-kdeclarative-5.10.0-1.fc21, kf5-attica-5.10.0-1.fc21, kf5-kapidox-5.10.0-1.fc21, kf5-threadweaver-5.10.0-1.fc21, kf5-kcompletion-5.10.0-1.fc21, kf5-kpty-5.10.0-1.fc21, kf5-kidletime-5.10.0-1.fc21, kf5-kxmlrpcclient-5.10.0-1.fc21, kf5-ki18n-5.10.0-1.fc21, kf5-kdesignerplugin-5.10.0-1.fc21, kf5-kpackage-5.10.0-1.fc21, kf5-kdbusaddons-5.10.0-1.fc21, kf5-kparts-5.10.0-1.fc21, kf5-kdesu-5.10.0-1.fc21, kf5-kmediaplayer-5.10.0-1.fc21, kf5-sonnet-5.10.0-1.fc21, kf5-kded-5.10.0-1.fc21, kf5-kcmutils-5.10.0-1.fc21, kf5-knotifyconfig-5.10.0-1.fc21, kf5-kjobwidgets-5.10.0-1.fc21, kf5-kdnssd-5.10.0-1.fc21, kf5-kunitconversion-5.10.0-1.fc21, kf5-kpeople-5.10.0-1.fc21, kf5-kdoctools-5.10.0-1.fc21, kf5-kbookmarks-5.10.0-1.fc21, kf5-kimageformats-5.10.0-1.fc21, kf5-ktexteditor-5.10.0-1.fc21, kf5-kio-5.10.0-1.fc21, kf5-kactivities-5.10.0-1.fc21, kf5-kiconthemes-5.10.0-1.fc21, kf5-kwallet-5.10.0-1.fc21, kf5-kitemmodels-5.10.0-1.fc21, kf5-kauth-5.10.0-1.fc21, kf5-karchive-5.10.0-1.fc21, extra-cmake-modules-5.10.0-1.fc21, kf5-kcodecs-5.10.0-1.fc21, kf5-kwindowsystem-5.10.0-1.fc21, kf5-krunner-5.10.0-1.fc21, kf5-kcoreaddons-5.10.0-1.fc21, kf5-networkmanager-qt-5.10.0-1.fc21, kf5-kitemviews-5.10.0-1.fc21, kf5-5.10.0-1.fc21, kf5-kxmlgui-5.10.0-2.fc21, kf5-kconfigwidgets-5.10.0-1.fc21, kf5-kemoticons-5.10.0-1.fc21, kf5-kinit-5.10.0-1.fc21, kf5-kconfig-5.10.0-3.fc21, kf5-plasma-5.10.0-2.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 26 Rex Dieter 2015-06-09 09:09:58 UTC
*** Bug 1228956 has been marked as a duplicate of this bug. ***

Comment 27 George R. Goffe 2015-06-09 13:27:34 UTC
Rex,

I have tested the Leave->Save session twice with konsoles and xosview. ALL appear in their requested desktops. Xosview still doesn't "remember" it's invocation parameters though.

George...

Comment 28 Rex Dieter 2015-06-09 13:38:16 UTC
Does xosview support session management?  (I'm guessing no)

Comment 29 Rex Dieter 2015-06-09 13:41:13 UTC
(big hint is that it doesn't link libSM)

Comment 30 Ed Greshko 2015-06-09 14:53:20 UTC
Nothing is fixed for me.  I have 4 virtual desktops.  konsole placed in the lower right of screen on pinned to all desktops and chrome browser on VD2 on the left side of the display.  Save the session.  Logout/Login.  konsole starts on VD1 only and in the upper left.  Chrome is not restarted.

Comment 31 Rex Dieter 2015-06-09 15:02:53 UTC
nothing?  konsole is restarting (that's what *this* bug was about initially).

kwin-5.3.1 + (recentish) qt5-qtbase-5.4.2 include patches for restoring placement, see other related updates:

plasma-5.3.1: https://admin.fedoraproject.org/updates/FEDORA-2015-9118

qt-5.4.2: https://admin.fedoraproject.org/updates/FEDORA-2015-9483

and followup qt5-qtbase refresh: https://admin.fedoraproject.org/updates/FEDORA-2015-9483


If you get all of those, then things should be working reasonably well (much better than at f22 GA release, where session management was essentially absent).


Can't speak for chrome, I can't verify if it supports full session management or not (though offhand, I don't see it linking libSM, so maybe not).  there's probably a bug here somewhere.

Comment 32 Ed Greshko 2015-06-09 15:26:34 UTC
OK, so konsole gets restated. (For me it had been, sometimes) But in the wrong position and not on all desktops as it was saved.  

If I understand, for that fix I have to wait for, or manually install, the other items you mention.  Will have to look into that tomorrow.

Comment 33 Rex Dieter 2015-06-09 15:40:28 UTC
Yes... this is all definitely an ongoing work in progress, that involved several different components, so far we have: kf5-kxmlgui, kf5-kconfig, qt5-qtbase, kwin

kudos to _stefanb, for contributing much of the detective-work, and most of the code/patches we're testing, recent examples include:

https://git.reviewboard.kde.org/r/123580/
https://bugreports.qt.io/browse/QTBUG-45484
https://bugreports.qt.io/browse/QTBUG-46310

Comment 34 George R. Goffe 2015-06-10 02:11:03 UTC
Rex,

Xosview does NOT link libSM.

Several years ago xosview would remember it's invocation parameters but I don't recall which release. It was early Fedora Core.

Konsole restarts now in the "right" VD AND with ALL the tabs.

Thanks to EVERYONE who is working their buns off.

I'm looking forward to the restart with this latest group of fixes... All 73.

Thanks again,

George...


Note You need to log in before you can comment on or make changes to this bug.