Bug 121102 - up2date not showing accurate packages
up2date not showing accurate packages
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: up2date (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
Fanny Augustin
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-17 02:17 EDT by sebastian
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-26 14:48:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description sebastian 2004-04-17 02:17:34 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040312

Description of problem:
several issues, hope its ok to listen them all in one submit.

- packages that aren't installed on the system appear on up2date. this
is quite a pain browsing though 200+ packages to see what updates are
available to packages that are actually installed on the system. isnt
it more logical to only show me updates to packages the system has
installed, rather than all available packages?

- when trying to update up2date as a non-root user and it prompts you
to enter the password up2date exits (doesn't do anything) after you
enter it. 

- when trying to update up2date in terminal it returns:
"Could not set exec context to root:rpm_t:sysadm_r." despite doing:

su root
<password>

seems to be very buggy..


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. su root
2. up2date

    

Additional info:

Note You need to log in before you can comment on or make changes to this bug.