Bug 121103 - pan fails to do many tasks
pan fails to do many tasks
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: pan (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jens Petersen
:
Depends On:
Blocks: FC2Blocker
  Show dependency treegraph
 
Reported: 2004-04-17 03:38 EDT by Nathan G. Grennan
Modified: 2014-01-21 17:49 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-07 12:27:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nathan G. Grennan 2004-04-17 03:38:46 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7b)
Gecko/20040320 Galeon/1.3.14

Description of problem:
The first thing I noticed is it the popup to setup the settings for
the first time. Yet I have a ~/.pan directory and it loaded the other
settings from it after it loaded.

The second thing I noticed was that when I went into a news group it
only listed 1-2 messages. When I views the list of of results of
actions  it had some error, "Glib  - gnode.c: line 315
(g_node_insert_before): assertion `G_NODE_IS_ROOT (node)' failed".

The third thing I noticed is when I tried renaming ~/.pan and then
setting up a new server. It would ask if I wanted to download the list
of all newsgroups. I would click yes and it would not download the
list, but just add it to the queue in the task manager.

Note pan-0.14.2-3 works fine.

Version-Release number of selected component (if applicable):
pan-0.14.2-5

How reproducible:
Always

Steps to Reproduce:
1. Start pan
2. Go into newsgroup and find 1-2 messages it in
3. Look in results of actions and file error message.
4. Close pan
5. mv ~/.pan ~/pan
6. Start pan
7. Add news server
8. Answer yes to question about downloading list of all newsgroups
9. Open Task Manager

Actual Results:  See bugs

Expected Results:  None of the seen bugs

Additional info:

I suspect all of it is the result of one of the patches added after
0.14.2-3.
Comment 1 Kaj J. Niemi 2004-04-17 22:24:18 EDT
Yeah.. pan 0.14.2-5 does funky things for me as well. It seems to
corrupt existing indexes, downgrading to 0.14.2-4 leaves all existing
groups broken.


Comment 2 Jens Petersen 2004-04-20 02:17:35 EDT
Thanks for the report.  Presumably it is due to one of these two changes
in -5:

- add pan-0.14.2-gmime-crash-120007.patch to fix crashing
  (confushion@comcast.net)
- add pan-0.14.2-gcc34.patch to fix building with newer gcc (Jeff Law)

If you have time to find out which one of the two patches is breaking
things that would be much appreciated.
Comment 3 Jens Petersen 2004-04-20 02:52:23 EDT
There was feedback in bug 119299 that the former patch seems to work
ok, so could it be the latter?
Comment 4 Kaj J. Niemi 2004-04-20 04:42:09 EDT
Correct, pan built without Patch 8 (pan-0.14.2-gcc34.patch) works just
dandy.
Comment 5 Jens Petersen 2004-04-20 06:58:31 EDT
Agreed, so I'm disabling the patch in pan-0.14.2-6.
Comment 6 Seth Vidal 2004-05-07 12:27:58 EDT
apparently fixed, closing, reopen if it comes back.

Note You need to log in before you can comment on or make changes to this bug.