Bug 1211040 - vino segfaults on Wayland Gnome
Summary: vino segfaults on Wayland Gnome
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: vino
Version: rawhide
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Søren Sandmann Pedersen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
: 1217321 1277270 1280274 (view as bug list)
Depends On:
Blocks: WaylandRelated
TreeView+ depends on / blocked
 
Reported: 2015-04-12 12:39 UTC by Pedro Francisco
Modified: 2017-01-11 14:26 UTC (History)
15 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2016-01-26 07:49:14 UTC


Attachments (Terms of Use)
File: backtrace (18.89 KB, text/plain)
2016-01-24 22:29 UTC, Ben Liblit
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Bugzilla 761120 None None None 2016-01-26 07:49 UTC
Red Hat Bugzilla 1394599 None None None Never

Internal Trackers: 1394599

Description Pedro Francisco 2015-04-12 12:39:08 UTC
Description of problem:
vino segfaults on Wayland Gnome


Version-Release number of selected component (if applicable):
vino-3.16.0-1.fc22.x86_64


How reproducible:
Always


Steps to Reproduce:
1. Configure Gnome for remote screen sharing
2. Watch dmesg for segfaults



Actual results:
kernel: vino-server[1920]: segfault at 400 ip 00007feff68880a9 sp 00007ffdcc83a630 error 4 in libX11.so.6.3.0[7feff684f000+13b000]


Expected results:
Should work or option should not be possible to enable or vino should support SPICE on Wayland and drop VNC. Pick one :)

Comment 1 fujiwara 2015-04-30 06:13:49 UTC
*** Bug 1217321 has been marked as a duplicate of this bug. ***

Comment 2 fujiwara 2015-04-30 06:15:58 UTC
This does not happen in non-Wayland GNOME but GNOME Wayland.

% /usr/libexec/vino-server

Program received signal SIGSEGV, Segmentation fault.
#0  0x000000000088dae0 in  ()
#1  0x00000033932390ab in XQueryExtension () at /lib64/libX11.so.6
#2  0x00000033b5203066 in find_display () at /lib64/libXtst.so.6
#3  0x00000033b5203242 in XTestQueryExtension () at /lib64/libXtst.so.6
#4  0x000000000040dee9 in vino_input_init ()
#5  0x000000000040e693 in name_acquired ()
#6  0x0000003392ad98f6 in do_call () at /lib64/libgio-2.0.so.0
#7  0x0000003392ad9b38 in request_name_cb () at /lib64/libgio-2.0.so.0
#8  0x0000003392a74b67 in g_simple_async_result_complete ()
    at /lib64/libgio-2.0.so.0
#9  0x0000003392ad18d2 in g_dbus_connection_call_done ()
    at /lib64/libgio-2.0.so.0
#10 0x0000003392a74b67 in g_simple_async_result_complete ()
    at /lib64/libgio-2.0.so.0
#11 0x0000003392a74bc9 in complete_in_idle_cb () at /lib64/libgio-2.0.so.0
#12 0x0000003390e4a0ba in g_main_context_dispatch () at /lib64/libglib-2.0.so.0
#13 0x0000003390e4a450 in g_main_context_iterate.isra ()
    at /lib64/libglib-2.0.so.0
#14 0x0000003390e4a772 in g_main_loop_run () at /lib64/libglib-2.0.so.0
#15 0x000000000040b2fa in main ()

Comment 3 srakitnican 2015-11-03 21:38:32 UTC
Fedora 23 have the same issue:

[  +0,000007] vino-server[2489]: segfault at 7fb200005a00 ip 00007fb2fb7bd0e9 sp 00007fffb89355d0 error 4 in libX11.so.6.3.0[7fb2fb784000+13a000]

Comment 4 Ondrej Holy 2015-11-11 11:41:58 UTC
*** Bug 1280274 has been marked as a duplicate of this bug. ***

Comment 5 Ondrej Holy 2015-11-11 11:42:00 UTC
*** Bug 1277270 has been marked as a duplicate of this bug. ***

Comment 6 Ben Liblit 2016-01-24 22:29:36 UTC
Another user experienced a similar problem:

Had just started a "GNOME on Wayland" session.

reporter:       libreport-2.6.3
backtrace_rating: 4
cmdline:        /usr/libexec/vino-server
crash_function: _XGetRequest
executable:     /usr/libexec/vino-server
global_pid:     2624
kernel:         4.2.8-300.fc23.x86_64
package:        vino-3.18.1-1.fc23
reason:         vino-server killed by SIGSEGV
runlevel:       N 5
type:           CCpp
uid:            29364

Comment 7 Ben Liblit 2016-01-24 22:29:40 UTC
Created attachment 1117726 [details]
File: backtrace

Comment 8 Daniel 2016-01-25 00:21:21 UTC
I think I’m that other user that Ben was talking about.

The crash happens every time I start a GNOME on Wayland session. 100% reproducible. System Settings: Sharing: Screen Sharing is set to Active. Doesn’t happen with non-Wayland sessions.

Comment 9 Daniel 2016-01-25 21:48:42 UTC
Another user experienced a similar problem:

Logged in to the system after a forceful restart.

reporter:       libreport-2.6.3
backtrace_rating: 4
cmdline:        /usr/libexec/vino-server
crash_function: XQueryExtension
executable:     /usr/libexec/vino-server
global_pid:     2696
kernel:         4.3.3-301.fc23.x86_64
package:        vino-3.18.1-1.fc23
reason:         vino-server killed by SIGSEGV
runlevel:       N 5
type:           CCpp
uid:            1000

Comment 10 Ondrej Holy 2016-01-26 07:54:04 UTC
I've filed upstream bug report for it:
https://bugzilla.gnome.org/show_bug.cgi?id=761120

Vino is not working under wayland, disable remote sharing in control center to avoid those segfaults.

Developers are working on a screen sharing for wayland already, see:
https://blogs.gnome.org/mclasen/2016/01/22/a-wayland-status-update-2/

Comment 11 John Webb 2016-02-27 12:59:13 UTC
Similar problem has been detected:

Immediately after reaching main desktop screen after booting the Gnome on Wayland

reporter:       libreport-2.6.4
backtrace_rating: 4
cmdline:        /usr/libexec/vino-server
crash_function: _XGetRequest
executable:     /usr/libexec/vino-server
global_pid:     5088
kernel:         4.3.5-300.fc23.x86_64
package:        vino-3.18.1-1.fc23
reason:         vino-server killed by SIGSEGV
runlevel:       N 5
type:           CCpp
uid:            1000

Comment 12 Christian Klomp 2017-01-11 14:26:59 UTC
Easiest work around (except for disabling the feature altogether, i.e. for people that switch between Wayland and X11) seems to be to disable the systemd user service and start vino via xdg autostart.

# disable vino systemd user service
$ systemctl --user mask vino-server
Created symlink /home/user/.config/systemd/user/vino-server.service → /dev/null.

# create .desktop file for xdg autostart
$ cat <<EOF > ~/.config/autostart/vino-server.desktop
[Desktop Entry]
Name=vino-server
Comment=Work around for only starting vino-server on X11 sessions
Exec=bash -c '[[ \$XDG_SESSION_TYPE == x11 ]] && /usr/libexec/vino-server'
Encoding=UTF-8
Type=Application
X-GNOME-Autostart-enabled=true
EOF


Note You need to log in before you can comment on or make changes to this bug.