Bug 1211098 - ld.so crash when audit modules provide path
Summary: ld.so crash when audit modules provide path
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: glibc
Version: 6.6
Hardware: Unspecified
OS: Linux
high
high
Target Milestone: rc
: ---
Assignee: Florian Weimer
QA Contact: Arjun Shankar
Marc Muehlfeld
URL:
Whiteboard:
Depends On:
Blocks: 1172231 1271375
TreeView+ depends on / blocked
 
Reported: 2015-04-13 01:48 UTC by Kazu Yoshida
Modified: 2020-02-14 17:29 UTC (History)
8 users (show)

Fixed In Version: glibc-2.12-1.176.el6
Doc Type: Release Note
Doc Text:
The dynamic linker (ld.so) does not fail anymore when an audit module provides a DSO path Previously, when an audit module provided an alternate DSO (dynamic shared object) path, the *ld.so* dynamic linker terminated unexpectedly with a segmentation fault. This update addresses the bug, and now the dynamic linker keeps track of the original DSO path for future reference and does not fail anymore.
Clone Of:
: 1211100 (view as bug list)
Environment:
Last Closed: 2016-05-10 21:26:33 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 1412683 None None None Never
Red Hat Product Errata RHBA-2016:0834 normal SHIPPED_LIVE glibc bug fix update 2016-05-10 22:41:39 UTC
Sourceware 18251 None None None Never

Description Kazu Yoshida 2015-04-13 01:48:28 UTC
Description of problem:

When audit modules provide path as the return value of the la_objsearch calls the name replaces whatever ld.so uses to find the DSO.  If the target DSO has an SONAME this is the SONAME. As a result the SONAME is not in the list by which the DSO is known. This usually is no problem. It becomes a problem when the SONAME is needed afterwards. One example is checking symbol and DSO versions.

Version-Release number of selected component (if applicable):
RHEL6 glibc

How reproducible:
As below

Steps to Reproduce:
ld.so crash when below both  conditions are met
1) audit modules provide path
2) dependent libary(ie what is recorded in NEEDED section) has dso versioning

Actual results:
ld.so crash

Expected results:
ld.so not to crash

Additional info:
Upstream bugzilla
https://sourceware.org/bugzilla/show_bug.cgi?id=18251

Comment 1 Kazu Yoshida 2015-04-13 01:57:37 UTC
glibc-2.12-1.149.el6_6.5

Comment 9 Florian Weimer 2015-11-06 13:20:26 UTC
Ulrich's patch posted upstream:

  https://sourceware.org/ml/libc-alpha/2015-11/msg00112.html

Comment 17 errata-xmlrpc 2016-05-10 21:26:33 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0834.html


Note You need to log in before you can comment on or make changes to this bug.