Bug 121120 - *.pyc files are not deleted at uninstalling
Summary: *.pyc files are not deleted at uninstalling
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: system-config-boot   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-04-17 15:54 UTC by Robert Scheck
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-21 14:12:31 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Robert Scheck 2004-04-17 15:54:45 UTC
Description of problem:
At uninstalling the rpm the *.pyc files are not deleted at 
/usr/share/system-config-boot/

Version-Release number of selected component (if applicable):
system-config-boot-0.2.5-1

How reproducible & Steps to Reproduce:
Every time and more is described above.

Actual results:
The following in the spec file solves it:

--- snipp ---
%preun
if [ -d %{_datadir}/%{name} ] ; then
  rm -rf %{_datadir}/%{name}/*.pyc
fi
--- snapp ---

Expected results:
That *.pyc files are deleted

Comment 1 Harald Hoyer 2004-04-21 14:12:31 UTC
huh? the .pyc files are part of the rpm...

$ rpm -qf /usr/share/system-config-boot/*.pyc
system-config-boot-0.2.5-1
system-config-boot-0.2.5-1

# rpm -e system-config-boot-0.2.5-1
[root@jever root]# ll /usr/share/system-config-boot/
ls: /usr/share/system-config-boot/: File or Directory not found


Comment 2 Robert Scheck 2004-04-21 14:19:45 UTC
Oh sorry you're right, but system-config-boot seems to be an exception, 
because there are other system-* packages where the *.pyc files are
not removed...


Note You need to log in before you can comment on or make changes to this bug.