Bug 1211221 - Any operation that relies on fd->flags may not work on anonymous fds
Summary: Any operation that relies on fd->flags may not work on anonymous fds
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: core
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Raghavendra Talur
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-04-13 10:51 UTC by Raghavendra Talur
Modified: 2016-06-16 12:50 UTC (History)
2 users (show)

Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-06-16 12:50:21 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Raghavendra Talur 2015-04-13 10:51:31 UTC
Description of problem:

We do not set the same flags to anonymous fd that posix uses to open
a anonymous fd in the backend. If there are any xlators which rely on
these flags for their operation they may not work well.

Add proper flags to anonymous fds at the time of their creation.

Comment 1 Anand Avati 2015-04-13 11:51:51 UTC
REVIEW: http://review.gluster.org/10219 (libglusterfs: Even anonymous fds must have fd->flags set) posted (#1) for review on master by Raghavendra Talur (rtalur@redhat.com)

Comment 2 Anand Avati 2015-04-27 13:06:39 UTC
REVIEW: http://review.gluster.org/10219 (libglusterfs: Even anonymous fds must have fd->flags set) posted (#2) for review on master by Raghavendra Talur (rtalur@redhat.com)

Comment 3 Anand Avati 2015-04-28 06:35:13 UTC
REVIEW: http://review.gluster.org/10219 (libglusterfs: Even anonymous fds must have fd->flags set) posted (#3) for review on master by Raghavendra Talur (rtalur@redhat.com)

Comment 4 Anand Avati 2015-07-20 10:48:22 UTC
COMMIT: http://review.gluster.org/10219 committed in master by Raghavendra G (rgowdapp@redhat.com) 
------
commit 175f1737fb6fe9450702556b24bf395bac97cef1
Author: Raghavendra Talur <rtalur@redhat.com>
Date:   Mon Apr 13 17:05:44 2015 +0530

    libglusterfs: Even anonymous fds must have fd->flags set
    
    We do not set the same flags to anonymous fd that posix uses to open
    an anonymous fd in the backend. If there are any xlators which rely on
    these flags for their operation they may not work well.
    
    Add proper flags to anonymous fds at the time of their creation and
    refer to them for subsequent operations.
    
    Change-Id: Ia99b7ea7d38839f099c7b4aae3c7ead123bc8c67
    BUG: 1211221
    Signed-off-by: Raghavendra Talur <rtalur@redhat.com>
    Reviewed-on: http://review.gluster.org/10219
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: soumya k <skoduri@redhat.com>
    Reviewed-by: Poornima G <pgurusid@redhat.com>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Rajesh Joseph <rjoseph@redhat.com>
    Reviewed-by: Niels de Vos <ndevos@redhat.com>
    Reviewed-by: Raghavendra Bhat <raghavendra@redhat.com>
    Reviewed-by: Raghavendra G <rgowdapp@redhat.com>

Comment 5 Niels de Vos 2016-06-16 12:50:21 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.