Bug 1211231 - [RFE] enable SPICE/QXL support for Windows 8/2012 even without the QXL drivers
Summary: [RFE] enable SPICE/QXL support for Windows 8/2012 even without the QXL drivers
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine
Version: 3.5.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ovirt-3.6.0-rc
: 3.6.0
Assignee: jniederm
QA Contact: Nisim Simsolo
URL:
Whiteboard:
Depends On:
Blocks: 1213701 1217494
TreeView+ depends on / blocked
 
Reported: 2015-04-13 11:31 UTC by Michal Skrivanek
Modified: 2016-03-09 21:02 UTC (History)
22 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
With this enhancement, users can connect to Windows 8 and Windows 2012 virtual machines using the SPICE protocol without QXL drivers. Limitations include: no multiple monitors, graphics are not accelerated, etc.
Clone Of:
: 1217494 (view as bug list)
Environment:
Last Closed: 2016-03-09 21:02:28 UTC
oVirt Team: Virt
sherold: Triaged+


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:0376 normal SHIPPED_LIVE Red Hat Enterprise Virtualization Manager 3.6.0 2016-03-10 01:20:52 UTC
oVirt gerrit 40333 master MERGED core: SPICE with QXL enabled for Windows 8/2012 Never
Red Hat Knowledge Base (Solution) 294843 None None None Never

Description Michal Skrivanek 2015-04-13 11:31:09 UTC
Many people report significant improvement in performance of SPICE console even without QXL drivers.
Let's enable it!

(also see bug 957827)

Comment 1 Scott Herold 2015-04-14 07:29:22 UTC
Providing PM Ack to resolve this nominal change

Comment 2 Tomas Pelka 2015-04-29 12:37:15 UTC
I think this is a logical step I would support it but there is one missing piece and that is support for new wins in qxl. I mean the API for drivers has changed so it is probably a better question for spice-devels if they would have manpower for this enablement from spice point of view.

Spice QE should have capacity to test.

cc-ing David Blechter too.

-Tom

Comment 3 Tomas Pelka 2015-04-29 12:56:13 UTC
(In reply to Tomas Pelka from comment #2)
> I think this is a logical step I would support it but there is one missing
> piece and that is support for new wins in qxl. I mean the API for drivers
> has changed so it is probably a better question for spice-devels if they
> would have manpower for this enablement from spice point of view.
> 
> Spice QE should have capacity to test.
> 
> cc-ing David Blechter too.
> 
> -Tom

Sorry I've misread the bz, does this "without QXL"  support mean no advanced functions like multimonitor and high res would be expected?

-Tom

Comment 4 Richard W.M. Jones 2015-04-29 13:40:09 UTC
Yes, only basic unaccelerated framebuffer would be expected to work.

Comment 5 Michal Skrivanek 2015-04-29 14:50:17 UTC
note we plan to use the QXL card without the driver, not cirrus.
It's the same as for the other Windows OSes, but we need to note in documentation that without drivers it provides less features/less performance

Comment 6 Tomas Pelka 2015-04-29 18:46:46 UTC
As I mentioned in the original e-mail we are not planing to include win 8 and win 2012 into our test matrix even with low prio. As the spice support is not planed in 3.6.

Having said that I also need to add that spice-qe cant commit to take over thist testing.

Sorry
-Tom

Comment 7 Ilanit Stein 2015-04-30 13:29:22 UTC
Testing scope (Michal Skrivanek):

It used to work like that in 3.4 so from spice perspective it doesn't need much Rhev qe should just test the effect of UI settings, that spice client can be opened and shows something on W2012/8

Comment 9 David Blechter 2015-04-30 14:19:19 UTC
(In reply to Michal Skrivanek from comment #0)
> Many people report significant improvement in performance of SPICE console
> even without QXL drivers.
> Let's enable it!
> 
> (also see bug 957827)

And what about spice-vdagent?

Comment 10 Tomas Pelka 2015-04-30 14:37:16 UTC
(In reply to Ilanit Stein from comment #7)
> Testing scope (Michal Skrivanek):
> 
> It used to work like that in 3.4 so from spice perspective it doesn't need
> much Rhev qe should just test the effect of UI settings, that spice client
> can be opened and shows something on W2012/8

I've talked with Michal and we should be able to provide some initial and sanity testing of VGA mode. So should be fine from our POV.

-Tom

Comment 11 Michal Skrivanek 2015-05-05 08:23:03 UTC
(In reply to David Blechter from comment #9)
> And what about spice-vdagent?

djasa confirmed it works ok, it's useful for copy&paste if nothing else.
we used to have the same configuration in 3.4 till we explicitly disabled SPICE in 3.4.z, there were no complaints about anything AFAIK

Lev, does the installer still install spice tools, even when we don't have qxl drivers?

Comment 12 Lev Veyde 2015-05-05 08:43:42 UTC
(In reply to Michal Skrivanek from comment #11)
> (In reply to David Blechter from comment #9)
> > And what about spice-vdagent?
> 
> djasa confirmed it works ok, it's useful for copy&paste if nothing else.
> we used to have the same configuration in 3.4 till we explicitly disabled
> SPICE in 3.4.z, there were no complaints about anything AFAIK
> 
> Lev, does the installer still install spice tools, even when we don't have
> qxl drivers?

Hi Michal,

Yes, we currently install the Spice Agent (vdagent) for all Windows versions, including the ones that we currently don't have a Spice QXL driver for.

Comment 14 Richard W.M. Jones 2015-07-13 09:10:07 UTC
Hi Michal, I have a question about this from virt-v2v point of view:

In virt-v2v we can convert many different Windows versions, including
Win2003 which has no QXL drivers.

Virt-v2v always selects QXL for RHEV output, and that was considered
a bug (bug 1213701):
it would be possible for virt-v2v to detect if the guest can do QXL
or Cirrus and write either <rasd:Device>qxl</rasd:Device> or
<rasd:Device>cirrus</rasd:Device>, but it never did this for RHEV output.

The current bug enables framebuffer-only QXL for Windows >= 8, but
doesn't consider older Windows that don't have QXL support (Win2003).

Questions:

Should virt-v2v continue only using QXL for RHEV?

Or should RHEV enable QXL framebuffer-only everywhere?  (Is
there any point using Cirrus if we have QXL)

If we _don't_ do that (ie. if we really fix bug 1213701), then virt-v2v
would need to do something complex like:

if (linux)
  // who knows?
else
  if (windows has QXL drivers || windows > 7)
    use QXL
  else # eg windows 2003
    use Cirrus

Comment 15 Michal Skrivanek 2015-07-13 14:51:22 UTC
That bug existed because of the original decision to block QXL in Windows 8/2012 guests in RHEV-M. 
Here in this bug we removed that restriction and now allow QXL without drivers to be used (it is deemed stable and actually still faster than cirrus even without proper qxl drivers)

I think we can just close that bug 1213701. One can always change it once it's imported...in v2v integration we only allow name, target SD and entwrok mapping to be defined up front, everything else needs to be changed within UI (or API) afterwards.
We didn't want to add too much UI complexity here as the "New VM" dialog is very complex and we want to support multiple VM import - so we want to keep the list of things you need to set before the conversion at minimum, and sort it out only after conversion finishes.
(OTOH it would greatly help to have a "mass edit" feature in UI, as now you have to do it one by one or use the API)

Comment 17 errata-xmlrpc 2016-03-09 21:02:28 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0376.html


Note You need to log in before you can comment on or make changes to this bug.