Bug 121131 - foomatic 3.0.1-2 needs perl 5.8.3
foomatic 3.0.1-2 needs perl 5.8.3
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: foomatic (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks: FC2Target
  Show dependency treegraph
 
Reported: 2004-04-17 15:38 EDT by Göran Uddeborg
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-29 23:30:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Göran Uddeborg 2004-04-17 15:38:36 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040312

Description of problem:
Foomatic places files in /usr/lib/perl5/vendor_perl/5.8.3/... but it
only requires perl >= 3:5.8.1.  Perl 5.8.1 doesn't search 5.8.3
directories.


Version-Release number of selected component (if applicable):
foomatic-3.0.1-2

How reproducible:
Always

Steps to Reproduce:
1. Arrange perl-5.8.1-92 and foomatic-3.0.1-2 (rpm won't have any
objections to this configuration)
2. Run e.g. "foomatic-ppdfile -h"

Actual Results:  Can't locate Foomatic/Defaults.pm in @INC (@INC
contains: /usr/lib/perl5/5.8.1/i386-linux-thread-multi
/usr/lib/perl5/5.8.1
/usr/lib/perl5/site_perl/5.8.1/i386-linux-thread-multi
/usr/lib/perl5/site_perl/5.8.1 /usr/lib/perl5/site_perl
/usr/lib/perl5/vendor_perl/5.8.1/i386-linux-thread-multi
/usr/lib/perl5/vendor_perl/5.8.1
/usr/lib/perl5/vendor_perl/5.8.0/i386-linux-thread-multi
/usr/lib/perl5/vendor_perl/5.8.0 /usr/lib/perl5/vendor_perl
/usr/lib/perl5/5.8.1/i386-linux-thread-multi /usr/lib/perl5/5.8.1 .)
at /usr/bin/foomatic-ppdfile line 3.
BEGIN failed--compilation aborted at /usr/bin/foomatic-ppdfile line 3.

Expected Results:  Help message for foomatic-ppdfile.

Additional info:

Presumably, foomatic should require perl >= 3:5.8.3.
Comment 1 Warren Togami 2004-04-18 14:48:03 EDT
This is not a bug for FC2 per se, but it is a case where we should use
the new perl virtual provides dependency in order to avoid unsupported
mixes of packages like this. 
Comment 2 Göran Uddeborg 2004-04-18 15:33:42 EDT
Looking at what the new perl provides, I assume you mean that foomatic
should require

perl(:MODULE_COMPAT_5.8.3)

That makes sense, it is better than pointing to package versions.

(I would still call it a bug in foomatic that it doesn't require this.
 But that philosophical question doesn't have that much practical
impact as long as we agree what needs to be done. :-)
Comment 3 Tim Waugh 2004-04-19 06:58:59 EDT
Well in fact it requires a version of perl with module compatibility
with the version it was built against in the first place.  So it needs
to determine that at build time, not at spec-edit time.

I've added this line to 3.0.1-3:

Requires: %(eval 'perl -V:version'; echo "perl(:MODULE_COMPAT_$version)")

Note You need to log in before you can comment on or make changes to this bug.