Bug 1211330 - Storage migration removes snapshot preview from the storage
Summary: Storage migration removes snapshot preview from the storage
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: vdsm
Version: 3.5.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ovirt-3.6.0-rc
: 3.6.0
Assignee: Tal Nisan
QA Contact: Ori Gofen
URL:
Whiteboard:
Depends On:
Blocks: 1217947
TreeView+ depends on / blocked
 
Reported: 2015-04-13 15:58 UTC by Roman Hodain
Modified: 2019-05-20 11:45 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1217947 (view as bug list)
Environment:
Last Closed: 2016-03-09 19:36:26 UTC
oVirt Team: Storage
Target Upstream Version:
ylavi: Triaged+


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:0362 normal SHIPPED_LIVE vdsm 3.6.0 bug fix and enhancement update 2016-03-09 23:49:32 UTC
oVirt gerrit 40080 master MERGED core: Check attached VMs snapshot status when moving a disk Never
oVirt gerrit 40443 ovirt-engine-3.5 MERGED core: Check attached VMs snapshot status when moving a disk Never
oVirt gerrit 40444 ovirt-engine-3.5.3 MERGED core: Check attached VMs snapshot status when moving a disk Never
oVirt gerrit 40593 master MERGED core: Check attached VMs snapshot preview only status when moving a disk Never
oVirt gerrit 40600 ovirt-engine-3.5.3 MERGED core: Check attached VMs snapshot preview only status when moving a disk Never

Description Roman Hodain 2015-04-13 15:58:03 UTC
Description of problem:
When a disk with a snapshot in the preview mode is moved to a different storage, the volume which is the preview one is not migrated and is removed from the source storage domain.

Version-Release number of selected component (if applicable):
vdsm-4.16.8.1-8.el6ev.x86_64

How reproducible:
100%

Steps to Reproduce:
1.Create VM with one disk
2.Create snapshot
3.Make preview
4.move the disk to a different SD

Actual results:
the preview volume is removed, but it remains in DB

Expected results:
The preview is migrated as well or the operation is not allowed.

Comment 2 Allon Mureinik 2015-04-14 07:25:59 UTC
(In reply to Roman Hodain from comment #0)
> Expected results:
> The preview is migrated as well or the operation is not allowed.
It should just be blocked.

Tal, since this is your week, please take a look, and either fix it or reassign at your discretion.

Comment 3 Tal Nisan 2015-04-21 10:17:23 UTC
Storage migration both live and cold is now blocked by CDA when one or more of the VMs attached to a disk are during a snapshot preview or during a snapshot creation

Comment 6 Ori Gofen 2015-05-17 13:26:08 UTC
Verified on 3.6 master, the operation is now Blocked

Comment 9 errata-xmlrpc 2016-03-09 19:36:26 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0362.html


Note You need to log in before you can comment on or make changes to this bug.