Bug 1211394 - rabbitmq-server package should install sample config files
Summary: rabbitmq-server package should install sample config files
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: rabbitmq-server
Version: epel7
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: ---
Assignee: Peter Lemenkov
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 1160810
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-04-13 21:29 UTC by Alan Pevec
Modified: 2015-11-21 14:25 UTC (History)
17 users (show)

Fixed In Version: rabbitmq-server-3.3.5-12.el7
Doc Type: Bug Fix
Doc Text:
Clone Of: 1160810
Environment:
Last Closed: 2015-11-21 14:25:56 UTC


Attachments (Terms of Use)

Description Alan Pevec 2015-04-13 21:29:10 UTC
+++ This bug was initially created as a clone of Bug #1160810 +++

+++ This bug was initially created as a clone of Bug #1134956 +++

The rabbitmq-server package does not install any configuration into /etc/rabbitmq/rabbitmq.config or /etc/rabbitmq/rabbitmq-env.conf.  Having the package install sample versions of these files would provide people with a model of what they should look like and may ease the process for people moving from qpid to rabbitmq (by providing and obvious location in which, e.g., to place credentials if they would like to use a non-default username/password).


--- Additional comment from Attila Fazekas on 2014-10-13 06:17:37 EDT ---

The 3.1.5 tarball (and the hg tag) does not contains an example config file, but the >=3.2.0 does.

Using the the sample from the >=3.2.0 would be also helpful.

--- Additional comment from Dan Yocum on 2014-10-13 08:23:39 EDT ---

The example config file has unsupported/unpackaged features which I removed in the second attachment I included.  Use the 2nd attachment as the first one had a typo (a trailing comma after a config stanza which made erlang puke).

Comment 1 Fedora Update System 2015-10-21 14:34:29 UTC
rabbitmq-server-3.3.5-8.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2015-9e02d235fb

Comment 2 Fedora Update System 2015-10-23 17:40:33 UTC
rabbitmq-server-3.3.5-11.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2015-addbe409a7

Comment 3 Fedora Update System 2015-10-26 21:20:23 UTC
rabbitmq-server-3.3.5-11.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'yum --enablerepo=epel-testing update rabbitmq-server'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2015-addbe409a7

Comment 4 Fedora Update System 2015-11-03 13:59:21 UTC
rabbitmq-server-3.3.5-12.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2015-f5273e10c1

Comment 5 Fedora Update System 2015-11-05 17:19:05 UTC
rabbitmq-server-3.3.5-12.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'yum --enablerepo=epel-testing update rabbitmq-server'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2015-f5273e10c1

Comment 6 Fedora Update System 2015-11-21 14:25:14 UTC
rabbitmq-server-3.3.5-12.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.