Bug 121149 - Touchpad not found
Touchpad not found
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-18 01:07 EDT by Brian Stretch
Modified: 2007-11-30 17:10 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-04 20:12:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brian Stretch 2004-04-18 01:07:35 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.6)
Gecko/20040312

Description of problem:
The touchpad (Synaptics? ALPS?) in my HP zv5000z notebook isn't found
by Fedora Core Devel.  It was found by FC1 for x86_64 Release, or at
least there was an option to select it. 

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Start FC Devel installation
2. FC can't find touchpad
3. Which forces a textmode install, because I didn't think to plug a
USB mouse in (d'oh!). 
    

Additional info:
Comment 1 Jeremy Katz 2004-05-06 17:53:52 EDT
Is this better with test3?
Comment 2 Brian Stretch 2004-05-08 11:45:46 EDT
Nope, no change.  I did a full reinstall with yesterday's devel tree. 
Comment 3 Jeremy Katz 2004-09-22 15:25:22 EDT
Committed paul's changes for synaptics support today.  Hopefully
tomorrow's devel tree will be better.
Comment 4 Alexandre Oliva 2004-10-10 01:23:55 EDT
FC3test3's kernel doesn't detect the ALPS touchpad of my brand new
Compaq Presario r3004 :-(  I've googled around a bit and I suspect no
amount of userland hacking is going to fix it.  Consensus on the net
is that kernel patches are needed to get ALPS to function (although
it's not clear to me what the common failure mode is if the patch is
missing).  Unfortunately, in my case, there's nothing other than the
keyboard in /proc/bus/input/devices, and I don't even know where to
look for.  i8042.nomux (suggested in bug 127821) actually disables the
keyboard for me :-(  Without any PS/2 ports, and without USB mice at
home, I'm out of luck :-(
Comment 5 Paul Nasrat 2004-10-11 06:02:55 EDT
ALPS support requires Dmitry's kernel patch - which is shipped along
with the synaptics driver. Once this goes upstream it'll get included
by default:

http://dtor.bkbits.net:8080/input/src/drivers/input/mouse?nav=index.html|src/|src/drivers|src/drivers/input

For installation mousekeys should work - press SHIFT-NUMLOCK then use
the numeric keypad to control the mouse pointer.
Comment 6 Alexandre Oliva 2004-10-12 03:17:06 EDT
It's not just the patch.  The Touchpad works fine in PS/2 emulation,
as long as psmouse is built as a module, and the module is reloaded
after the boot sequence is completed.  If it's initialized when built
into the kernel, or even loaded by initrd, it doesn't work; I have to
rmmod it and modprobe it again in rc.local.  Apparently even
rc.sysinit, just before rhgb is started, is too early.
Comment 7 Alexandre Oliva 2004-10-12 08:42:04 EDT
I lied.  I was using an older version of the patch.  A newer version
apparently has a fix for the initialization error that caused even
PS/2 emulation to break.  It works without the need for reloading any
modules now.  Let's see how it goes as a built-in...
Comment 8 Alexandre Oliva 2004-10-12 12:21:13 EDT
Nope, built in, it fails (not mouse is detected), and then there's no
way to re-probe :-(
Comment 9 Rahul Sundaram 2005-08-23 18:32:26 EDT
Alexandre Oliva,

Does this bug still exist?
Comment 10 Brian Stretch 2005-08-23 20:07:25 EDT
Nope.  I did a clean FC4 install a few days ago and, at least with the current
upgraded kernel version, the touchpad works automagically.  With the exception
of wireless networking (which requires ndiswrapper because of Broadcom's
continuing rectal-cranial inversion) everything I've tried on this notebook
(which isn't everything) Just Works... well, except for power management due to
HP breaking their BIOS somewhere along the way (it used to work, argh!).  That's
a subject for another thread though. 
Comment 11 Rahul Sundaram 2005-09-04 20:12:28 EDT
Closing it as per previous comment. Thanks

Note You need to log in before you can comment on or make changes to this bug.