Bug 121162 - kernel hangs during boot displaying 'freeing unused kernel memory'
Summary: kernel hangs during boot displaying 'freeing unused kernel memory'
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel   
(Show other bugs)
Version: rawhide
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-04-18 09:45 UTC by David Juran
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-18 10:19:02 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description David Juran 2004-04-18 09:45:39 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1)
Gecko/20031114

Description of problem:
When trying to boot kernel-smp-2.6.5-1.326 on my dual PIII it get's to
a point where it prints 
'freeing unused kernel memory: 184 k freed' 
and then it just hangs there. Seem to be a regression issue, since
kernel-smp-2.6.5-1.315 works fine.

Version-Release number of selected component (if applicable):
kernel-smp-2.6.5-1.326

How reproducible:
Always

Steps to Reproduce:
1. boot with kernel-smp-2.6.5-1.326


    

Additional info:

Comment 1 Arjan van de Ven 2004-04-18 09:49:31 UTC
Is this a FC2 userspace ?
or FC1-ish 

Comment 2 David Juran 2004-04-18 09:54:10 UTC
FC1 with a few packages (e.g. kernel, picutils, kudzu, modutils)
updated  to devel. 

Comment 3 Arjan van de Ven 2004-04-18 10:02:35 UTC
ok then it's a known FC1 glibc bug ;(
you'll either have to put "vdso=0" on the kernel commandline or
upgrade glibc as well. To be honest putting vdso=0 in is going to be
easier ;)

Comment 4 David Juran 2004-04-18 10:19:02 UTC
Thanks, the 'vdso=0' workaround works fine (-:

Comment 5 Hans Ecke 2004-04-22 18:13:45 UTC
Arjan, could you make a note of this in your readme? Lots of folks
with RH9/FC1 are using your kernels and it looks like this will happen
to all of us...


Note You need to log in before you can comment on or make changes to this bug.