Bug 1211682 - Libvirt does not generate guest address for USB hostdev element
Summary: Libvirt does not generate guest address for USB hostdev element
Keywords:
Status: CLOSED DUPLICATE of bug 1215968
Alias: None
Product: Virtualization Tools
Classification: Community
Component: libvirt
Version: unspecified
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Libvirt Maintainers
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 1215968
TreeView+ depends on / blocked
 
Reported: 2015-04-14 15:12 UTC by Martin Polednik
Modified: 2016-04-10 21:04 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1215968 (view as bug list)
Environment:
Last Closed: 2016-04-10 21:04:03 UTC


Attachments (Terms of Use)

Description Martin Polednik 2015-04-14 15:12:35 UTC
Description of problem:
Libvirt does not generate addresses for USB host devices. For almost every other device (even PCI host devices), an address is generated and can be read via parsing domain XML.

Version-Release number of selected component (if applicable):
rpm -q libvirt
libvirt-1.2.13-1.el7.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Create a domain XML containing valid type="usb" hostdev
2. Start the domain

Actual results:
Domain XML contains hostdev element without additional address child.

Expected results:
Domain XML should contain hostdev element with libvirt-generated address child.

Additional info:

Comment 1 Cole Robinson 2016-04-10 21:04:03 UTC
Since there's already a RHEL bug tracking this, there isn't much utility in keeping this report open. Duping to the RHEL bug

*** This bug has been marked as a duplicate of bug 1215968 ***


Note You need to log in before you can comment on or make changes to this bug.