Bug 1211720 - Custom Search for "External Bug ID is empty" is not working
Summary: Custom Search for "External Bug ID is empty" is not working
Keywords:
Status: CLOSED DUPLICATE of bug 1260009
Alias: None
Product: Bugzilla
Classification: Community
Component: Query/Bug List
Version: 4.4
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
Assignee: PnT DevOps Devs
QA Contact: Rony Gong 🔥
URL:
Whiteboard:
Depends On:
Blocks: UI-Modernization
TreeView+ depends on / blocked
 
Reported: 2015-04-14 17:49 UTC by Bryan Kearney
Modified: 2016-01-05 01:50 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-09-04 07:28:19 UTC


Attachments (Terms of Use)

Comment 1 Jason McDonald 2015-04-15 09:16:45 UTC
I see significantly fewer bugs due to permissions, but I can reproduce this issue.  Most likely it's a regression related to Bug 1205491.

We'll add this issue to our current sprint.  In the meantime, you should be able to work around the problem by changing the last line of the custom search from "External Bug ID - is empty" to "Not - External Bug Id - is not empty".

Comment 2 Matt Tyson 🤬 2015-04-21 04:53:55 UTC
It's not related to Bug 1205491 nor is it a regression.  The code has always functioned this way.

As Jason says, the way to perform this search is "Not" "External Bug Id" "Is Not Empty"

Comment 3 Jeff Fearn 🐞 2015-05-18 02:51:21 UTC
This search is designed to validate content within tables, it has no ability to test if a relationship does not exist. Due to the very abstracted nature of the functions it appears very invasive to try and pre-empt the search and either rewrite it to a matching search or handle a non existing relationship.

There is also a problem where the search type drop down does not have options filtered to those that make sense for the field selected. i.e. you can never have FKs that are NULL or empty in this search results as the tables are searched outside of the bugs query SQL and thus can only ever return values for those relationships that exist. This is why the double NOT works here, the first NOT gets you every bug that has an external link and then the second NOT says to not include them in the search results.

Comment 4 Jason McDonald 2015-05-18 03:02:57 UTC
Thanks for the analysis Jeff.  I think it's fair to say that all three members of the BZ team would prefer not to make invasive changes to the search code where a viable workaround exists (the "double NOT").  Instead, I think we should use the points in comment #3 as input for the upstream folks when they get around to modernizing the search UI, post-Bugzilla-5.0.

Comment 5 Jason McDonald 2015-09-04 07:28:19 UTC

*** This bug has been marked as a duplicate of bug 1260009 ***


Note You need to log in before you can comment on or make changes to this bug.