Bug 121173 - binutils ld linking problem in gnome-media
binutils ld linking problem in gnome-media
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gnome-media (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Colin Walters
:
Depends On:
Blocks: FC2Blocker FC3Target
  Show dependency treegraph
 
Reported: 2004-04-18 10:13 EDT by Warren Togami
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version: 2.8.0-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-16 14:06:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Warren Togami 2004-04-18 10:13:43 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040404 Firefox/0.8

Description of problem:
The latest FC2 gnome-media package built successfully on April 1st,
but somehow fails today.  ld is suspected?

http://people.redhat.com/wtogami/temp/gnome-media-x86_64.log
test -z "/usr/src/build/389713-x86_64/install/usr/lib64/libglade/2.0"
|| mkdir -p -- .
"/usr/src/build/389713-x86_64/install/usr/lib64/libglade/2.0"
 /bin/sh ../../libtool --mode=install /usr/bin/install -c 
'libgnome-media-profiles.la'
'/usr/src/build/389713-x86_64/install/usr/lib64/libglade/2.0/libgnome-media-profiles.la'
libtool: install: warning: relinking `libgnome-media-profiles.la'
(cd
/usr/src/build/389713-x86_64/BUILD/gnome-media-2.6.0/profiles/glade;
/bin/sh ../../libtool  --mode=relink x86_64-redhat-linux-gcc -O2 -g
-pipe -o libgnome-media-profiles.la -rpath /usr/lib64/libglade/2.0
-export-dynamic -module -avoid-version -no-undefined
libgnome_media_profiles_la-gnome-media-profiles-glade.lo -pthread
-Wl,--export-dynamic -L/usr/X11R6/lib64 -lglade-2.0 -lgnomeui-2 -lSM
-lICE -lbonoboui-2 -lxml2 -lpthread -lz -lgnomecanvas-2 -lgnome-2
-lpopt -lart_lgpl_2 -lpangoft2-1.0 -lgtk-x11-2.0 -lgdk-x11-2.0
-latk-1.0 -lgdk_pixbuf-2.0 -lpangoxft-1.0 -lpangox-1.0 -lpango-1.0
-lbonobo-2 -lgconf-2 -lgnomevfs-2 -lbonobo-activation -lORBit-2
-lgobject-2.0 -lgthread-2.0 -lm -lgmodule-2.0 -ldl -lglib-2.0
../../profiles/libgnome-media-profiles.la -inst-prefix-dir
/usr/src/build/389713-x86_64/install)
x86_64-redhat-linux-gcc -shared 
.libs/libgnome_media_profiles_la-gnome-media-profiles-glade.o 
-pthread -L/usr/X11R6/lib64 -lglade-2.0 -lgnomeui-2 -lSM -lICE
-lbonoboui-2 -L/usr/src/build/389713-x86_64/install/usr/lib64
-L/usr/lib64 -lxml2 -lpthread -lz -lgnomecanvas-2 -lgnome-2 -lpopt
-lart_lgpl_2 -lpangoft2-1.0 -lgtk-x11-2.0 -lgdk-x11-2.0 -latk-1.0
-lgdk_pixbuf-2.0 -lpangoxft-1.0 -lpangox-1.0 -lpango-1.0 -lbonobo-2
-lgconf-2 -lgnomevfs-2 -lbonobo-activation -lORBit-2 -lgobject-2.0
-lgthread-2.0 -lm -lgmodule-2.0 -ldl -lglib-2.0 -lgnome-media-profiles
 -Wl,--export-dynamic -Wl,-soname -Wl,libgnome-media-profiles -o
.libs/libgnome-media-profiles
/usr/bin/ld:
/usr/src/build/389713-x86_64/install/usr/lib64/libgnome-media-profiles.a(libgnome_media_profiles_la-audio-profile-edit.o):
relocation R_X86_64_32 can not be used when making a shared object;
recompile with -fPIC
/usr/src/build/389713-x86_64/install/usr/lib64/libgnome-media-profiles.a:
could not read symbols: Bad value
collect2: ld returned 1 exit status
libtool: install: error: relink `libgnome-media-profiles.la' with the
above command before installing it
make[3]: *** [install-glademoduleLTLIBRARIES] Error 1

http://people.redhat.com/wtogami/temp/gnome-media-i386.log
    File not found by glob:
/usr/src/build/389772-i386/install/usr/lib/*.so.*
    File not found by glob:
/usr/src/build/389772-i386/install/usr/lib/libglade/2.0/*.so
    File not found by glob:
/usr/src/build/389772-i386/install/usr/lib/*.so


Version-Release number of selected component (if applicable):
binutils-2.15.90.0.3-1
Comment 1 Bill Nottingham 2004-04-19 00:40:03 EDT
This is a package bug. Shared objects need -fPIC.
Comment 2 Colin Walters 2004-09-16 14:06:37 EDT
Looks like the latest rawhide uses -fPIC.

Note You need to log in before you can comment on or make changes to this bug.