Bug 121183 - gnome-settings-daemon stomps on .Xmodmap
Summary: gnome-settings-daemon stomps on .Xmodmap
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: control-center   
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Ray Strode [halfline]
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-04-18 17:04 UTC by Ralf Ertzinger
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-16 12:22:12 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Ralf Ertzinger 2004-04-18 17:04:33 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040312

Description of problem:
The gnome-settings-daemon overwrites settings made in the local
.Xmodmap file (and even displays a dialog box saying so):

"You have a keyboard remapping file (.Xmodmap) in your home directory
whose contents will now be ignored. You can use the keyboard
preferences to restore them."

Point is, the keyboard preferences dialog does not offer the
functionality I need (and running xmodmap .Xmodmap in an xterm works
just fine).

So, I'd like my .Xmodmap back.

Version-Release number of selected component (if applicable):
control-center-2.6.0.3-3

How reproducible:
Always

Steps to Reproduce:
1. Log in to gnome
2.
3.
    

Actual Results:  .Xmodmap being ignored

Expected Results:  .Xmodmap used

Additional info:

Comment 1 Christopher Przybycien 2004-06-22 07:16:05 UTC
I found a workaround for this just a few minutes ago. 
 
1) Go to Preferences->Sessions 
2) Choose the "Startup Programs" tab 
3) Add the command "xmodmap /home/<username>/.Xmodmap" 

Comment 2 Chris Petersen 2004-11-17 16:48:02 UTC
Agreed.  I use Xmodmap to rewrite my mouse buttons so I can actually
use the scroll wheel on my mouse.  I can't even get my global
/etc/X11/Xmodmap file to run, let alone the local one that produces
the gnome error.

Will install the workaround, but that shouldn't be the way things work.

Comment 3 Ralf Ertzinger 2005-02-13 12:35:29 UTC
The g-s-d from control-center 2.9.91-1 asks me to to import my
.Xmodmap at startup time (and actually does so). Makes me happy.

Comment 4 Ralf Ertzinger 2005-03-16 12:22:12 UTC
Seems to be fixed in current rawhide, closing.


Note You need to log in before you can comment on or make changes to this bug.