Bug 121191 - Konqueror refuses to open directories
Konqueror refuses to open directories
Product: Fedora
Classification: Fedora
Component: kdebase (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Ben Levenson
Depends On:
  Show dependency treegraph
Reported: 2004-04-18 15:16 EDT by Andy Green
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-10-29 16:55:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Andy Green 2004-04-18 15:16:29 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040225 Firefox/0.8

Description of problem:
Attempting to use Konqueror to navigate around directories, or use the
up a
level button, fails completely after a yum update just now.  A dialog

Error - Konqueror

There appears to be a configuration error.  You have associated
Konqueror with
inode/directory, but it can't handle this file type.

#rpm -q --whatprovides /usr/bin/konqueror

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. yum update
2. kdebase-3.2.2-1 installed
3. reboot

Actual Results:  Rebooted and Konqueror windows open, but
double-clicking a directory shown in the file manager view of
Konqueror gets the error message.

Expected Results:  The directory should open in the same window as usual.

Additional info:
Comment 1 Andy Green 2004-04-18 16:50:42 EDT
Konqueror in web-browsing mode is giving a similar error "...you 
have associated Konqueror with text/html, but it can't handle..." if 
I click on a normal HTML link.  Editing the URL in the URL bar and 
hitting enter works okay. 
Comment 2 Ismael Juma 2004-04-18 18:45:55 EDT
I am experiencing the same problem. Interestingly, if I right-click a
folder and then select the "Open in a new window" option, it works.
Opening in a new tab on the other hand fails the same way as just
double clicking.
Comment 3 Ismael Juma 2004-04-19 07:25:56 EDT
Dennis Gilmore has explained how to solve the problem in:


I will quote the relevant section:

"i fixed this by right clicking on a folder -> selecting properties ->
next to 
where it says Type :  directory is a tool box icon clicking it ->
embededding tab -> and selecting Use settings for 'inode' group 
clicked ok 
till i got back to folder and it was all good after that"

That fixed it for me too. 8)

It would be nice, however, if updating to KDE 3.2.2 just worked
without requiring the user to change settings to get back funcionality
previously available.
Comment 4 Andy Green 2004-04-19 08:22:08 EDT
Good find Dennis! 
His fix also works for me, and I found that the HTML links can be 
fixed too by 
 - Settings | Configure Konqueror 
 - File Associations 
 - type html in the box 
 - open the text node and click html (this is pretty clunky this 
property page - don't press Enter either or it closes the dialog) 
 - Embedding tab 
 - select "Show file in embedded viewer' 
 - OK 
Comment 5 Ngo Than 2004-04-21 11:57:46 EDT
could someone of you could give me a testcase please how i can
reproduce  this problem? it seems it works for me. Thanks
Comment 6 John Thacker 2006-10-29 16:55:04 EST
Closing per lack of response to previous request for information.  Note that FC3
and FC4 are supported by Fedora Legacy for security fixes only.  Please test
this on FC5 or FC6.  If it still occurs there, please reopen and change the
version to fc5 or fc6.  Otherwise, if this is a security issue, please reassign
the bug to Fedora Legacy.  Thanks, and we apologize for not getting to this bug

Note You need to log in before you can comment on or make changes to this bug.