Bug 121195 - unit mask error for MACHINE_CLEAR event
unit mask error for MACHINE_CLEAR event
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: oprofile (Show other bugs)
3.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: William Cohen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-18 16:31 EDT by Tom Lane
Modified: 2013-07-02 23:01 EDT (History)
1 user (show)

See Also:
Fixed In Version: oprofile-0.5.4-22
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-03-03 16:49:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tom Lane 2004-04-18 16:31:56 EDT
Description of problem:
I tried to use the MACHINE_CLEAR event on a Xeon to monitor memory
ordering related machine clears.  op_help claims this is mask 0x40,
but when I use that, I get no samples.  The Intel manuals say that
the MOCLEAR bit is bit 2, so I tried 0x4, but oprofile wouldn't let
me: the daemon fails to start.  So this is really 3 separate bugs:

1. Information for Xeon MACHINE CLEAR unit masks is wrong (the bit
assignment for SMCLEAR looks wrong too).

2. Should the daemon really refuse to start if it thinks the unit mask
 is inappropriate?  How dangerous is that?

3. Shouldn't this error (or preferably warning) appear at opcontrol
--setup instead of daemon start?

Version-Release number of selected component (if applicable):
oprofile-devel-0.5.4-20

How reproducible:
every time

Steps to Reproduce:
1. opcontrol --setup --no-vmlinux --ctr3-event=MACHINE_CLEAR
--ctr3-count=100000 --ctr3-unit-mask=0x4
2. opcontrol --start-daemon
  
Actual results:
oprofiled: ctr3: 0x04: invalid unit mask for cpu P4 / Xeon

Expected results:
collection of data

Additional info:
Comment 1 William Cohen 2004-04-19 11:39:01 EDT
1. The unit masks for machine_clear don't agree with the latest intel
documentation. This has been corrected in oprofile-0.5.4-22.

2. I haven't seen any warning to the effect "This performance bit will
cause the machine to lock up."

3. opcontrol --setup should probably give the error (warning) message
instead of the opcontrol --start. Whether it should be a warning or an
error message is up for debate.

Should go through and check the other unit masks to verify that there
are not other discrapancies.

Note You need to log in before you can comment on or make changes to this bug.