Bug 121210 - kon2 doesn't work with recent policy
kon2 doesn't work with recent policy
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: policy (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Russell Coker
Ben Levenson
: i18n
Depends On:
Blocks: 122683
  Show dependency treegraph
 
Reported: 2004-04-19 03:54 EDT by Akira TAGOH
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-12 15:55:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Akira TAGOH 2004-04-19 03:54:00 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; ja-JP; rv:1.6)
Gecko/20040413 Debian/1.6-5

Description of problem:
kon2 worked before, but it doesn't work now with recent policy(at
least with 1.11.2-8). when I run kon, I got these messages.

Apr 19 16:49:31 devel02 kernel: audit(1082360971.378:0): avc:  denied
 { dac_override } for  pid=2648 exe=/usr/bin/kon capability=1
scontext=user_u:user_r:user_t tcontext=user_u:user_r:user_t
tclass=capability
Apr 19 16:49:31 devel02 kernel: audit(1082360971.378:0): avc:  denied
 { dac_read_search } for  pid=2648 exe=/usr/bin/kon capability=2
scontext=user_u:user_r:user_t tcontext=user_u:user_r:user_t
tclass=capability
Apr 19 16:49:31 devel02 kernel: audit(1082360971.378:0): avc:  denied
 { dac_override } for  pid=2648 exe=/usr/bin/kon capability=1
scontext=user_u:user_r:user_t tcontext=user_u:user_r:user_t
tclass=capability
Apr 19 16:49:31 devel02 kernel: audit(1082360971.378:0): avc:  denied
 { dac_read_search } for  pid=2648 exe=/usr/bin/kon capability=2
scontext=user_u:user_r:user_t tcontext=user_u:user_r:user_t
tclass=capability


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.run kon on the console as the normal user
2.
3.
    

Actual Results:  doesn't work due to kon can't open /dev/console

Expected Results:  kon should work correctly

Additional info:
Comment 1 Daniel Walsh 2004-04-22 15:23:31 EDT
I have no idea how to use kon.  Could you attempt to write policy for
it?  

Dan

Note You need to log in before you can comment on or make changes to this bug.