Bug 1212120 - Importing manifest may fail to upload unless timeout is increased
Summary: Importing manifest may fail to upload unless timeout is increased
Keywords:
Status: CLOSED DUPLICATE of bug 1193803
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Subscription Management
Version: 6.1.0
Hardware: Unspecified
OS: Unspecified
high
high vote
Target Milestone: Unspecified
Assignee: David Davis
QA Contact: Katello QA List
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-04-15 15:13 UTC by Kedar Bidarkar
Modified: 2016-03-11 13:10 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-03-11 13:10:40 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Kedar Bidarkar 2015-04-15 15:13:18 UTC
Description of problem:

Importing  a manifest fails with the below error in /var/log/foreman/production.log

2015-04-14 21:25:30 [E] Error during manifest import: {"displayMessage"=>"Manifest import failed", "conflicts"=>[]}
2015-04-14 21:25:30 [E] Katello::Resources::Candlepin::Owner: Request Timeout  (POST /candlepin/owners/aa959e63-d464-409c-817f-691de3e6ddb4/imports) (RestClient::RequestTimeout)
/opt/rh/ruby193/root/usr/share/gems/gems/rbovirt-0.0.29/lib/restclient_ext/request.rb:56:in `rescue in transmit'
/opt/rh/ruby193/root/usr/share/gems/gems/rbovirt-0.0.29/lib/restclient_ext/request.rb:11:in `transmit'
/opt/rh/ruby193/root/usr/share/gems/gems/rest-client-1.6.7/lib/restclient/request.rb:64:in `execute'

Version-Release number of selected component (if applicable):
sat6.1 beta RC5

How reproducible:


Steps to Reproduce:
1. import a manifest with just "RedHat Employee Subscription" subscription fails as upload happens for more than 120 secs.
2.
3.

Actual results:
Get a message on the UI saying "Error during manifest import".
Manifest upload happens for more than 120 secs.

Increasing the rest_client_timeout in /etc/foreman/plugins/katello.yaml to 300 secs solves this issue.

Expected results:
Manifest import should be successful, via UI without having to tweak timeout values. May be katello.yaml file should already be configured with an optimal timeout value.

Additional info:

1) Sat6 automation uses cloned manifests using our own cert/keys to sign the manifest and create manifest clones.
2) After a manifest import has failed, importing any cloned manifest works fine.

Comment 2 David Davis 2016-03-11 13:10:40 UTC

*** This bug has been marked as a duplicate of bug 1193803 ***


Note You need to log in before you can comment on or make changes to this bug.