Bug 121246 - CPU speed always set to c.a. 600MHZ
Summary: CPU speed always set to c.a. 600MHZ
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel   
(Show other bugs)
Version: rawhide
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Dave Jones
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-04-19 17:17 UTC by Richard Allen
Modified: 2015-01-04 22:05 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-27 23:52:40 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Output from dmesg (12.90 KB, text/plain)
2004-04-19 17:18 UTC, Richard Allen
no flags Details
Output from lspci -v (5.28 KB, text/plain)
2004-04-19 17:20 UTC, Richard Allen
no flags Details

Description Richard Allen 2004-04-19 17:17:12 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040312

Description of problem:
I have a HP NX7010 Centrino based laptop.

[root@xo root]# cat /proc/cpuinfo 
processor       : 0
vendor_id       : GenuineIntel
cpu family      : 6
model           : 9
model name      : Intel(R) Pentium(R) M processor 1600MHz
stepping        : 5
cpu MHz         : 598.312
cache size      : 1024 KB
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 2
wp              : yes
flags           : fpu vme de pse tsc msr mce cx8 sep mtrr pge mca cmov
pat clflush dts acpi mmx fxsr sse sse2 tm pbe tm2 est
bogomips        : 1185.79

For some strange reason the system decides to start slowing the cpu
down immediatly after booting.   I rebooted my machine and checked the
reported cpu speed and it was about 1300 mhz.   then it slowly drops
to 598.312 mhz and stays there.

It should be noted that the laptop is docked and on mains power.
Also, this is a Fedora Core test2 (fully up2date via rawhide)
kernel-2.6.5-1.327

[root@xo root]# cd /sys/devices/system/cpu/cpu0/cpufreq
[root@xo cpufreq]# cat cpuinfo_max_freq
1600000
[root@xo cpufreq]# cat cpuinfo_min_freq
600000
[root@xo cpufreq]# cat scaling_available_frequencies
1600000 1400000 1200000 1000000 800000 600000 
[root@xo cpufreq]# cat scaling_available_governors
userspace performance 
[root@xo cpufreq]# cat scaling_driver
centrino
[root@xo cpufreq]# cat scaling_governor
userspace
[root@xo cpufreq]# cat scaling_max_freq
1600000
[root@xo cpufreq]# cat scaling_min_freq
600000
[root@xo cpufreq]# cat scaling_setspeed
600000

[root@xo cpufreq]# echo 1600000 > scaling_setspeed
[root@xo cpufreq]# grep "cpu MHz" /proc/cpuinfo 
cpu MHz         : 1595.500

will attach more diagnostics info.




Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Boot a centrino based laptop and monitor the CPU speed

Additional info:

Comment 1 Richard Allen 2004-04-19 17:18:35 UTC
Created attachment 99533 [details]
Output from dmesg

Output from dmesg

Comment 2 Richard Allen 2004-04-19 17:20:00 UTC
Created attachment 99534 [details]
Output from lspci -v

Comment 3 Richard Allen 2004-04-19 17:25:30 UTC
Yup :)   Fedora Core 1 also does this :)    Meaning I've been running
my laptop at 600Mhz from the getgo ;)
I guess this sais more about me than the laptop... :)


Comment 4 Richard Allen 2004-04-19 17:45:20 UTC
I found a service running called "cpuspeed".  did a chkconfig cpuspeed
off and rebooted.

[root@xo root]# grep "cpu MHz" /proc/cpuinfo 
cpu MHz         : 1595.606

Now this slow scaling down to 600 mhz does not happen and I do feel a
difference ;)

This service seems to be starting "/usr/sbin/cpuspeed" that reads
/etc/cpuspeed.conf which is basicly empty on my box (only has VMAJOR=1
and VMINOR=1 that are not comments).
This programs seems to come from the kernel-utils package and has no
man page or other documentation.

I've investigated this and as far as I can see (from the limited help
cpuspeed --help is) all the criteria the program needs to run
correctly are met except I cant find any thermal_zone file on my machine.

[root@xo thermal_zone]# pwd
/proc/acpi/thermal_zone
[root@xo thermal_zone]# ls -l
total 0



Comment 5 Richard Allen 2004-04-19 18:23:33 UTC
ok. you guys can shoot me.

I RTFS (the code for cpuspeed) and ofcource its all as it should be.
Something like "dump 0af - / | gzip -9 >  /dev/null" will load the CPU
right up and then cpuspeed will kick the CPU directly up to max speed.

I guess the only issue here is that thermal_zone is missing so I cant
so some of the more advanced things here.


Comment 6 Arjan van de Ven 2004-04-19 19:38:06 UTC
cpuspeed looks like something really neat but unfortionately my laptop
doesn't do speedstep (unlike it was advertized ;( ) so I can't test
it's tuning etc myself. If there's something that makes it work better
for you please play around with the settings and let me know....

Comment 7 Richard Allen 2004-04-20 13:10:41 UTC
Arjan, I've been looking at the kernel source and I dont see why the
thermal info is not there.  The .configs you ship with the kernel are
correct.
From what google tells me the thermal stuff in the Centrino chipset
should work just fine.   Should I log a specific case for that issue ?


Comment 8 Bastien Nocera 2004-08-30 21:45:09 UTC
It's not a CPU thing, it's an ACPI problem. Either your laptop doesn't
report the temperature, or the ACPI implementation doesn't.

Your laptop:
ACPI: Processor [CPU0] (supports C1 C2 C3, 8 throttling states)

Mine:
ACPI: Processor [CPU0] (supports C1 C2, 8 throttling states)
ACPI: Thermal Zone [ATF0] (51 C)

Could you make sure that the "acpi" module is loaded (speedstepping
via ACPI)? If it is, your best bet is to file a bug upstream,
following the instructions at:
http://acpi.sourceforge.net/index.html


Note You need to log in before you can comment on or make changes to this bug.