Bug 121247 - postfix/pickup hangs when lots of mails come to maildrop queue
postfix/pickup hangs when lots of mails come to maildrop queue
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: postfix (Show other bugs)
3.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Thomas Woerner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-19 13:27 EDT by Roger Pena-Escobio
Modified: 2008-08-02 19:40 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-24 11:58:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Roger Pena-Escobio 2004-04-19 13:27:28 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20031212

Description of problem:
when lots ( > 3000) of mails come to the maildrop queue the pickup
daemon hangs, sometimes the master daemon pick that situation and make
a restart to pickup daemon but sometimes it doesn't, when it doesn't
all the mail flux stop because nobody move mails from maildrop to
incoming queue. you have to restart postfix by hand to fix the situation

here is some of pickup logs:
Feb 23 14:46:44 mail postfix/pickup[4800]: fatal: watchdog timeout
 Feb 23 15:03:28 mail postfix/pickup[18406]: fatal: watchdog timeout
 Feb 23 15:21:08 mail postfix/pickup[28746]: fatal: watchdog timeout
 Feb 23 15:38:48 mail postfix/pickup[486]: fatal: watchdog timeout
 Feb 23 15:56:28 mail postfix/pickup[4631]: fatal: watchdog timeout
 Feb 23 16:14:11 mail postfix/pickup[9811]: fatal: watchdog timeout
 Feb 23 16:31:54 mail postfix/pickup[15322]: fatal: watchdog timeout
 Feb 23 16:49:36 mail postfix/pickup[21637]: fatal: watchdog timeout
 Feb 23 17:07:16 mail postfix/pickup[25701]: fatal: watchdog timeout
 Feb 23 18:07:11 mail postfix/pickup[32112]: fatal: watchdog timeout
 Feb 23 18:24:53 mail postfix/pickup[7754]: fatal: watchdog timeout
 Feb 23 18:42:36 mail postfix/pickup[22061]: fatal: watchdog timeout
 Feb 23 19:00:17 mail postfix/pickup[10177]: fatal: watchdog timeout
 Feb 23 19:18:03 mail postfix/pickup[31180]: fatal: watchdog timeout

with each line you can find two more from master process



Version-Release number of selected component (if applicable):
postfix-2.0.11-4

How reproducible:
Always

Steps to Reproduce:
1. send a bunch of e-mails to maildrop queue (using mail command for
example), more than 10 000 will be ok
2. keep feeding the maildrop queue faster than the postfix speed
3. keep looking in to pickup activity (tail -20f /var/log/maillog |
grep pickup)


    

Actual Results:  after 17-18 minutes, if you still have more than a
few thousand of mail in the maildrop, you start getting the fatal error.
those errors will apear very regulary, after 17-18 minutos from
eachother, when someone fail to apear is because:
1. there is less than 1000 mails in the maildrop
2. the pickup hangs and the master couldn't notice that, pickup will
never pick anymore mail from maildrop until restarted by hand 

Additional info:

as i say, if the pickup daemon hangs and the master didn't notice
that, the mail system for uucp peoples, and any other solution where
the e-mail are passed to the postfix system by direct invocation of
the sendmail command (webmail, smtpd-obtuse, etc) will be stopped.
the mails will start acumulating into maildrop queue waiting for the
pickup daemon, the mail queue could become very large in busy servers.
Comment 1 Chris Ricker 2004-05-07 10:20:47 EDT
If you edit /etc/postfix/master.cf and change the line

pickup    fifo  n       -       n       60      1       pickup

to 

pickup    fifo  n       -       n       60      1       pickup -v

it should give additional debugging information to show why pickup is
hanging
Comment 2 Jason Long 2004-10-13 10:17:30 EDT
This is probably the bug described here

http://www.irbs.net/internet/postfix/0401/2658.html
Comment 3 Thomas Woerner 2007-07-23 05:12:09 EDT
Have you tested if the patch from comment #2 is solving your problem?
Comment 4 Thomas Woerner 2007-07-24 11:57:25 EDT
This request was evaluated by Red Hat Engineering for inclusion in a Red
Hat Enterprise Linux maintenance release.

Red Hat does not currently plan to provide this change in a Red Hat Enterprise
Linux update release for currently deployed products.

With the goal of minimizing risk of change for deployed systems, and in
response to customer and partner requirements, Red Hat takes a conservative
approach when evaluating enhancements for inclusion in maintenance updates
for currently deployed products. The primary objectives of update releases
are to enable new hardware platform support and to resolve critical
defects.

However, Red Hat will further review this request for potential inclusion
in future major releases of Red Hat Enterprise Linux. 

Note You need to log in before you can comment on or make changes to this bug.