Bug 121261 - 2 * local variable used before set
Summary: 2 * local variable used before set
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: gok   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Colin Walters
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-04-19 20:05 UTC by d.binderman
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-23 17:04:20 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description d.binderman 2004-04-19 20:05:32 UTC
Description of problem:

I just tried to compile Core2 Test2 package gok-0.9.10-1

The compiler said

1.

gok-keyboard.c(3857): remark #592: variable "bChanged" is used before
its value
is set

The source code is

                return bChanged;

but

[root@localhost SPECS]# grep bChanged !$
grep bChanged ../BUILD/gok-0.9.10/gok/gok-keyboard.c
        gboolean bChanged;
                return bChanged;

I agree with the compiler. This code needs re-work.

2.

main.c(1515): remark #592: variable "langlist" is used before its
value is set

The source code is

        langlist == NULL;

Perhaps

        langlist = NULL;

was intended by the programmer ?


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Colin Walters 2004-04-23 17:04:20 UTC
The first was already fixed upstream, and I just fixed the second now.


Note You need to log in before you can comment on or make changes to this bug.