Bug 1212772 (CVE-2015-2571) - CVE-2015-2571 mysql: unspecified vulnerability related to Server:Optimizer (CPU April 2015)
Summary: CVE-2015-2571 mysql: unspecified vulnerability related to Server:Optimizer (C...
Status: CLOSED ERRATA
Alias: CVE-2015-2571
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard: impact=moderate,public=20150415,repor...
Keywords: Security
Depends On: 1214580 1214588 1214590 1214599 1247020 1247021 1247022 1247023 1247024 1247027 1247028
Blocks: 1212785
TreeView+ depends on / blocked
 
Reported: 2015-04-17 09:55 UTC by Martin Prpič
Modified: 2019-07-11 08:58 UTC (History)
25 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2016-10-14 21:42:38 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHSA-2015:1628 normal SHIPPED_LIVE Moderate: mysql55-mysql security update 2015-08-17 09:44:14 UTC
Red Hat Product Errata RHSA-2015:1629 normal SHIPPED_LIVE Moderate: mysql55-mysql security update 2015-08-17 10:05:22 UTC
Red Hat Product Errata RHSA-2015:1647 normal SHIPPED_LIVE Moderate: mariadb55-mariadb security update 2015-08-20 13:17:49 UTC
Red Hat Product Errata RHSA-2015:1665 normal SHIPPED_LIVE Moderate: mariadb security update 2015-08-24 22:43:12 UTC

Description Martin Prpič 2015-04-17 09:55:25 UTC
Vulnerability in the MySQL Server component of Oracle MySQL (subcomponent: Server : Optimizer). Supported versions that are affected are 5.5.42 and earlier and 5.6.23 and earlier. Easily exploitable vulnerability allows successful authenticated network attacks via multiple protocols. Successful attack of this vulnerability can result in unauthorized ability to cause a hang or frequently repeatable crash (complete DOS) of MySQL Server.

External References:

http://www.oracle.com/technetwork/topics/security/cpuapr2015-2365600.html#AppendixMSQL

Comment 3 Huzaifa S. Sidhpurwala 2015-04-23 09:10:16 UTC
This issue was addressed in mysql-5.5 in Fedora 20 via the following security advisory:

https://admin.fedoraproject.org/updates/community-mysql-5.5.43-1.fc20

This issue was addressed in mysql-5.6 in Fedora 21 via the following security advisory:

https://admin.fedoraproject.org/updates/community-mysql-5.6.24-1.fc21

Comment 4 Huzaifa S. Sidhpurwala 2015-04-23 09:36:10 UTC
Statement:

This issue affects the versions of mysql and mysql55 packages as shipped with Red Hat Enterprise Linux 5, 6 and 7. This issue affects the version of mariadb and mariadb55 packages as shipped with Red Hat Enterprise Linux 6 and 7. Red Hat Product Security has rated this issue as having Moderate security impact, a future update may address this flaw.

Comment 5 Huzaifa S. Sidhpurwala 2015-06-18 03:24:25 UTC
This issue has been fixed in mariadb-10.0.18 as per the release notes at:
https://mariadb.com/kb/en/mariadb/mariadb-10018-release-notes/

Comment 8 errata-xmlrpc 2015-08-17 05:45:23 UTC
This issue has been addressed in the following products:

  Red Hat Enterprise Linux 5

Via RHSA-2015:1628 https://rhn.redhat.com/errata/RHSA-2015-1628.html

Comment 9 errata-xmlrpc 2015-08-17 06:05:54 UTC
This issue has been addressed in the following products:

  Red Hat Software Collections for Red Hat Enterprise Linux 7.1 EUS
  Red Hat Software Collections for Red Hat Enterprise Linux 7
  Red Hat Software Collections for Red Hat Enterprise Linux 6
  Red Hat Software Collections for Red Hat Enterprise Linux 6.6 EUS
  Red Hat Software Collections for Red Hat Enterprise Linux 6.5 EUS

Via RHSA-2015:1629 https://rhn.redhat.com/errata/RHSA-2015-1629.html

Comment 10 errata-xmlrpc 2015-08-20 09:18:14 UTC
This issue has been addressed in the following products:

  Red Hat Software Collections for Red Hat Enterprise Linux 7.1 EUS
  Red Hat Software Collections for Red Hat Enterprise Linux 7
  Red Hat Software Collections for Red Hat Enterprise Linux 6
  Red Hat Software Collections for Red Hat Enterprise Linux 6.6 EUS
  Red Hat Software Collections for Red Hat Enterprise Linux 6.5 EUS

Via RHSA-2015:1647 https://rhn.redhat.com/errata/RHSA-2015-1647.html

Comment 11 errata-xmlrpc 2015-08-24 18:43:38 UTC
This issue has been addressed in the following products:

  Red Hat Enterprise Linux 7

Via RHSA-2015:1665 https://rhn.redhat.com/errata/RHSA-2015-1665.html


Note You need to log in before you can comment on or make changes to this bug.