Bug 121287 - no lpr command after upgrade
no lpr command after upgrade
Status: CLOSED DEFERRED
Product: Fedora
Classification: Fedora
Component: chkconfig (Show other bugs)
1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-19 23:54 EDT by Nick Simicich
Modified: 2014-03-16 22:44 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-02 16:27:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Log from Fedora Core 1 upgrade. (57.87 KB, text/plain)
2004-07-23 03:09 EDT, Nick Simicich
no flags Details

  None (edit)
Description Nick Simicich 2004-04-19 23:54:55 EDT
Description of problem:

I had a redhat 7.3 installation in which everything was installed.
I had a lot of userdata and some other stuff I did not want to lose,
so I did an upgrade installation.  Almost everything worked, but I had
no lpr command.  After noticing that the lprNG system had been
removed, and that CUPS was now installed, I presumed that this was
intentional.



Version-Release number of selected component (if applicable):

0.5.1-2

How reproducible:

Upgrade an "everything" 7.3 system to Fedora Core 1.

Steps to Reproduce:
1. Install an "everything 7.3"
2. Install a Fedora Core 1 and all errata
3. Behold.
  
Actual results:

None of the symlinks to set up the CUPS system were extant.

Expected results:

I wanted to be able to print.

Additional info:

For whatever reason, I had to use the redhat-switch-printer-nox
command, as I got a bunch of error messages when I tried to use the X
version, even though other commands, such as "redhat-config-printer"
worked fine. In any case, once I selected the "hobson's choice" of
CUPS, all the links were set up correctly. 

I would have been happy with a few lines in the release notes,
suggesting that I run redhat-config-printer.  Given that there is no
longer a lprNG, perhaps an upgrade that forces the CUPS setup is
appropriate.  In any case, it should probably simply be noted in case
someone is trying to debug it.
Comment 1 Tim Waugh 2004-07-22 06:25:08 EDT
alternatives is supposed to do the right thing here.
Comment 2 Bill Nottingham 2004-07-22 14:32:22 EDT
Are there any error messages from alternatives in the upgrade log?
Comment 3 Nick Simicich 2004-07-23 03:09:51 EDT
Created attachment 102165 [details]
Log from Fedora Core 1 upgrade.

I *think* this is the upgrade log - I am not sure if there are any error
messages from any packages you care about in this - please feel free to take a
look.
Comment 4 Bill Nottingham 2005-02-02 16:27:33 EST
No obvious error messages there.

Unfortunately, we haven't seen this in testing here. Please re-open if
it persists.
Comment 5 Nick Simicich 2005-02-04 10:48:56 EST
How can it possibly persist?  Should I re-install a 7.3 system and
then a Fedora Core 1 on top of that?  
Comment 6 Bill Nottingham 2005-02-04 15:28:41 EST
Probably not, if it's working for you now; merely there as a reminder
to reinvestigate if it starts recurring on later releases.

Note You need to log in before you can comment on or make changes to this bug.