This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 121288 - cdrecord fails to burn image properly
cdrecord fails to burn image properly
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: cdrtools (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-20 00:14 EDT by Ellen Shull
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-06 20:08:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Ellen Shull 2004-04-20 00:14:32 EDT
Description of problem: 
Did a mkbootdisk --iso and went to burn the image.  cdrecord burns it 
without complaint, but the burn always fails to verify, and always at 
the same spot.  Tried several different discs, both -rw and -r, with 
the exact same result. 
 
Switched to the cdrecord-prodvd-2.01a27-i686-pc-linux-gnu binary from 
Schilly's site and the image was then burned and verified 
successfully.  Was using the same readcd to compare every time, while 
is why I suspect it was the burn that failed. 
 
Version-Release number of selected component (if applicable): 
cdrecord-2.01-0.a27.2.i386.rpm 
 
How reproducible: 
always (with this particular image anyway, haven't tried any others 
yet) 
 
Steps to Reproduce: 
1.  grab image I'm using:  
http://kuoi.asui.uidaho.edu/~wes/boot-2.6.5-1.327.iso (made with 
"mkbootdisk --device boot-2.6.5-1.327.iso --iso 2.6.5-1.327") 
2.  burn image...  in my case I do "cdrecord dev=/dev/hdc -dao -v 
boot-2.6.5-1.327.iso" 
3.  attempt to verify the burn... 
 
Actual results: 
[root@ip68-110-7-34 root]# readcd dev=/dev/hdc f=- | cmp 
boot-2.6.5-1.327.iso 
Read  speed:  4233 kB/s (CD  24x, DVD  3x). 
Write speed:  1411 kB/s (CD   8x, DVD  1x). 
Capacity: 1003 Blocks = 2006 kBytes = 1 MBytes = 2 prMB 
Sectorsize: 2048 Bytes 
Copy from SCSI (1,0,0) disk to file '-' 
end:      1003 
readcd: Success. read_g1: scsi sendcmd: no error 
CDB:  28 00 00 00 03 B1 00 00 3A 00 
status: 0x2 (CHECK CONDITION) 
Sense Bytes: F0 00 03 00 00 03 EA 0E 00 00 00 00 11 05 00 00 
Sense Key: 0x3 Medium Error, Segment 0 
Sense Code: 0x11 Qual 0x05 (l-ec uncorrectable error) Fru 0x0 
Sense flags: Blk 1002 (valid) 
resid: 118784 
cmd finished after 4.639s timeout 40s 
readcd: Success. Cannot read source disk 
readcd: Retrying from sector 945. 
.......................................................... 
 
etc. until you kill it.  Note the read failure happened at sector 945 
*every* time, regardless of the disc. 
 
Expected results: 
successful read/compare, as happens when I burn the image with 
Schilly's binary. 
 
Additional info: 
rest of system is current fedora rawhide
Comment 1 Ellen Shull 2004-05-06 20:08:12 EDT
Just tested with cdrecord-2.01-0.a27.3, works correctly for me now.  
Maybe the messed-up command-line parsing in .2 was missing the -dao 
and causing the problem? 

Note You need to log in before you can comment on or make changes to this bug.