Bug 121289 - [ALSA] Gsteamer crashes when Default Source is ALSA
[ALSA] Gsteamer crashes when Default Source is ALSA
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: alsa-lib (Show other bugs)
rawhide
All Linux
medium Severity high
: ---
: ---
Assigned To: Bill Nottingham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-20 00:20 EDT by Jerone Young
Modified: 2014-03-16 22:44 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-26 21:24:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jerone Young 2004-04-20 00:20:59 EDT
Description of problem:
If you launch "gsteamer-properties" and go to "Default Source" , the
Input is set to ALSA (as it should be)...but when you press the test
button it crashes (Segmentation Fault). This same sympotum is also
causing "gnome-sound-recorder" to die as well. Now if I switch default
source to OSS then it doesn't crash, and "gnome-sound-recorder"
doesn't crash...but it doesn't work either. 

I've spent sometime on this issue and I've narrowed it down to what
I've stated above. I just want "gnome-sound-recorder" to work, but
this is the cause. I don't know if it's Gstreamers fault or ALSA.
Comment 1 Gerry Tool 2004-04-29 21:26:05 EDT
I confirm that the gnome-sound-recorder does not function.  If I start
it from the command line, it opens the app.  Then when I click record,
it provides the following error message:

[gerry@gstpc gerry]$ gnome-sound-recorder
ALSA lib pcm.c:824:(snd_pcm_sw_params) snd_pcm_sw_params:
params->avail_min problem for start_threshold

and does nothing.  I have been using this app in FC1 where it works
most of the time - occasional crash when saving the file, but
otherwise works well, even with >200MB audio files.

Version above should proabably be changed from 2 to test3.

I have a fresh installed test3 with all updates applied as of 4/29/04,
8:31pm CDT.
Comment 2 Jerone Young 2004-05-08 11:07:09 EDT
When I run "krec" the KDE recording program, I see these messages:

ALSA lib pcm_hw.c:494:(snd_pcm_hw_start) SNDRV_PCM_IOCTL_START failed:
Broken pipe
ALSA lib pcm_hw.c:494:(snd_pcm_hw_start) SNDRV_PCM_IOCTL_START failed:
Broken pipe
ALSA lib pcm_hw.c:494:(snd_pcm_hw_start) SNDRV_PCM_IOCTL_START failed:
Broken pipe
QLayout "unnamed" added to KRecFileView "unnamed", which already has a
layout
ALSA lib pcm_hw.c:494:(snd_pcm_hw_start) SNDRV_PCM_IOCTL_START failed:
Broken pipe

Recording doesn't work (as you can see why)...the problem seems to be
square at ALSA. If it is the library or the driver that is causing the
problem is unknown.
Comment 3 Colin Walters 2004-05-17 17:30:38 EDT
Can you guys try upgrading to the alsa-lib from here?
http://people.redhat.com/~walters/alsa/
Comment 4 Jerone Young 2004-05-17 23:37:51 EDT
Didn't help any...still same old problem...I had actually got those
from the alsa project web site long ago to see if they would fix the
problem. I tried your rpms anyway but no dice.

I never mentioned my specs for my home machine:
Asus K8V motherboard (onboard AD1980 souncard using via82xx ALSA driver).

Now this isn't just on my machine, I've reproduced this on other
(Intel) boxes.
Comment 5 Colin Walters 2004-07-07 14:22:28 EDT
This does look like an alsa issue.
Comment 6 Jerone Young 2004-10-26 21:24:16 EDT
I have a new board now (Abit AV8)...but I was seeing the same problem.
By adding dxs_support=4 on the via82xx driver, Gstreamer seems to work
now in FC3. So yes the ALSA driver was at fault.

Note You need to log in before you can comment on or make changes to this bug.