Bug 1212902 - Red Hat Enterprise Virtualization Hypervisor 6.6 (20150128.0.el6ev) no longer shows "release" in /etc/redhat-release
Summary: Red Hat Enterprise Virtualization Hypervisor 6.6 (20150128.0.el6ev) no longer...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-node
Version: 3.5.0
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: ovirt-3.6.0-rc
: 3.6.0
Assignee: Fabian Deutsch
QA Contact: Ying Cui
URL:
Whiteboard:
Depends On:
Blocks: 1219809
TreeView+ depends on / blocked
 
Reported: 2015-04-17 15:46 UTC by Michael Everette
Modified: 2019-07-16 11:32 UTC (History)
11 users (show)

Fixed In Version: ovirt-node-3.3.0-0.4.20150906git14a6024.el7ev
Doc Type: Bug Fix
Doc Text:
Fixed the 'redhat-release'file to include the 'release' keyword to ensure that the Red Hat Enterprise Virtualization Hypervisor version is displayed when using the command: 'cat /etc/redhat-release'
Clone Of:
: 1219809 (view as bug list)
Environment:
Last Closed: 2016-03-09 14:22:28 UTC
oVirt Team: Node
Target Upstream Version:
mgoldboi: Triaged+


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:0378 normal SHIPPED_LIVE ovirt-node bug fix and enhancement update for RHEV 3.6 2016-03-09 19:06:36 UTC
oVirt gerrit 40055 master MERGED recipe: Bring back the 'release' string Never
oVirt gerrit 40621 ovirt-3.5 MERGED recipe: Bring back the 'release' string Never

Description Michael Everette 2015-04-17 15:46:31 UTC
Description of problem:

Latest build of RHEV H 6.6 (20150128.0.el6ev) no longer shows "release" in /etc/redhat-release

From RHEVH with the 0114 ISO:

# cat /etc/redhat-release
Red Hat Enterprise Virtualization Hypervisor release 6.6 (20150114.0.el6ev)

From RHEVH with the 0128 ISO:

# cat /etc/redhat-release 
Red Hat Enterprise Virtualization Hypervisor 6.6 (20150128.0.el6ev)
Additional info:

Customer noticed this and asked why this had been removed. Not sure if this was intentional but wanted to file a bz in case this was a mistake. 

It was causing issues with their monitoring tool that looks for the exact phrasing of old.

Comment 1 Ying Cui 2015-04-21 02:28:37 UTC
I can reproduce this issue both on 6.6 (20150128.0.el6ev) and rhevh 7.1 20150416.0.el7ev.

# cat /etc/redhat-release 
Red Hat Enterprise Virtualization Hypervisor 7.1 (20150416.0.el7ev)
# ls -al /etc/redhat-release 
lrwxrwxrwx. 1 root root 23 Apr 16 13:46 /etc/redhat-release -> rhev-hypervisor-release
# cat /etc/rhev-hypervisor-release 
Red Hat Enterprise Virtualization Hypervisor 7.1 (20150416.0.el7ev)

There is no "release" shown.

Expected result:
Red Hat Enterprise Virtualization Hypervisor release 7.1 (20150416.0.el7ev)
Red Hat Enterprise Virtualization Hypervisor release 6.6 (20150128.0.el6ev)

Comment 6 Ying Cui 2015-10-12 06:29:12 UTC
Verified this bug on build:

# ls -al /etc/redhat-release 
lrwxrwxrwx. 1 root root 23 Oct  9 20:38 /etc/redhat-release -> rhev-hypervisor-release
# cat /etc/rhev-hypervisor-release
Red Hat Enterprise Virtualization Hypervisor release 7.2 (20151009.0.el7ev)
# cat /etc/redhat-release 
Red Hat Enterprise Virtualization Hypervisor release 7.2 (20151009.0.el7ev)
# rpm -qa ovirt-node
ovirt-node-3.3.0-0.13.20151008git03eefb5.el7ev.noarch

There is "release" shown.

Comment 8 errata-xmlrpc 2016-03-09 14:22:28 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0378.html


Note You need to log in before you can comment on or make changes to this bug.