Bug 121291 - OOo default external program launchers
OOo default external program launchers
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dan Williams
:
Depends On:
Blocks: FC2Target
  Show dependency treegraph
 
Reported: 2004-04-20 00:43 EDT by Warren Togami
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-03 17:44:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Warren Togami 2004-04-20 00:43:16 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040418 Firefox/0.8

Description of problem:
If you click on links within OOo, it fails because openoffice.org
lacks defined default external program launchers.  Please add the
following changes to FC2's openoffice.org:
1) REQUIRED - The patch below for
/usr/lib/ooo-1.1/share/registry/data/org/openoffice/Office/Common.xcu
would easily add workable default settings that launch the Preferred
Applications defined in gconf schema.
2) REQUIRED In order to guarantee that gnome-open exists,
openoffice.org should Requires libgnome which contains
/usr/bin/gnome-open.
3) OPTIONAL In order to guarantee that the user can modify the
Preferred Applications settings, control-center package must be
installed in order to have the "Preferred Application" chooser in the
Preferences menu.

--- Common.xcu.orig     2004-04-19 18:12:56.736013051 -1000
+++ Common.xcu  2004-04-19 18:16:00.968277007 -1000
@@ -17,19 +17,19 @@
  </node>
  <node oor:name="ExternalApps">
   <prop oor:name="http" oor:op="replace" oor:type="xs:string">
-   <value/>
+   <value>gnome-open</value>
   </prop>
   <prop oor:name="https" oor:op="replace" oor:type="xs:string">
-   <value/>
+   <value>gnome-open</value>
   </prop>
   <prop oor:name="ftp" oor:op="replace" oor:type="xs:string">
-   <value/>
+   <value>gnome-open</value>
   </prop>
   <prop oor:name="file" oor:op="replace" oor:type="xs:string">
    <value/>
   </prop>
   <prop oor:name="mailto" oor:op="replace" oor:type="xs:string">
-   <value/>
+   <value>gnome-open</value>
   </prop>
  </node>
  <node oor:name="ExternalMailer">

Wont this cause problems for KDE Only Installs?
===============================================
No.  openoffice.org already requires gnome-vfs2 which is one of the
core GNOME components, so KDE users cannot avoid GNOME entirely if
they wish to use openoffice.org.  gnome-vfs2 contains the schema for
default application launching, which for http/https protocols in FC2
are set to mozilla.  Due to reasons of lack of time and the fact that
KDE supplies no cross-desktop equivalent, using this gconf schema is a
working solution that we have today for working Preferred Applications.

KDE users in FC2 must have a certain small number of core GNOME
applications installed in order to use the Preferred Appplication
choosing functionality.  If they so wish, they may choose Konqueror
and KMail from the Preferred Applications menu and these will be
properly integrated into openoffice via gnome-open and gconf schema.

Version-Release number of selected component (if applicable):
openoffice.org-1.1.1-2

I highly encourage this to go into FC2 if you are doing any future
builds for that distribution target.
Comment 1 Warren Togami 2004-04-30 00:31:30 EDT
* Wed Apr 21 2004 Dan Williams <dcbw@redhat.com> 1.1.1-4
- First cut of Bluecurve Icons
- Use gnome-open for helper application (launching URLs and mailto:)
     (#121291)
- Use CVS snapshot of ooo-build (2004-04-21, 1.1.53pre)

This changelog says that it should have been fixed, but I am unable to
find any signs in the SRPM to confirm that it has been fixed.  Can you
please check on this again?

Note You need to log in before you can comment on or make changes to this bug.