Bug 121297 - install exited abnormally shortly after Anaconda starts
install exited abnormally shortly after Anaconda starts
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
i586 Linux
medium Severity high
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-20 01:36 EDT by Kajetan S.
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-01 18:18:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kajetan S. 2004-04-20 01:36:58 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6)
Gecko/20040113

Description of problem:
Install procedes normaly untill Anaconda starts.  I then get get:

Running anaconda, the Fedora Core system installer - please wait...
install exited abnormally
sending termination signals...done

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Boot up install CD
2.choose text install
3.everything else is default
    

Actual Results:  the screen displayed:

Running anaconda, the Fedora Core system installer - please wait...
install exited abnormally
sending termination signals...done


Expected Results:  Anaconda should have continued.

Additional info:

This happens only on an old Cyrix system.  The install has no problem
running on my Athlon XP system.

The target system (the old Cyrix box) runs RH 9 without a problem.

The DM5 sums check out for all 4 cd images
Comment 1 Jeremy Katz 2004-04-20 01:42:44 EDT
Are there any error messages from the kernel on tty4?  How much memory
in the system?
Comment 2 Kajetan S. 2004-04-20 11:12:12 EDT
The system has 64Mb of RAM.

There are no error messages from the kernel however there are lots
(screen and bit full) of audit messages. The last one being:

<3>audit(...): avc: denied { noatsecure } for pid=106
exe=/mnt/runtime/usr/bin/python scontext=system_u:system_r:kernel_t
tcontext=system_u:object_r:anaconda_t tclass=process
Comment 3 Tait Pottebaum 2004-04-20 14:56:03 EDT
I am having the same problem installing Fedora Core 1.  I get the 
same messages at the same point in the installation process.  My 
system is a K6-2 with 32MB of RAM, and I am trying a text 
installation.
Comment 4 Kajetan S. 2004-04-20 22:59:48 EDT
I would like to provide additional information on my system.  It is a
Acer Aspire 5120SR.  The Acer part number is 91.AB120.M01.  The
product web site is at http://assist.acer.com/public/system/91AB120M01.htm

The system CPU is an IBM/Cyrix 6x86.  The chipset on the MB is the ALi
M1521. There are 65Mb of EDO RAM
Comment 5 Alan Cox 2004-05-02 20:14:53 EDT
64Mb is extremely tight for the fedora install. You might get away
with it if you specify selinux=0.
Comment 6 Alan Cox 2004-05-02 20:15:11 EDT
or is it selinux=off (one of the two)
Comment 7 Kajetan S. 2004-05-08 08:31:18 EDT
I turned selinux off but the installation still aborts in exactly the
same way as always.  After trying that I added more RAM to the system.
 The system now has 128Mb.  Tried to install again, again the same
failure as always.

Please advise as to what I can try next.
Comment 8 Jeremy Katz 2004-09-22 15:27:15 EDT
Should be happier now
Comment 9 Kajetan S. 2004-09-28 22:02:53 EDT
I tried Fedora Core 3 Test 2 and i still get the same thing :(  No 
change at all.  Is there any more debugging i can do to help you guys 
out with this issue?

Note You need to log in before you can comment on or make changes to this bug.