Bug 121298 - (DRI I865) 3d app hangs the computer on Intel 82865G
(DRI I865) 3d app hangs the computer on Intel 82865G
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Arjan van de Ven
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-20 02:12 EDT by Ondrej Svetlik
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-05 06:11:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Output of lspci, dmesg and lsmod (17.11 KB, text/plain)
2004-04-20 02:19 EDT, Ondrej Svetlik
no flags Details
XFree86.0.log (69.01 KB, text/plain)
2004-04-20 02:20 EDT, Ondrej Svetlik
no flags Details
New X log (49.05 KB, text/plain)
2004-04-20 03:00 EDT, Ondrej Svetlik
no flags Details
Diag output made on 2.6.5-1.327smp (20.37 KB, text/plain)
2004-04-20 03:32 EDT, Ondrej Svetlik
no flags Details
Xorg.0.log on 2.6.5-1.327smp (45.65 KB, text/plain)
2004-04-20 03:34 EDT, Ondrej Svetlik
no flags Details
308-315 diff (binary dist) (166.30 KB, application/octet-stream)
2004-05-03 07:04 EDT, Ondrej Svetlik
no flags Details

  None (edit)
Description Ondrej Svetlik 2004-04-20 02:12:41 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040116

Description of problem:
I have these kernels installed:
kernel-2.6.4-1.305
kernel-2.6.5-1.308
kernel-2.6.5-1.315
kernel-2.6.5-1.322
kernel-2.6.5-1.326
kernel-smp-2.6.5-1.326

and only 308 works fine, some of the others (315) hang while I try to
start X and some (2.6.4, 326 and smp-326) when any 3d (opengl)
application starts. I'm not sure, what 322 build does, but I may try it.

Version-Release number of selected component (if applicable):
all 2.6 except kernel-2.6.5-1.308

How reproducible:
Always

Steps to Reproduce:
1.boot the propper kernel
2.start X (it's enough for some kernels)
3.start anything 3d (tuxracer, armagetron, radiant, et...)
    

Actual Results:  Hang, some kernels reply to ping but do nothing else,
some don't even reply to ping.

Expected Results:  No hangs at all.

Additional info:

I'm going to attach the output of some diag tools.
Comment 1 Ondrej Svetlik 2004-04-20 02:15:30 EDT
I forgot to mention, that kernel-2.6.5-1.308 works fine for both X and
3d acceleration.
Comment 2 Ondrej Svetlik 2004-04-20 02:19:07 EDT
Created attachment 99547 [details]
Output of lspci, dmesg and lsmod
Comment 3 Ondrej Svetlik 2004-04-20 02:20:48 EDT
Created attachment 99548 [details]
XFree86.0.log

This is my Xserver's output, all output was produced using the only working
kernel 2.6.5-1.308.
Comment 4 Ondrej Svetlik 2004-04-20 03:00:26 EDT
Created attachment 99549 [details]
New X log

I'm sorry, I uploaded wrong log.
Comment 5 Ondrej Svetlik 2004-04-20 03:28:57 EDT
New kernel build hangs with 3d (or drm) too. I'm going to add logs
from the new kernel.
Comment 6 Ondrej Svetlik 2004-04-20 03:32:33 EDT
Created attachment 99552 [details]
Diag output made on 2.6.5-1.327smp

lspci -v
lsmod
dmesg
Comment 7 Ondrej Svetlik 2004-04-20 03:34:48 EDT
Created attachment 99553 [details]
Xorg.0.log on 2.6.5-1.327smp
Comment 8 Ondrej Svetlik 2004-04-20 06:35:11 EDT
May be I found the reason. It seems that on all kernels except build
308, drm uses IRQ that is already in use by uhci-hcd:
> cat /proc/interrupts | grep 11:
 11:       4080          XT-PIC  uhci_hcd, uhci_hcd
> cat /var/log/Xorg.0.log | grep IRQ
(II) I810(0): [drm] dma control initialized, using IRQ 11

This output was produced using kernel build 327, smp version is very
similar, only the irq used by uhci and drm is 169.

When using build 308, IRQ 11 is unused, so DRM may use it.
Comment 9 Ondrej Svetlik 2004-04-20 08:38:41 EDT
Please, ignore the last comment, it is not true, sorry.
Comment 10 Arjan van de Ven 2004-04-20 08:42:52 EDT
are you using a graphical console by chance ??
Comment 11 Ondrej Svetlik 2004-04-20 09:00:19 EDT
What do you mean by graphical console? I use text console in standard
text (non-graphical) mode, and runlevel 5 to start X by default. I'd
like to make more tests, but it takes a while as I have to power
off/on and check the filesystem after any unsuccessful test. I may
send more information about my comuter to you (any /proc entries).
Comment 12 Ondrej Svetlik 2004-04-21 09:37:39 EDT
kernel-2.6.5-1.332 hangs too
Comment 13 Arjan van de Ven 2004-05-03 06:07:14 EDT
can you try the kernel at http://people.redhat.com/arjanv/2.6
we fixed a critical bug in this code yesterday
Comment 14 Ondrej Svetlik 2004-05-03 06:47:59 EDT
I'm sorry, still the same result with kernel-2.6.5-1.349 and
kernel-smp-2.6.5-1.349. Tell me, what was so different in the build 308.
Comment 15 Arjan van de Ven 2004-05-03 06:57:20 EDT
308 had the 4g/4g split disabled; in oder to debug bugs related to
that I need to get an actual oops trace....
Comment 16 Ondrej Svetlik 2004-05-03 07:04:13 EDT
Created attachment 99906 [details]
308-315 diff (binary dist)

I still have instalation packages in my apt cache, so I made a diff between
1.308 and 1.315.
Comment 17 Ondrej Svetlik 2004-05-03 07:09:38 EDT
Hm, I see, I may try to get it, if you tell me how. Some debug output
from the kernel? I may setup the display correctly and start the
program from the text console.
Comment 18 Ondrej Svetlik 2004-05-03 07:31:27 EDT
It doesn't work, the program starts, but it does nothing untill I
switch back to X, then it hangs :-(. I need some program to make it
crash it the text mode, don't I? I really would like to help, but I
have no idea how.
Comment 19 Arjan van de Ven 2004-05-04 13:16:20 EDT
ok then please try the 350 kernel at http://people.redhat.com/arjanv/2.6

I spent most of today debugging this after I found out one of my
testboxes has this chipset (it also has a radeon card so I never
noticed the built-in video before ;)
Comment 20 Ondrej Svetlik 2004-05-05 02:55:05 EDT
Well done, I owe you a beer :-). Just let me know when you come to see
us :-). Both smp and up versions work well.

Note You need to log in before you can comment on or make changes to this bug.