Bug 121305 - Nautilus' ftp stops working after a few transfers
Summary: Nautilus' ftp stops working after a few transfers
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-vfs   
(Show other bugs)
Version: 2
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jonathan Blandford
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-04-20 09:13 UTC by Julien Olivier
Modified: 2013-04-02 04:19 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-24 07:37:06 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Julien Olivier 2004-04-20 09:13:58 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040312

Description of problem:
I use the "connect to server" function in Nautilus to connect to an
FTP server. After I have just opened it, I can transfer files from it
to my desktop, and from my desktop to it flawlessly. But, after a few
transfers, I can't transfer file from the FTP server to Nautilus
anymore. Every time I transfer a file from the FTP server to Nautilus
(or try to open the file directly using gedit or EOG), the destination
app complains about the files being empty in some cases, and truncated
in other cases. However, transfers from Nautilus to the FTP server
still work.

Killing Nautilus and re-connecting to the server fixes the problem.

It seems to me (but I'm not sure at all) that this problem appeared
since fam was re-activated in FC2 test2...

Version-Release number of selected component (if applicable):
gnome-vfs-1.0.5-18

How reproducible:
Always

Steps to Reproduce:
1.Connect to an FTP server using ftp://login:pass@server/path
2.Get a few files from the FTP server to Nautilus or to any
gnome-vfs-enabled app
    

Actual Results:  The first files are transfered correctly, but the
latest ones (after 3 or 4 transfers) are trauncated (the beginning of
the file is missing), or empty.

Transferring files from Nautilus to the FTP server still works.

Killing Nautilus fixes the problem.

Expected Results:  ...

Additional info:

Using an updated FC2 test2

Comment 1 Julien Olivier 2004-04-24 07:37:06 UTC
I've just found a similar (still unresolved) bug in bugzilla.gnome.org.

So, if you're interested, it's here:
http://bugzilla.gnome.org/show_bug.cgi?id=140583

Is it OK to close it with the UPSTREAM resolution keyword ?


Note You need to log in before you can comment on or make changes to this bug.