Bug 1213258 - Docker 1.6 needs tar but does not require it
Summary: Docker 1.6 needs tar but does not require it
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: docker-io
Version: 21
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Lokesh Mandvekar
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-04-20 07:48 UTC by Jan Pazdziora
Modified: 2015-07-15 21:23 UTC (History)
22 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-07-15 21:23:36 UTC


Attachments (Terms of Use)

Description Jan Pazdziora 2015-04-20 07:48:21 UTC
Description of problem:

Starting container fails with fork/exec /usr/bin/tar: no such file or directory

Version-Release number of selected component (if applicable):

docker-io-1.6.0-0.1.rc6.fc21

How reproducible:

Seen once, assume deterministic.

Steps to Reproduce:
1. Build an image.
2. Run a container.

Actual results:

time="2015-04-20T03:35:12-04:00" level=fatal msg="Error response from daemon: Cannot start container 4df4e127d80dbfbf26a972a00f51085570fff275554979e80901ee93c7f69b29: [8] System error: [/usr/bin/tar -cf /var/lib/docker/tmp/4df4e127d80dbfbf26a972a00f51085570fff275554979e80901ee93c7f69b29725221613/_run.tar -C /var/lib/docker/devicemapper/mnt/4df4e127d80dbfbf26a972a00f51085570fff275554979e80901ee93c7f69b29/rootfs/run .] failed: : fork/exec /usr/bin/tar: no such file or directory" 

Expected results:

No error, container runs.

Additional info:

Comment 2 Jan Pazdziora 2015-04-24 19:23:59 UTC
docker-io-1.6.0-2.git3eac457.fc21.x86_64 (and possibly earlier builds) have the Requires: tar.

Comment 3 Russell Davies 2015-05-21 16:43:22 UTC
Same problem here.  

For example. doing 'docker run --rm swarm create' results in a ': mainFATA[0002] Error response from daemon: : exit status 2 '. with the following noted in journalctl: 

3:41 jeb docker[4548]: Cannot start container 134815e0c72cffe4debf781fd52edaba548b6c82e39e2d74aabeb425fdcd7101: [8] System error: [/usr/bin/tar -cf /var/lib/docker/tmp/134815e0c72cffe4debf781fd52edaba548b6c82e39e2d74aabeb425fdcd7101535370894/_tmp.tar -C /var/lib/docker/devicemapper/mnt/134815e0c72cffe4debf781fd52edaba548b6c82e39e2d74aabeb425fdcd7101/rootfs/tmp .] failed: /usr/bin/tar: /var/lib/docker/devicemapper/mnt/134815e0c72cffe4debf781fd52edaba548b6c82e39e2d74aabeb425fdcd7101/rootfs/tmp: Cannot open: No such file or directory
May 13 18:23:41 jeb docker[4548]: /usr/bin/tar: Error is not recoverable: exiting now
May 13 18:23:41 jeb docker[4548]: : exit status 2


Version 1.5 seems to work on Fedora 20, but fails if updated to 1.6 from the updates-testing.  

Work-around seems to be to use 1.5.  However, Fedora 21 only has 1.3 and 1.6 available in the repositories.

Comment 4 Russell Davies 2015-05-21 16:47:45 UTC
More complete diagnostics here: https://github.com/docker/swarm/issues/781#issuecomment-104158953

They says it's related to patches specific to Redhat/Fedora.

Comment 5 Marcus Ramberg 2015-05-21 22:51:31 UTC
We are seeing this last version as well with docker 1.6 on RHEL7.1 - tar is installed, so it's failing in some other way. Not making the correct folders? 

[root@ose3beta-node01 ~]# docker run openshift/hello-openshift
Timestamp: 2015-05-22 00:50:15.957307284 +0200 CEST
Code: System error

Message: [/usr/bin/tar -cf /var/lib/docker/tmp/5ad511352e37a517bc976c0492c49fe73e0d822ee61aa29ac4eee85d5c3abe24134539868/_tmp.tar -C /var/lib/docker/devicemapper/mnt/5ad511352e37a517bc976c0492c49fe73e0d822ee61aa29ac4eee85d5c3abe24/rootfs/tmp .] failed: /usr/bin/tar: /var/lib/docker/devicemapper/mnt/5ad511352e37a517bc976c0492c49fe73e0d822ee61aa29ac4eee85d5c3abe24/rootfs/tmp: Cannot chdir: No such file or directory
/usr/bin/tar: Error is not recoverable: exiting now
: exit status 2

Frames:
---
0: setupRootfs
Package: github.com/docker/libcontainer
File: rootfs_linux.go@30

Comment 6 Brenton Leanhardt 2015-05-29 19:03:25 UTC
Hi Marcus,

I believe the issue mentioned in Comment #5 is https://github.com/openshift/origin/issues/2579 and unrelated to this bug.

Comment 7 Ben Parees 2015-05-30 01:16:22 UTC
issue in comment 5 is also being tracked in bugzilla here:
https://bugzilla.redhat.com/show_bug.cgi?id=1223662

Comment 8 Daniel Walsh 2015-06-03 12:17:43 UTC
Should be fixed in docker-1.6.2/


Note You need to log in before you can comment on or make changes to this bug.