Bug 121330 - Panel segfaults on finding unreadable .desktop file
Panel segfaults on finding unreadable .desktop file
Status: CLOSED DUPLICATE of bug 120014
Product: Fedora
Classification: Fedora
Component: gnome-vfs2 (Show other bugs)
2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Alexander Larsson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-20 11:37 EDT by David Woodhouse
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:02:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Woodhouse 2004-04-20 11:37:53 EDT
Description of problem:

open("/etc/X11/applnk/System/control-panel.desktop",
O_RDONLY|O_LARGEFILE) = -1
EACCES (Permission denied)
--- SIGSEGV (Segmentation fault) @ 0 (0) ---

Version-Release number of selected component (if applicable):
gnome-panel-2.6.0-7

How reproducible:
100%

Steps to Reproduce:
1. sudo chmod og-r /etc/X11/applnk/Graphics/gv.desktop
2. restart gnome-panel
  
Actual results:

SEGV

Expected results:

Offending .desktop file should be silently ignored.
Comment 1 David Woodhouse 2004-04-20 11:40:29 EDT
Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 1073913856 (LWP 32711)]
0x402a7061 in entry_set_swap_contents ()
   from /usr/lib/gnome-vfs-2.0/modules/libmenu.so
(gdb) bt
#0  0x402a7061 in entry_set_swap_contents ()
   from /usr/lib/gnome-vfs-2.0/modules/libmenu.so
#1  0x402a7217 in entry_set_swap_contents ()
   from /usr/lib/gnome-vfs-2.0/modules/libmenu.so
#2  0x402a72a5 in entry_set_swap_contents ()
   from /usr/lib/gnome-vfs-2.0/modules/libmenu.so
#3  0x402a74df in entry_set_swap_contents ()
   from /usr/lib/gnome-vfs-2.0/modules/libmenu.so
#4  0x402a6a17 in entry_set_swap_contents ()
   from /usr/lib/gnome-vfs-2.0/modules/libmenu.so
#5  0x402a4a38 in entry_directory_load ()
   from /usr/lib/gnome-vfs-2.0/modules/libmenu.so
#6  0x402a95dd in menu_node_root_set_entry_cache ()
   from /usr/lib/gnome-vfs-2.0/modules/libmenu.so
#7  0x402a9798 in menu_node_menu_get_app_entries ()
   from /usr/lib/gnome-vfs-2.0/modules/libmenu.so
#8  0x402ada48 in menu_load () from
/usr/lib/gnome-vfs-2.0/modules/libmenu.so
#9  0x402adefb in menu_load () from
/usr/lib/gnome-vfs-2.0/modules/libmenu.so
#10 0x402adec1 in menu_load () from
/usr/lib/gnome-vfs-2.0/modules/libmenu.so
#11 0x402adec1 in menu_load () from
/usr/lib/gnome-vfs-2.0/modules/libmenu.so
#12 0x402ace9d in menu_load () from
/usr/lib/gnome-vfs-2.0/modules/libmenu.so
#13 0x402ad2cd in menu_load () from
/usr/lib/gnome-vfs-2.0/modules/libmenu.so
#14 0x402ad345 in menu_load () from
/usr/lib/gnome-vfs-2.0/modules/libmenu.so
Comment 2 David Woodhouse 2004-04-20 11:48:26 EDT

*** This bug has been marked as a duplicate of 120014 ***
Comment 3 Red Hat Bugzilla 2006-02-21 14:02:41 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.