Bug 1213427 - err:module:import_dll Library libwinpthread-1.dll (which is needed by L"C:\\windows\\mono\\mono-2.0\\bin\\libmono-2.0-x86.dll") not found
Summary: err:module:import_dll Library libwinpthread-1.dll (which is needed by L"C:\\w...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: wine-mono
Version: 22
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Andreas Bierfert
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-04-20 14:19 UTC by Mikhail
Modified: 2015-06-21 00:19 UTC (History)
3 users (show)

Fixed In Version: wine-mono-4.5.6-4.fc22
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-06-21 00:19:51 UTC
Type: Bug


Attachments (Terms of Use)

Description Mikhail 2015-04-20 14:19:32 UTC
Description of problem:

[mikhail@corei5 ~]$ .wine/drive_c/Program\ Files/VMware/Infrastructure/Virtual\ Infrastructure\ Client/Launcher/VpxClient.exe 
fixme:mscoree:ConfigFileHandler_startElement Unknown element L"configSections" in state 2
fixme:mscoree:ConfigFileHandler_startElement Unknown element L"section" in state 6
fixme:mscoree:ConfigFileHandler_startElement Unknown element L"system.net" in state 2
fixme:mscoree:ConfigFileHandler_startElement Unknown element L"connectionManagement" in state 6
fixme:mscoree:ConfigFileHandler_startElement Unknown element L"clear" in state 6
fixme:mscoree:ConfigFileHandler_startElement Unknown element L"add" in state 6
fixme:mscoree:ConfigFileHandler_startElement Unknown element L"appSettings" in state 2
fixme:mscoree:ConfigFileHandler_startElement Unknown element L"add" in state 6
fixme:mscoree:ConfigFileHandler_startElement Unknown element L"add" in state 6
fixme:mscoree:ConfigFileHandler_startElement Unknown element L"add" in state 6
fixme:mscoree:ConfigFileHandler_startElement Unknown element L"add" in state 6
fixme:mscoree:ConfigFileHandler_startElement Unknown element L"add" in state 6
fixme:mscoree:ConfigFileHandler_startElement Unknown element L"add" in state 6
fixme:mscoree:ConfigFileHandler_startElement Unknown element L"cmdlineFallback" in state 2
fixme:mscoree:ConfigFileHandler_startElement Unknown element L"generatePublisherEvidence" in state 4
err:module:import_dll Library libwinpthread-1.dll (which is needed by L"C:\\windows\\mono\\mono-2.0\\bin\\libmono-2.0-x86.dll") not found
err:mscoree:load_mono Could not load Mono into this process
[mikhail@corei5 ~]$ wine --version
wine-1.7.40 (Staging)


Please see also here: https://bugs.wine-staging.com/show_bug.cgi?id=230

Comment 1 Mikhail 2015-04-20 14:20:53 UTC
> Michael Müller 2015-04-17 15:43:38 CEST
> How did you install mono? We do not include mono and this looks like a broken 
> mono build shipped by your distribution. Seems like they forgot to put
> libwinpthread-1.dll into the installer or they should have linked statically
> against this library. The libwinpthread library is part of MinGW and not part 
> of Wine.

Comment 2 Fedora Update System 2015-04-22 20:40:36 UTC
wine-mono-4.5.6-3.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/wine-mono-4.5.6-3.fc22

Comment 3 Fedora Update System 2015-04-23 16:04:14 UTC
Package wine-mono-4.5.6-3.fc22:
* should fix your issue,
* was pushed to the Fedora 22 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing wine-mono-4.5.6-3.fc22'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-6699/wine-mono-4.5.6-3.fc22
then log in and leave karma (feedback).

Comment 4 Mikhail 2015-04-23 23:25:20 UTC
I do not see that the problem is gone after update.

$ rpm -q wine-mono
wine-mono-4.5.6-3.fc22.noarch

$ .wine/drive_c/Program\ Files\ \(x86\)/VMware/Infrastructure/Virtual\ Infrastructure\ Client/Launcher/VpxClient.exe 
fixme:winediag:start_process Wine Staging is a testing version containing experimental patches.
fixme:winediag:start_process Please report bugs at http://bugs.wine-staging.com (instead of winehq.org).
fixme:ntoskrnl:MmGetSystemRoutineAddress L"EtwRegisterClassicProvider" not found
fixme:ntoskrnl:IoWMIRegistrationControl (0x44a860 2147549185) stub
fixme:ntoskrnl:IoCsqInitialize (0x13fc8 0x44730c 0x44735c 0x447394 0x4473ec 0x447410 0x447424) stub
fixme:ntoskrnl:KeInitializeEvent stub: 0x13f50 0 0
fixme:ntoskrnl:KeInitializeEvent stub: 0x13f68 0 0
fixme:ntoskrnl:KeInitializeEvent stub: 0x13f80 0 0
fixme:ntoskrnl:IoRegisterPlugPlayNotification (2 0 0x449310 0x7ffb1516d5e0 0x4468e4 0x13ae8 0x13fb8) stub
fixme:ntoskrnl:IoRegisterPlugPlayNotification (2 1 0x4492b0 0x7ffb1516d5e0 0x446cf0 0x13ae8 0x13fc0) stub
fixme:ntoskrnl:ObReferenceObjectByHandle stub: 0x4c 1f03ff (nil) 0 0x13f98 (nil)
fixme:ntoskrnl:KeWaitForMultipleObjects stub: 2, 0x67e4e0, 1, 0, 0, 0, (nil), (nil)
fixme:advapi:GetExplicitEntriesFromAclW 0x2b720 0x23f7a8 0x23f728
fixme:advapi:GetExplicitEntriesFromAclW 0x2b9d0 0x23f528 0x23f4a8
fixme:advapi:GetExplicitEntriesFromAclW 0x2b9d0 0x23f528 0x23f4a8
fixme:advapi:GetExplicitEntriesFromAclW 0x2b760 0x23f798 0x23f718
fixme:advapi:GetExplicitEntriesFromAclW 0x2b760 0x23f798 0x23f718
fixme:msvcrt:MSVCRT__wsopen_s : pmode 0x01a0 ignored
fixme:ntoskrnl:IoGetDeviceObjectPointer stub: L"\\??\\HCD0" 1f01ff 0x43dd40 0x43dd30
fixme:ntoskrnl:ObfReferenceObject ((nil)): stub
fixme:ntoskrnl:ObDereferenceObject ((nil)): stub
fixme:ntoskrnl:IoGetDeviceObjectPointer stub: L"\\??\\HCD1" 1f01ff 0x43dd40 0x43dd30
fixme:ntoskrnl:ObfReferenceObject ((nil)): stub
fixme:ntoskrnl:ObDereferenceObject ((nil)): stub
fixme:ntoskrnl:IoGetDeviceObjectPointer stub: L"\\??\\HCD2" 1f01ff 0x43dd40 0x43dd30
fixme:ntoskrnl:ObfReferenceObject ((nil)): stub
fixme:ntoskrnl:ObDereferenceObject ((nil)): stub
fixme:ntoskrnl:IoGetDeviceObjectPointer stub: L"\\??\\HCD3" 1f01ff 0x43dd40 0x43dd30
fixme:ntoskrnl:ObfReferenceObject ((nil)): stub
fixme:ntoskrnl:ObDereferenceObject ((nil)): stub
fixme:ntoskrnl:IoGetDeviceObjectPointer stub: L"\\??\\HCD4" 1f01ff 0x43dd40 0x43dd30
fixme:ntoskrnl:ObfReferenceObject ((nil)): stub
fixme:ntoskrnl:ObDereferenceObject ((nil)): stub
fixme:ntoskrnl:IoGetDeviceObjectPointer stub: L"\\??\\HCD5" 1f01ff 0x43dd40 0x43dd30
fixme:ntoskrnl:ObfReferenceObject ((nil)): stub
fixme:ntoskrnl:ObDereferenceObject ((nil)): stub
fixme:ntoskrnl:IoGetDeviceObjectPointer stub: L"\\??\\HCD6" 1f01ff 0x43dd40 0x43dd30
fixme:ntoskrnl:ObfReferenceObject ((nil)): stub
fixme:ntoskrnl:ObDereferenceObject ((nil)): stub
fixme:ntoskrnl:IoGetDeviceObjectPointer stub: L"\\??\\HCD7" 1f01ff 0x43dd40 0x43dd30
fixme:ntoskrnl:ObfReferenceObject ((nil)): stub
fixme:ntoskrnl:ObDereferenceObject ((nil)): stub
fixme:ntoskrnl:IoGetDeviceObjectPointer stub: L"\\??\\HCD8" 1f01ff 0x43dd40 0x43dd30
fixme:ntoskrnl:ObfReferenceObject ((nil)): stub
fixme:ntoskrnl:ObDereferenceObject ((nil)): stub
fixme:ntoskrnl:IoGetDeviceObjectPointer stub: L"\\??\\HCD9" 1f01ff 0x43dd40 0x43dd30
fixme:ntoskrnl:ObfReferenceObject ((nil)): stub
fixme:ntoskrnl:ObDereferenceObject ((nil)): stub
fixme:ntoskrnl:IoGetDeviceObjectPointer stub: L"\\??\\HCD:" 1f01ff 0x43dd40 0x43dd30
fixme:ntoskrnl:ObfReferenceObject ((nil)): stub
fixme:ntoskrnl:ObDereferenceObject ((nil)): stub
fixme:ntoskrnl:IoGetDeviceObjectPointer stub: L"\\??\\HCD;" 1f01ff 0x43dd40 0x43dd30
fixme:ntoskrnl:ObfReferenceObject ((nil)): stub
fixme:ntoskrnl:ObDereferenceObject ((nil)): stub
fixme:ntoskrnl:IoGetDeviceObjectPointer stub: L"\\??\\HCD<" 1f01ff 0x43dd40 0x43dd30
fixme:ntoskrnl:ObfReferenceObject ((nil)): stub
fixme:ntoskrnl:ObDereferenceObject ((nil)): stub
fixme:ntoskrnl:IoGetDeviceObjectPointer stub: L"\\??\\HCD=" 1f01ff 0x43dd40 0x43dd30
fixme:ntoskrnl:ObfReferenceObject ((nil)): stub
fixme:ntoskrnl:ObDereferenceObject ((nil)): stub
fixme:ntoskrnl:IoGetDeviceObjectPointer stub: L"\\??\\HCD>" 1f01ff 0x43dd40 0x43dd30
fixme:ntoskrnl:ObfReferenceObject ((nil)): stub
fixme:ntoskrnl:ObDereferenceObject ((nil)): stub
fixme:ntoskrnl:IoGetDeviceObjectPointer stub: L"\\??\\HCD?" 1f01ff 0x43dd40 0x43dd30
fixme:ntoskrnl:ObfReferenceObject ((nil)): stub
fixme:ntoskrnl:ObDereferenceObject ((nil)): stub
wine: Call from 0x7ffb1bfbe6f4 to unimplemented function ntoskrnl.exe.KeAcquireSpinLockRaiseToDpc, aborting
wine: Unimplemented function ntoskrnl.exe.KeAcquireSpinLockRaiseToDpc called at address 0x7ffb1bfbe6f4 (thread 0018), starting debugger...
fixme:service:scmdatabase_autostart_services Auto-start service L"VMUSBArbService" failed to start: 1053
fixme:mscoree:ConfigFileHandler_startElement Unknown element L"configSections" in state 2
fixme:mscoree:ConfigFileHandler_startElement Unknown element L"section" in state 6
fixme:mscoree:ConfigFileHandler_startElement Unknown element L"system.net" in state 2
fixme:mscoree:ConfigFileHandler_startElement Unknown element L"connectionManagement" in state 6
fixme:mscoree:ConfigFileHandler_startElement Unknown element L"clear" in state 6
fixme:mscoree:ConfigFileHandler_startElement Unknown element L"add" in state 6
fixme:mscoree:ConfigFileHandler_startElement Unknown element L"appSettings" in state 2
fixme:mscoree:ConfigFileHandler_startElement Unknown element L"add" in state 6
fixme:mscoree:ConfigFileHandler_startElement Unknown element L"add" in state 6
fixme:mscoree:ConfigFileHandler_startElement Unknown element L"add" in state 6
fixme:mscoree:ConfigFileHandler_startElement Unknown element L"add" in state 6
fixme:mscoree:ConfigFileHandler_startElement Unknown element L"add" in state 6
fixme:mscoree:ConfigFileHandler_startElement Unknown element L"add" in state 6
fixme:mscoree:ConfigFileHandler_startElement Unknown element L"cmdlineFallback" in state 2
fixme:mscoree:ConfigFileHandler_startElement Unknown element L"generatePublisherEvidence" in state 4
err:module:import_dll Library libwinpthread-1.dll (which is needed by L"C:\\windows\\mono\\mono-2.0\\bin\\libmono-2.0-x86.dll") not found
err:mscoree:load_mono Could not load Mono into this process

Comment 5 Michael Cronenworth 2015-04-24 01:57:32 UTC
1. Please do not post large logs in comments. Use attachments. Also, do not post large logs in Bodhi.

2. You *must* use either a) a fresh WINEPREFIX or b) delete C:\windows\mono to have mono reinstalled with the new binaries.

A yum update does not put the new binaries in your local WINEPREFIX unless it is a new major release.

Comment 6 Mikhail 2015-04-24 05:53:26 UTC
(In reply to Michael Cronenworth from comment #5)
> 1. Please do not post large logs in comments. Use attachments. Also, do not
> post large logs in Bodhi.
> 
> 2. You *must* use either a) a fresh WINEPREFIX or b) delete C:\windows\mono
> to have mono reinstalled with the new binaries.

I am delete folder ".wine" for testing.

Comment 7 Fedora Update System 2015-04-26 13:00:32 UTC
Package wine-mono-4.5.6-3.fc22:
* should fix your issue,
* was pushed to the Fedora 22 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing wine-mono-4.5.6-3.fc22'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-6699/wine-mono-4.5.6-3.fc22
then log in and leave karma (feedback).

Comment 8 Bas Mevissen 2015-06-10 13:22:11 UTC
Package  wine-mono-4.5.6-3.fc22.noarch.rpm doesn't seem to be available in Koji. (link gives a 404). However, wine-mono-4.5.6-3.fc23.noarch.rpm is there and seems to be fine. At least, I could now run the application in Wine that I wanted to run.

Comment 9 Mikhail 2015-06-10 13:43:17 UTC
[mikhail@corei5 ~]$ .wine/drive_c/Program\ Files/VMware/Infrastructure/Virtual\ Infrastructure\ Client/Launcher/VpxClient.exe 
fixme:mscoree:ConfigFileHandler_startElement Unknown element L"configSections" in state 2
fixme:mscoree:ConfigFileHandler_startElement Unknown element L"section" in state 6
fixme:mscoree:ConfigFileHandler_startElement Unknown element L"system.net" in state 2
fixme:mscoree:ConfigFileHandler_startElement Unknown element L"connectionManagement" in state 6
fixme:mscoree:ConfigFileHandler_startElement Unknown element L"clear" in state 6
fixme:mscoree:ConfigFileHandler_startElement Unknown element L"add" in state 6
fixme:mscoree:ConfigFileHandler_startElement Unknown element L"appSettings" in state 2
fixme:mscoree:ConfigFileHandler_startElement Unknown element L"add" in state 6
fixme:mscoree:ConfigFileHandler_startElement Unknown element L"add" in state 6
fixme:mscoree:ConfigFileHandler_startElement Unknown element L"add" in state 6
fixme:mscoree:ConfigFileHandler_startElement Unknown element L"add" in state 6
fixme:mscoree:ConfigFileHandler_startElement Unknown element L"add" in state 6
fixme:mscoree:ConfigFileHandler_startElement Unknown element L"add" in state 6
fixme:mscoree:ConfigFileHandler_startElement Unknown element L"cmdlineFallback" in state 2
fixme:mscoree:ConfigFileHandler_startElement Unknown element L"generatePublisherEvidence" in state 4
err:module:import_dll Library libwinpthread-1.dll (which is needed by L"C:\\windows\\mono\\mono-2.0\\bin\\libmono-2.0-x86.dll") not found
err:mscoree:load_mono Could not load Mono into this process
[mikhail@corei5 ~]$ rpm -q wine-mono
wine-mono-4.5.6-3.fc22.noarch

VMWare client still write message: "err:module:import_dll Library libwinpthread-1.dll (which is needed by L"C:\\windows\\mono\\mono-2.0\\bin\\libmono-2.0-x86.dll") not found err:mscoree:load_mono Could not load Mono into this process"

Comment 10 Fedora Update System 2015-06-10 15:33:09 UTC
wine-mono-4.5.6-4.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/wine-mono-4.5.6-4.fc22

Comment 11 Mikhail 2015-06-14 14:55:22 UTC
Update wine-mono-4.5.6-4 fix this bug.

But I'm concerned about why it is impossible make to the current directory .wine updated automatically?

It's not right for every update package wine-mono, recreate and .wine reinstall all programs.

Comment 12 Fedora Update System 2015-06-21 00:19:51 UTC
wine-mono-4.5.6-4.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.