Bug 1213545 - [packaging] missing dependencies for openstack-glance-common: python-glance
Summary: [packaging] missing dependencies for openstack-glance-common: python-glance
Keywords:
Status: CLOSED EOL
Alias: None
Product: RDO
Classification: Community
Component: openstack-glance
Version: trunk
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: Kilo
Assignee: hguemar
QA Contact: nlevinki
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-04-20 17:59 UTC by Christian Berendt
Modified: 2016-05-19 15:49 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-05-19 15:49:34 UTC


Attachments (Terms of Use)

Description Christian Berendt 2015-04-20 17:59:58 UTC
It looks like openstack-glance-api and openstack-glance-registry do not 
longer require python-glance?

openstack-glance-api and openstack-glance-registry only require 
openstack-glance-common.

openstack-glance-api and openstack-glance-registry are not workable 
without python-glance. For me it does not makes sense to not install/require  
python-glance with openstack-glance-api and openstack-glance-registry.

Comment 1 Suraj Narwade 2016-05-19 09:50:09 UTC
Required dependency 'python-glance' is already added, here is respctive link for that:
https://github.com/rdo-packages/glance-distgit/blob/rpm-master/openstack-glance.spec

Comment 2 Chandan Kumar 2016-05-19 15:49:34 UTC
This bug is against a Version which has reached End of Life.
If it's still present in supported release (http://releases.openstack.org), please update Version and reopen.


Note You need to log in before you can comment on or make changes to this bug.