Bug 121369 - need to remove policy compatibility code
need to remove policy compatibility code
Product: Fedora
Classification: Fedora
Component: policy (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Ben Levenson
Depends On:
Blocks: FC2Blocker
  Show dependency treegraph
Reported: 2004-04-20 15:50 EDT by Bill Nottingham
Modified: 2014-03-16 22:44 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2004-05-28 09:11:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Bill Nottingham 2004-04-20 15:50:01 EDT
install.log sez:

Installing policy-1.11.2-12.noarch
cat: /selinux/policyvers: No such file or directory
Can't open '/etc/security/selinux/plicy.': no such file or directory
Comment 1 Colin Walters 2004-04-20 16:59:57 EDT
Hmm.  You don't have /selinuxfs mounted?
Comment 2 Bill Nottingham 2004-04-20 17:25:44 EDT
In the installer? Don't think so.
Comment 3 Colin Walters 2004-04-20 17:31:14 EDT
I just chatted with Jeremy, he agreed to mount /selinuxfs during

However this issue is due to the policy backwards compatibility code,
which we want to get rid of.  I'm going to investigate doing that too.
Comment 4 Jeremy Katz 2004-04-20 19:55:21 EDT
Added hack in anaconda to mount selinux.  Back to policy package for a
real eventual fix 
Comment 5 Daniel Walsh 2004-04-22 17:10:25 EDT
Until a new way of handling backwards compatability this is required
so that if we upgrade the kernel version we can handle old and new
kernels.  We should fix the code to not fail if the kernel does not
support selinux though.

Checking to see if /selinux/policvers exists in policy.spec
fixed in policy-1.11.2-18

Note You need to log in before you can comment on or make changes to this bug.