Bug 1213698 - lxc vm failed to start when set numatune in vm
Summary: lxc vm failed to start when set numatune in vm
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: libvirt
Version: 7.2
Hardware: x86_64
OS: Linux
low
low
Target Milestone: rc
: ---
Assignee: Libvirt Maintainers
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-04-21 05:35 UTC by Luyao Huang
Modified: 2015-11-19 06:29 UTC (History)
5 users (show)

Fixed In Version: libvirt-1.2.15-1.el7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-11-19 06:29:38 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:2202 0 normal SHIPPED_LIVE libvirt bug fix and enhancement update 2015-11-19 08:17:58 UTC

Description Luyao Huang 2015-04-21 05:35:57 UTC
Description of problem:
lxc vm failed to start when set numatune in vm

Version-Release number of selected component (if applicable):
libvirt-1.2.14-1.el7.x86_64

How reproducible:
100%

Steps to Reproduce:
1.
virsh # dumpxml helloworld
...
  <numatune>
    <memory mode='interleave' nodeset='0'/>
  </numatune>
...

virsh # start helloworld
error: Failed to start domain helloworld
error: internal error: guest failed to start: Unknown failure in libvirt_lxc startup

2. set cpuset without numatune settings
virsh # dumpxml helloworld
  <vcpu placement='static' cpuset='1-3'>2</vcpu>
  <resource>
    <partition>/machine</partition>
  </resource>


virsh # start helloworld
error: Failed to start domain helloworld
error: internal error: guest failed to start: Invalid value '1-3' for 'cpuset.mems': Invalid argument

3.

Actual results:
vm cannot start in this two case

Expected results:

vms start success

Additional info:

Some patches to fix this issue:

commit 930e8697a5b66989fbf56a5e38cfaf1378a1c59e
Author: Luyao Huang <lhuang@redhat.com>
Date:   Mon Apr 20 15:33:31 2015 +0200

    lxc: fix starting a domain with non-strict numa memory mode

commit 461eafecfade36555e44378c34568caf55c5cc8a
Author: Luyao Huang <lhuang@redhat.com>
Date:   Fri Apr 3 18:11:15 2015 +0800

    lxc: fix starting a domain with a cpuset but no numatune

v1.2.14-226-g930e869

Comment 2 yisun 2015-06-03 11:25:33 UTC
Verified.

versions:
libvirt-1.2.15-2.el7.x86_64
============================
 <numatune> node included. 
verify steps:
============================
1. # virsh -c lxc:///
Welcome to virsh, the virtualization interactive terminal.

Type:  'help' for help with commands
       'quit' to quit
2. virsh # list
 Id    Name                           State
----------------------------------------------------
 26954 lxc1                           running
3. edit lxc1's xml and add following segment
virsh # edit lxc1
 <numatune>
    <memory mode='interleave' nodeset='0'/>
  </numatune>
4. virsh # destroy lxc1; start lxc1
Domain lxc1 destroyed

Domain lxc1 started
============================
set cpuset without numatune settings
verify steps:
============================
1. # virsh -c lxc:///
Welcome to virsh, the virtualization interactive terminal.

Type:  'help' for help with commands
       'quit' to quit
2. virsh # list
 Id    Name                           State
----------------------------------------------------
 26954 lxc1                           running
3. edit lxc1's xml and add following segment (remove previously added <numatune>
virsh # edit lxc1
...
 <vcpu placement='static' cpuset='1-3'>2</vcpu>
...
4. virsh # destroy lxc1; start lxc1
Domain lxc1 destroyed

Domain lxc1 started

Comment 4 errata-xmlrpc 2015-11-19 06:29:38 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2202.html


Note You need to log in before you can comment on or make changes to this bug.