Bug 121384 - Anaconda fails while partitioning
Anaconda fails while partitioning
Status: CLOSED DUPLICATE of bug 121266
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
powerpc Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
: 1213830 1213831 (view as bug list)
Depends On:
Blocks: fedora-ppc
  Show dependency treegraph
 
Reported: 2004-04-20 20:04 EDT by Thomas Gordon
Modified: 2015-04-22 12:37 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:02:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thomas Gordon 2004-04-20 20:04:22 EDT
Description of problem:
In text mode install from NFS image (booting from boot.iso) I chose to
replace all partitions on a drive with all linux partitions (no mac
stuff).  After package selection I get an error that says something
like "partition map does not exist" and i chose "fix" and i get an error.

Version-Release number of selected component (if applicable):
rawhide 20040418/9 one of those...

How reproducible:
Every time


Steps to Reproduce:
1. Netboot-install (text)

  
Actual results:
An unhandled exception has occurred.  This is most likely a bug...

...Traceback (most recent call last):

File "/usr/bin/anaconda", line 1129, in ? intf.run(id, dispatch,
configFileData)
File "/usr/lib/anaconda/text.py", line 475, in run dispatch.gotoNext
elf.moveStep()
File "/usr/lib/anaconda/dispatch.py", line 237, in moveStep rc-
apply(func, self.bindArgs(args))
File "/usr/lib/anaconda/packages.py", line 531, in turnOnFilesystems
diskset.savePartitions ()
File "/usr/lib/anaconda/partedUtils.py", line 692, in savePartitions
disk.commit()
error: Error: Unable to satisfy all contraints on the partition

Expected results:
download images from NFS mount and being install

Additional info:
Comment 1 Colin Charles 2004-08-30 12:39:13 EDT
Just did an install from rawhide latest (as we approach fc3test2), and
this is not a visible bug

Thomas, mind checking to see if this still bites you with the latest
installer?
Comment 2 Colin Charles 2004-09-26 01:03:38 EDT
It bites again (0925 tree). Autopartition, with either remove all
linux partitions or remove all partitions on the system fails on my
iMac. Manually partitioning it however, just works
Comment 3 David Woodhouse 2005-02-18 22:23:04 EST

*** This bug has been marked as a duplicate of 121266 ***
Comment 4 Red Hat Bugzilla 2006-02-21 14:02:42 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.
Comment 5 Richa 2015-04-22 08:24:51 EDT
*** Bug 1213831 has been marked as a duplicate of this bug. ***
Comment 6 Richa 2015-04-22 12:23:23 EDT
*** Bug 1213830 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.