Bug 121403 - non-Xft Mozilla crashes X trying to display binary garbage
non-Xft Mozilla crashes X trying to display binary garbage
Status: CLOSED DUPLICATE of bug 145546
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
rawhide
i386 Linux
medium Severity high
: ---
: ---
Assigned To: X/OpenGL Maintenance List
http://bugzilla.mozilla.org/attachmen...
: Triaged
Depends On:
Blocks: FC4Target
  Show dependency treegraph
 
Reported: 2004-04-21 01:46 EDT by Andrew Schultz
Modified: 2007-11-30 17:10 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:02:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
lsmod output (2.20 KB, text/plain)
2004-04-21 21:50 EDT, Andrew Schultz
no flags Details
X config file (3.07 KB, text/plain)
2004-04-21 21:51 EDT, Andrew Schultz
no flags Details
/var/log/messages (67.15 KB, text/plain)
2004-04-21 21:57 EDT, Andrew Schultz
no flags Details
X log (71.51 KB, text/plain)
2004-04-21 21:59 EDT, Andrew Schultz
no flags Details
strace startx 2> stracestartx.txt (28.06 KB, text/plain)
2004-06-06 06:46 EDT, Captain
no flags Details
strace mozilla 2> stracemozilla.txt (11.96 KB, text/plain)
2004-06-06 06:47 EDT, Captain
no flags Details
Xorg log file (34.23 KB, text/plain)
2004-11-18 10:11 EST, Dawid Gajownik
no flags Details
Mozilla's profile (9.67 KB, application/octet-stream)
2004-11-18 15:06 EST, Dawid Gajownik
no flags Details

  None (edit)
Description Andrew Schultz 2004-04-21 01:46:30 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8a)
Gecko/20040419

Description of problem:
When loading the URL (action=view probably also crashes, but I haven't
tried it), X crashes.  With the action=edit page, it will try to load
the binary in the iframe (it's a zip and I mis-identified the
attachment as text/html).

I've tested with current Mozilla trunk (gtk1, not xft).

Version-Release number of selected component (if applicable):
xorg-x11-6.7.0-0.5

How reproducible:
Always

Steps to Reproduce:
1. grab a Mozilla nightly (1.6 with gtk1 probably does the same)
2. load http://bugzilla.mozilla.org/attachment.cgi?id=146647&action=edit

Actual Results:
seg fault.  Useful info from XFree86.0.log is:
Fatal server error:
Caught signal 11.  Server aborting

Expected Results:  display binary garbage
Comment 1 Mike A. Harris 2004-04-21 18:51:16 EDT
Attach your X server config file and complete log file,
/var/log/messages, and the output of "lsmod" to the report using
the bugzilla file attachment feature below.

Once this information is provided, we can review the issue further.

Thanks in advance.
Comment 2 Andrew Schultz 2004-04-21 21:50:45 EDT
Created attachment 99618 [details]
lsmod output

ltmodem/ltserial is for my modem (Lucent chipset)
Comment 3 Andrew Schultz 2004-04-21 21:51:35 EDT
Created attachment 99619 [details]
X config file
Comment 4 Andrew Schultz 2004-04-21 21:57:18 EDT
Created attachment 99621 [details]
/var/log/messages

Apr 21 21:52:28 localhost gdm[24657]: gdm_slave_xioerror_handler: Fatal X error
- Restarting :0

I'm running the FC1 kernel because the RH 2.6 kernel can't handle my VIA SATA.
Comment 5 Andrew Schultz 2004-04-21 21:59:22 EDT
Created attachment 99622 [details]
X log

Fatal server error:
Caught signal 11.  Server aborting
Comment 6 Andrew Schultz 2004-04-21 22:04:24 EDT
I tested some other Mozilla builds.
Mozilla 1.6 (gtk1/no xft) did not crash X
Mozilla 1.7a (gtk1/no xft) did crash X.
Mozilla trunk with xft did not crash X.
Comment 8 Captain 2004-05-27 13:32:06 EDT
X.org changed the URL for bugzilla, so here is the updated URL for the
X bugzilla:
http://freedesktop.org/bugzilla/show_bug.cgi?id=659
Comment 9 Captain 2004-06-06 06:46:19 EDT
Created attachment 100902 [details]
strace startx 2> stracestartx.txt

I figured out how to use strace for this bug.
On my Fedora-box:
failsave-terminal
# telinit 3
# strace startx 2> stracestartx.txt
Opened mozilla, loaded the crashing-page, X crashed...
Comment 10 Captain 2004-06-06 06:47:02 EDT
Created attachment 100903 [details]
strace mozilla 2> stracemozilla.txt

This is the strace when logged in in GNOME and calling mozilla from the
terminal.
strace mozilla 2> stracemozilla.txt
Comment 11 Andrew Schultz 2004-06-06 09:15:24 EDT
startx and mozilla are both shell scripts, and that's all you've
straced (not the binary programs).  an strace of the binaries would
likely be enormous and probably useful.
Comment 12 Andrew Schultz 2004-06-06 13:09:36 EDT
> startx and mozilla are both shell scripts, and that's all you've
> straced (not the binary programs).  an strace of the binaries would
> likely be enormous and probably useful.

"probably not useful"
Comment 13 Captain 2004-07-04 10:35:25 EDT
Mike, do you have any updates for us on this issue ?
Thank you, Hannes.
Comment 14 Mike A. Harris 2004-07-04 10:43:46 EDT
Thanks for filing this bug upstream.  We will track it in the
upstream bugzilla now, and provide any status updates there should
the status change or a fix become available.

Thanks again.

Setting status to "UPSTREAM" for tracking at xorg bugzilla.
Comment 15 Captain 2004-07-04 11:11:51 EDT
Thank you Mike!

Something I found out last month or so:
When disabling XFT on Mozilla 1.6 (that one that came with FC2)
# GDK_USE_XFT=0 /usr/bin/mozilla
the X server doesn't crash.

Andrew Schultz posted earlier, that my straces are not useful.
Mike, if you can give me some hints on what to try or to look at I can
try to find out more. (i.e. where to implement strace etc...)
If you've got a minute, I'd be glad to hear from you at my email I use
for this bugzilla. Thank you, Hannes.
Comment 16 Captain 2004-07-09 14:29:32 EDT
FYI, I just updated all xorg packages to 6.7.0-5 as it appeared in
up2date. The problem still persists...
Comment 17 Mike A. Harris 2004-09-01 07:34:51 EDT
Status update:  I've reviewed the upstream bug for this in X.Org
bugzilla <http://freedesktop.org/bugzilla/show_bug.cgi?id=659>,
and there has been no resolution yet for this issue.

Please test the latest X.Org release from our rawhide xorg-x11
packages, and indicate wether the issue still exists in rawhide
or not.  Please update the upstream bug report with this also.

You may also find the xorg or mozilla mailing lists helpful if you
are debugging the issue yourself and require assistance.

Hope this helps.

Comment 18 Mike A. Harris 2004-09-01 07:35:57 EDT
Setting status to "NEEDINFO", awaiting status update from reporter
on rawhide testing.
Comment 19 Andrew Schultz 2004-09-01 20:29:15 EDT
I upgraded to xorg-x11-6.7.99.903-2 and it still crashes loading the
given URL.
Comment 20 Chris Kuivenhoven 2004-09-04 17:52:57 EDT
I haven't tested this previously, but using the current rawhide
packages (mozilla-1.7.2-0.3.0 and xorg-x11-6.7.99.903.5) does NOT
crash or cause me any problems when loading the test URL provided in
Andrew's first post.

-Chris Kuivenhoven
Comment 21 Andrew Schultz 2004-09-04 19:03:20 EDT
Chris: see comment 6.  all fedora-packaged Mozillas use gtk2/xft,
which does not trigger this bug.  You should see the bug if you
download a gtk1 build from mozilla.org
Comment 22 Chris Kuivenhoven 2004-09-04 23:19:00 EDT
My apologies, I was misreading that comment. Thanks for straightening
me out. :)

-Chris Kuivenhoven
Comment 23 Dawid Gajownik 2004-11-18 10:11:37 EST
Created attachment 106961 [details]
Xorg log file

I see this bug in FC3 (xorg-x11-6.8.1-12.FC3.1).

Testcase:
https://bugzilla.redhat.com/bugzilla/attachment.cgi?id=106786&action=view
https://bugzilla.redhat.com/bugzilla/attachment.cgi?id=106799&action=view

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8a4) Gecko/20040927

Unfortunately, I'm not able to reproduce it on a newly created Mozilla's
profile - X server crashes only with my 6 month old one :/
Comment 24 Dawid Gajownik 2004-11-18 15:06:09 EST
Created attachment 106982 [details]
Mozilla's profile

Well, I've made a small investigation and I think that I know the way how to
reproduce this bug :-)

1. Install Microsoft Truetype Fonts

You can grab it from here →
http://www.mjmwired.net/resources/mjm-fedora-fc3.shtml#ttf or
http://corefonts.sourceforge.net/

Do not install this rpm, just extract fonts from the package using mc to some
directory (in other case you would have to change path to TTF fonts in
Mozilla's configuration file).

Open KDE's Control Center, search menu for the font installer and change your
role to admin.

Install extracted fonts to the TTF directory (make shure that they where
installed in /usr/local/share/fonts/TTF/).

2. adduser fedora (in other case you would have to remove file
~/.mozilla/appreg).

3. Install this →
http://ftp.mozilla.org/pub/mozilla.org/mozilla/releases/mozilla1.8a4/mozilla-i686-pc-linux-gnu-1.8a4-installer.tar.gz


4. Log in as "fedora" user, download attached Mozilla's profile and extract.
Make shure that /home/fedora/.mozilla was created.

5. Run /usr/local/mozilla/mozilla binary

6. In personal toolbar there are links to pages which crashes X server. Click
them and log in once again ;-)

Additional info:
I do not know whether it's important but I have recompiled freetype with
enabled bytecode interpreter.

Oh, I have almost forgot - without evil MS fonts ;) X server does not crash in
my case.

Sorry for any mistakes in my English.
Comment 25 Dawid Gajownik 2004-11-23 15:48:07 EST
I also noticed, that after X server crash there are some characters on
7th vt - just run telinit 3 and CTRL+ALT+F7.

What is weird, mouse on that console acts strange (it's really slow)
and I'm not able to swith to 1st vt. Only power button helps (thanks
God that it starts reboot procedure so my filesystems didn't hurt a lot).
Comment 26 Thomas Hartwig 2004-11-25 09:39:31 EST
For all who have not noticed, see this for a workaround:

https://bugs.freedesktop.org/show_bug.cgi?id=659#c6

Greetings
Thomas
Comment 27 Mike A. Harris 2004-11-25 10:15:07 EST
Adding URLs in one spot for easy clicking.

https://bugs.freedesktop.org/show_bug.cgi?id=659
http://bugzilla.mozilla.org/attachment.cgi?id=146647
Comment 29 Dawid Gajownik 2005-03-07 14:52:34 EST
Do you know that Soeren Sandmann Pedersen rulez? ;-)

With patch from bug #145546 X server does not crash anymore :D You can
close this report, because it's fixed in Rawhide.
Comment 30 Mike A. Harris 2005-03-07 17:03:14 EST
Thanks for the update!

*** This bug has been marked as a duplicate of 145546 ***
Comment 31 Red Hat Bugzilla 2006-02-21 14:02:42 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.