Bug 1214064 - missing --start-hidden option
Summary: missing --start-hidden option
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: yumex-dnf
Version: 21
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Tim Lauridsen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-04-21 20:54 UTC by John
Modified: 2015-05-01 16:45 UTC (History)
2 users (show)

Fixed In Version: dnfdaemon-0.3.7-1.fc21
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-05-01 16:38:54 UTC
Type: Bug


Attachments (Terms of Use)

Description John 2015-04-21 20:54:03 UTC
Description of problem:
Please re-add the --start-hidden option. This was useful in conjunction with my customized update checking script.

Version-Release number of selected component (if applicable):
4.1.0

How reproducible:
100%

Comment 1 Tim Lauridsen 2015-04-22 05:36:06 UTC
yumex-dnf has a build in scheduled update checker there can be activated in preferences, there is also an option to start yumex when the user login.
It will only start a small notification icon, there can check for updates and launch the yumex-dnf gui if the user click the icon.

from the command line you can start it by yumex --icononly

Comment 2 John 2015-04-22 14:24:08 UTC
Yeah, I tested the built-in update checker and it didn't quite suit me; I'd prefer to continue using my customized update checker. The --icononly option doesn't work quite the same as --start-hidden and wouldn't work well called from my script :-/

Comment 3 Tim Lauridsen 2015-04-23 09:01:06 UTC
@John, can you give me some details your usecase, so I understand it better.

Comment 4 John 2015-04-23 14:29:31 UTC
Here's what my script does with yumex 3 ...

Starts at user login. Waits x minutes before checking for updates.

The rest of this is in a loop ...

Checks for updates via yum; if there are no updates, then it waits y minutes and checks again; if there are updates it puts up a popup notification via notify-send and starts yumex in the tray as follows:
yumex --update-only --start-hidden &>/dev/null &

The script then waits for the yumex process to end before continuing the loop (that is, it waits for me to respond to the notification by actually installing the updates and then closing out of yumex, preventing it from putting up another popup notification every y minutes and calling yumex again since it's already open).

So first I'll explain why I don't want to use --icononly as a replacement for my script ...
1) I don't want the icon to clutter my tray except when updates are available
2) I want a popup notification in addition to the tray icon (as it's more noticeable, particularly because my panel is automatically hidden), which I don't think --icononly provides
3) It seems to be buggy ... once it finally finds the updates, clicking the icon doesn't seem to consistently or quickly bring up yumex ... I click it once, wait several seconds, nothing happens, then click it again and get an error message about yumex already being open, then yumex comes up, and it takes repeated clicks to get rid of the error message and it acts all goofy. If I close the yumex window the icon remains and doesn't seem to function at all when clicked after this point. I have to logoff or restart to recover.

Here's why I don't want to use --icononly in place of --start-hidden in my script ...
1) It seems to be buggy, as outlined in #3, above.
2) User seems to be unable to bring up yumex window by clicking on the icon until after all the repo metadata has loaded (this seems to be an unnecessary restriction which disrupts my process flow).
3) The icon remains after the user has closed the yumex window, making it impossible for my script to determine (using its current method) when the user has responded to the update notification.

Comment 5 Tim Lauridsen 2015-04-26 09:21:03 UTC
fixed upstream

https://github.com/timlau/yumex-dnf/issues/23

Comment 6 Tim Lauridsen 2015-04-26 09:29:51 UTC
* added notification on updates to yumex status icon, with buttons to launch  yumex
* to watch updates or to apply updates automatic (user is asked for confirmation)
addedd option to hide icon when nothing happens and there are no pending updates.
* added '--updateall' to apply all updates from cmdline with minimal gui
* status icon preferences got a separate page i prefernces.

You can use the preferences to set status icon to autostart at login or use dbus to start it 

Start status icon:
/usr/bin/dbus-send --session --print-reply --dest=dk.yumex.StatusIcon / dk.yumex.StatusIcon.Start

Check for updates: (will return the number of updates)
/usr/bin/dbus-send --session --print-reply --dest=dk.yumex.StatusIcon / dk.yumex.StatusIcon.CheckUpdates

Comment 7 John 2015-04-26 13:38:57 UTC
Sounds good! Can't wait to try it :-)

Comment 8 Fedora Update System 2015-04-26 16:47:06 UTC
yumex-dnf-4.1.1-1.fc22,dnfdaemon-0.3.7-1.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/yumex-dnf-4.1.1-1.fc22,dnfdaemon-0.3.7-1.fc22

Comment 9 Fedora Update System 2015-04-27 08:42:15 UTC
Package yumex-dnf-4.1.1-1.fc22, dnfdaemon-0.3.7-1.fc22:
* should fix your issue,
* was pushed to the Fedora 22 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing yumex-dnf-4.1.1-1.fc22 dnfdaemon-0.3.7-1.fc22'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-6975/yumex-dnf-4.1.1-1.fc22,dnfdaemon-0.3.7-1.fc22
then log in and leave karma (feedback).

Comment 10 Fedora Update System 2015-04-27 08:43:32 UTC
yumex-dnf-4.1.1-1.fc21,dnfdaemon-0.3.7-1.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/yumex-dnf-4.1.1-1.fc21,dnfdaemon-0.3.7-1.fc21

Comment 11 John 2015-04-28 19:08:48 UTC
Tested 4.1.1 and it's a definite improvement.

I do have a couple remaining requests, however ...

1) I have "Show status icon when no updates found" set to off. Could you make it so that the icon does not show up in the tray until it finds updates? Currently it shows up as soon as it starts checking, and in the case of a slow Internet connection it was stuck on "Working" for over 10 minutes ... I'd rather the icon not show at all until there are updates detected, because to me there's no point in being notified prior to that since I can't do anything at that point anyway.

2) Once updates are detected, could you make it so that yumex-dnf gets launched to the tray automatically (as an option at least)? This was one of the main reasons I requested for the --start-hidden option to be brought back. In 4.1.1, once updates are detected, when the user clicks the tray icon, in my case it takes about 5 seconds for yumex-dnf to load. With yumex 3 using the --start-hidden option, yumex was brought up instantaneously once I clicked the icon in the tray because it was preloaded. yumex-dnf already has the capability to be hidden to the tray and instantly restored -- is there any reason you can't make this a command-line startup option like in yumex 3?

Comment 12 Tim Lauridsen 2015-04-29 05:38:38 UTC
I will look into these requests.

1) sounds fine to me. the reason it takes a long time to check for update the first time, is the status icon is using a session based d-bus dnfdaemon to check for update, it will download all metadata in current users context, even if dnf metadata is allready downloaded in system context, this was done original to avoid the users get asked for admin password, but this can be fixed

2) I will look into make it even better, my main consideration is if the icon is hidden, while yumex is hidden, there is no way to make it visible, if there is no updates.

The main differnce is that in yumex 3, the status icon is part of the gui, in yumex 4, it is a separate dbus service with buildin update checker, there communicates with yumex. This is much better because it dont uses so much system ressources when not active.

Comment 13 John 2015-04-29 12:14:35 UTC
"my main consideration is if the icon is hidden, while yumex is hidden, there is no way to make it visible, if there is no updates"

I think the solution is to never hide the icon when the yumex-dnf GUI in minimized to the tray.

Comment 14 Tim Lauridsen 2015-04-29 12:34:44 UTC
Added '--minimized' cmd option to start yumex minizied.

It will use iconify(), instead of hide(), so yumex will be shown in the task list etc. so it posible so select it even if the small notification icon is not shown.

Comment 16 Fedora Update System 2015-05-01 16:38:54 UTC
dnfdaemon-0.3.7-1.fc21, yumex-dnf-4.1.1-1.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 17 Fedora Update System 2015-05-01 16:45:34 UTC
yumex-dnf-4.1.1-1.fc22, dnfdaemon-0.3.7-1.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.