Bug 12141 - Linuxconf doesn't configure smc-ultra.o correctly
Summary: Linuxconf doesn't configure smc-ultra.o correctly
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: linuxconf   
(Show other bugs)
Version: 6.2
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-06-12 18:29 UTC by dcjanes
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 18:47:41 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description dcjanes 2000-06-12 18:29:38 UTC
I just set a box up to be a firewall using two old SMC Ultra ISA NICs. I 
set the interrupts and everything, started the network and my system hung 
(cold re-start, fsck needed).

The problem appears to be that the smc-ultra driver requires another 
module to be preloaded before it is loaded.  Adding a line like

pre-install smc-ultra modprobe -a 8390

to /etc/conf.modules fixed the problem, but shouldn't linuxconf take care 
of these dependencies?  The install program did, since this machine lacks 
a CD-ROM and was installed using http.

Comment 1 Nalin Dahyabhai 2000-06-15 20:02:51 UTC
What does "grep smc-ultra /lib/modules/`uname -r`/modules.dep" on the affected
machine show?

Comment 2 dcjanes 2000-06-16 01:27:05 UTC
/lib/modules/2.2.14-5.0/net/smc-ultra.o:	
/lib/modules/2.2.14-5.0/net/8390.o
/lib/modules/2.2.14-5.0/net/smc-ultra32.o:	
/lib/modules/2.2.14-5.0/net/8390.o

Looks right to me. I'm still using the stock kernel from 6.2, as the machine is 
not really connected yet. I plan to roll a custom kernel this weekend, probably 
from the virgin 2.2.16 sources.

Comment 3 Brent Fox 2002-06-05 16:24:02 UTC
Closing because we don't ship linuxconf anymore

Comment 4 Red Hat Bugzilla 2006-02-21 18:47:41 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.