Bug 121413 - P4 HT machine will not boot with any FC1 kernel
P4 HT machine will not boot with any FC1 kernel
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
1
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Arjan van de Ven
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-21 07:04 EDT by Raphael Clifford
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-29 16:20:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg output of a boot using atrpms kernel (14.74 KB, text/plain)
2004-04-22 10:26 EDT, Raphael Clifford
no flags Details

  None (edit)
Description Raphael Clifford 2004-04-21 07:04:27 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040124

Description of problem:
No FC1 kernel will boot successfully on my single CPU P4 machine with
hyperthreading.  Here are the symptoms.

Using kernel-smp-2.4.22-1.2179.nptl or kernel-2.4.22-1.2179.nptl the
machine loads grub and then once you have chosen a kernel gets to 

Uncompressing Linux... Ok, booting the kernel

and then hangs.

Using kernel-2.4.22-1.2174.nptl or kernel-smp-2.4.22-1.2174.nptl the
machine simply reboots immediately (before any message appears)
without warning.

The only kernel that works is
kernel-smp-2.4.22-1.2174.nptl_37.rhfc1.at which runs with no apparent
problems.

Boot arguments are ro root=/dev/hda3 rhgb

Further tests tried that did not make any difference:

1) Turning off HT in the BIOS
2) noapic acpi=off at boot prompt
3) acpismp=force at boot prompt

Hardware description:

Single CPU P4 with HT. 
Motherboard  Intel D865GLC version  AAC28906-406
512MB RAM

lspci gives:

00:00.0 Host bridge: Intel Corp. 82865G/PE/P DRAM Controller/Host-Hub
Interface (rev 02)
00:01.0 PCI bridge: Intel Corp. 82865G/PE/P PCI to AGP Controller (rev 02)
00:1d.0 USB Controller: Intel Corp. 82801EB/ER (ICH5/ICH5R) USB UHCI
#1 (rev 02)
00:1d.1 USB Controller: Intel Corp. 82801EB/ER (ICH5/ICH5R) USB UHCI
#2 (rev 02)
00:1d.2 USB Controller: Intel Corp. 82801EB/ER (ICH5/ICH5R) USB UHCI
#3 (rev 02)
00:1d.3 USB Controller: Intel Corp. 82801EB/ER (ICH5/ICH5R) USB UHCI
#4 (rev 02)
00:1d.7 USB Controller: Intel Corp. 82801EB/ER (ICH5/ICH5R) USB2 EHCI
Controller (rev 02)
00:1e.0 PCI bridge: Intel Corp. 82801BA/CA/DB/EB/ER Hub interface to
PCI Bridge (rev c2)
00:1f.0 ISA bridge: Intel Corp. 82801EB/ER (ICH5/ICH5R) LPC Bridge
(rev 02)
00:1f.1 IDE interface: Intel Corp. 82801EB/ER (ICH5/ICH5R) Ultra ATA
100 Storage Controller (rev 02)
00:1f.3 SMBus: Intel Corp. 82801EB/ER (ICH5/ICH5R) SMBus Controller
(rev 02)
00:1f.5 Multimedia audio controller: Intel Corp. 82801EB/ER
(ICH5/ICH5R) AC'97 Audio Controller (rev 02)
01:00.0 VGA compatible controller: nVidia Corporation NV11DDR
[GeForce2 MX 100 DDR/200 DDR] (rev b2)
02:01.0 Multimedia audio controller: Ensoniq 5880 AudioPCI (rev 02)
02:02.0 Ethernet controller: 3Com Corporation 3c905C-TX/TX-M [Tornado]
(rev 74)


Version-Release number of selected component (if applicable):
kernel-smp-2.4.22-1.2179.nptl

How reproducible:
Always

Steps to Reproduce:
1.  Attempt to boot machine. Choose a 2179 FC1 kernel from Grub
2. Observe that the machine hangs after printing  Uncompressing
Linux... Ok, booting the kernel
3.
    

Actual Results:  Boot hangs after printing Uncompressing Linux... Ok,
booting the kernel every time.

Expected Results:  The machine should boot normally.

Additional info:

kernel-smp-2.4.22-1.2174.nptl_37.rhfc1.at works apparently perfectly.
Comment 1 Raphael Clifford 2004-04-21 08:35:25 EDT
The 2179 SMP rhfc1.at kernel also works perfectly.
Comment 2 Axel Thimm 2004-04-21 15:04:27 EDT
Are you booting from a sata drive?

The ATrpms kernels add the following patches to the standard Fedora
Core 1 kernel (some server related and some multimedia related). I
believe only the libata updates and the xfs code would touch vital
parts of the boot sequence, which would be relevant to this report.

If you are using the sata interface I'd bet on the libata updates. You
could get the src.rpm from FC1 and replace only this patch and rebuild
to check.

PS I'd love to see some of these patches in standard FC kernels. With
FC2 approaching at fast speed I suppose adding features to FC1 is not
worth while though.

o xfs
o ea+acl+nfsacls
o i2c 2.8.4 & lm_sensors 2.8.6
o openswan
o v4l2
o linux-ntfs
o libata updates
o bootsplash
o autofs updates
o CAP_SETPCAP
o drm low latency (currently deactivated as it depends on LOLAT)
o acpi updates
o Variable Hz
o alsa rtc caps
Comment 3 Arjan van de Ven 2004-04-21 15:32:57 EDT
I have yet to see a variable-HZ patch for 2.4 that isn't utterly
broken and really bad.
Comment 4 Dave Jones 2004-04-21 16:39:42 EDT
does it boot if you boot with acpi=on ?
Comment 5 Raphael Clifford 2004-04-22 10:26:13 EDT
Created attachment 99631 [details]
dmesg output of a boot using atrpms kernel
Comment 6 Raphael Clifford 2004-04-22 10:44:51 EDT
I am booting from a SATA drive. It is an 80GB Hitachi Deskstar 7K250.  

I assume the relevant lspci line for the controller is 

00:1f.1 IDE interface: Intel Corp. 82801EB/ER (ICH5/ICH5R) Ultra ATA
100 Storage Controller (rev 02)

I will test acpi=on as soon as I can reboot again.
Comment 7 Raphael Clifford 2004-04-29 09:08:30 EDT
I have tried acpi=on. 

It appears to make no difference. The kernels still hang in the same
place or simply reboot immediately.
Comment 8 Raphael Clifford 2004-07-29 09:22:37 EDT
Found a solution... it's something to do with the Linux kernel's
handling of SMP and HyperThreading - add "acpi=ht" to the kernel
options, and all's well.
Comment 9 David Lawrence 2004-09-29 16:20:51 EDT
Thanks for the bug report. However, Red Hat no longer maintains this version of
the product. Please upgrade to the latest version and open a new bug if the problem
persists.

The Fedora Legacy project (http://fedoralegacy.org/) maintains some older releases, 
and if you believe this bug is interesting to them, please report the problem in
the bug tracker at: http://bugzilla.fedora.us/
Comment 10 Raphael Clifford 2004-09-29 17:13:25 EDT
I don't mean to strike a negative note but presumably, were I to file
a report for FC2 it would stay open with no useful comments until that
went out of service too.  I am not sure this is a very inspiring system.

Note You need to log in before you can comment on or make changes to this bug.