Bug 121414 - Needs Obsoletes, Fails to remove itcl
Summary: Needs Obsoletes, Fails to remove itcl
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: tk (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
high
Target Milestone: ---
Assignee: Jens Petersen
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: FC2Blocker
TreeView+ depends on / blocked
 
Reported: 2004-04-21 11:04 UTC by Warren Togami
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-21 22:06:24 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Warren Togami 2004-04-21 11:04:40 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040418 Firefox/0.8

Description of problem:
http://togami.com/~warren/archive/2004/fc1-fc2-conflicts.txt

tcltk from FC1 has been split into tcl and tk.  itcl used to be a
subpackage from tcltk in FC1, but it fails to be removed by
dependencies within FC2's packages.  This was only clued to me due to
a single file conflict with tk.

Both tcl and tk should
Obsoletes: itcl <= 3.2

Version-Release number of selected component (if applicable):
tk-8.4.5-7

Comment 1 Jens Petersen 2004-04-21 12:31:02 UTC
Yes, the only conflict seems to be /usr/share/man/mann/panedwindow.n.gz
in itcl-3.2 and tk-devel-8.4.5.

Should be fixed in 8.4.5-8.  Thanks a lot for catching this. :-)

Comment 2 Warren Togami 2004-04-21 13:00:19 UTC
tcl-8.4.5-7 too.

Comment 3 Warren Togami 2004-04-21 22:06:24 UTC
both will be in rwahide tomorrow

Comment 4 Jerry 2004-06-23 05:56:39 UTC
I have an existing application looking for itcl.  I see it is not in
package list for FC2 but is in FC1.  Is it in the new tcl and tk
packages?  I tried installing itcl from fc1 on my fc2 system.  I
forced the overwrite of the panndwindow.n.gz to get it to install. 
The application trys to run and seg faults.  Any suggestions?  I
probably did something I should not have? :)

Comment 5 Warren Togami 2004-06-23 06:45:11 UTC
itcl is unsupported in FC2, sorry.  If strong reasoning can be given
to bring it back, then it is Petersen's decision as package maintainer
if the reasons are good enough to increase the maintenance burden in
re-adding and supporting it in FC2 updates and future products.


Comment 6 Jens Petersen 2004-07-30 07:33:54 UTC
Jerry, I don't know, I see to remember testing it and it working
for me, but I could be wrong... have you tried rebuilding itcl
on fc2?

Comment 7 Jens Petersen 2004-07-30 07:34:44 UTC
There haven't been that many requests for itcl: it would
probably be something good to contribute to Fedora Extras
in my opinion.


Note You need to log in before you can comment on or make changes to this bug.