Bug 121426 - Login name limited to 8 chars in 'last' output
Login name limited to 8 chars in 'last' output
Status: CLOSED UPSTREAM
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: SysVinit (Show other bugs)
3.0
All Linux
medium Severity low
: ---
: ---
Assigned To: Bill Nottingham
David Lawrence
:
: 172247 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-21 10:13 EDT by Mario Lorenz
Modified: 2014-03-16 22:44 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-21 15:14:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mario Lorenz 2004-04-21 10:13:21 EDT
Description of problem:

The username is not fully displayed in "last" output
Only the first 8 characters are shown. Given the man page
does notmention this limitation, and given further
the user name is not limited to 8 characters on RHEL
(adduser allows longer usernames, redhat-config-user
does, UT_NAMESIZE is 32), this hard limit is
insufficient, especially if you have a username
that is 8 chars long and a second user with a name
that is longer, but has the same first 8 chars.

The same applies to "w" in the procps and "who"
in the coreutils packages.

utmp and wtmp do have proper data, 
Other utils (ls, utmpdump) handle long file names
correctly.

Version-Release number of selected component (if applicable):
2.85-4

How reproducible:
Always


Steps to Reproduce:
1. create user a12345678901234567890 using adduser or redhat-config-users
2. ls -la /home :observe home directory name and owner/group are shown
properly in full length
3. log in as that user
4. use w, who and observe you show only up as a1234567
5. logout
6. use last to observe you show only up as a1234567
   (which may be confusing, if, by coincidence, another user on the
   system is named a1234567
  
Actual results:
see above

Expected results:

login names should be shown in full length.If this is not
feasible for optical reasons (columns), the output should
mark them as cut off, and a command line option to display
them using the full name (distorting columns if needed)
should be available.


Additional info:

I know that historically, Unix had a 8char username limit. However
I thought these days were long gone. And especially with 32bit UIDs...
Comment 1 Mario Lorenz 2004-04-21 10:15:23 EDT
Typo: Make this "Other utils (ls, utmpdump) handle long login names
correctly"
Comment 2 Bill Nottingham 2005-09-21 15:14:33 EDT
Red Hat strives to work within the community of upstream open source projects.
This allows us to reduce the likelihood of regressions between releases as well
as to benefit from features and fixes as development moves forward. This change
would require a significant divergence from the upstream project and is
therefore being rejected.

The upstream site is ftp://ftp.cistron.nl/pub/people/miquels/sysvinit/; they may
be amenable to this suggestion.
Comment 3 Bill Nottingham 2005-11-01 16:52:20 EST
*** Bug 172247 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.