Bug 1214299 (kf5-bluez-qt) - Review Request: kf5-bluez-qt - A Qt wrapper for Bluez
Summary: Review Request: kf5-bluez-qt - A Qt wrapper for Bluez
Keywords:
Status: CLOSED RAWHIDE
Alias: kf5-bluez-qt
Product: Fedora
Classification: Fedora
Component: Package Review
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jan Grulich
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: kde-reviews kf5 plasma5
TreeView+ depends on / blocked
 
Reported: 2015-04-22 11:47 UTC by Daniel Vrátil
Modified: 2015-11-02 01:38 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-05-05 15:43:57 UTC
jgrulich: fedora-review+
gwync: fedora-cvs+


Attachments (Terms of Use)

Description Daniel Vrátil 2015-04-22 11:47:51 UTC
Spec URL: https://dvratil.fedorapeople.org/plasma5/review/kf5-bluez-qt.spec
SRPM URL: https://dvratil.fedorapeople.org/plasma5/review/kf5-bluez-qt-5.2.95-1.fc21.src.rpm
Description: A Qt wrapper for Bluez
Fedora Account System Username: dvratil

kf5-bluez-qt is currently released as part of Plasma 5 (hence the 5.2.95 version), but according to upstream the plan is to move it to Frameworks around 5.11, hence the name.

Comment 1 Daniel Vrátil 2015-04-22 11:51:37 UTC
Question: should this deprecate libbluedevil, since bluedevil now depends on this instead of libbluedevil?

Comment 2 Jan Grulich 2015-04-22 12:49:57 UTC
1) I think it should deprecate libbluedevil, there won't be probably any new release. Unless you want to keep KDE 4 version from some reason.

2) #%doc COPYING.LIB README.md → Why is this commented out?

Except of above mentioned issues it looks good. License is correct, scriptlets are also correct.

Comment 3 Daniel Vrátil 2015-04-22 13:05:12 UTC
Spec URL: https://dvratil.fedorapeople.org/plasma5/review/kf5-bluez-qt.spec
SRPM URL: https://dvratil.fedorapeople.org/plasma5/review/kf5-bluez-qt-5.2.95-2.fc21.src.rpm

* Wed Apr 22 2015 Daniel Vrátil <dvratil@redhat.com> - 5.2.95-2
- install %%doc
- Obsoletes: libbluedevil

Comment 4 Jan Grulich 2015-04-22 13:25:30 UTC
Looks good now, approved.

Comment 5 Daniel Vrátil 2015-04-22 18:45:30 UTC
New Package SCM Request
=======================
Package Name: pkgname
Short Description: summary of package
Upstream URL: http://pkgname-project.org/pkgname
Owners: dvratil ltinkl jgrulich rdieter kkofler
Branches: f22
InitialCC: group::kde-sig

Comment 6 Gwyn Ciesla 2015-04-22 19:44:04 UTC
WARNING: Requested package name pkgname doesn't match bug summary
kf5-bluez-qt

Comment 7 Daniel Vrátil 2015-04-23 12:03:12 UTC
New Package SCM Request
=======================
Package Name: kf5-bluez-qt
Short Description: A Qt wrapper for Bluez
Upstream URL: https://projects.kde.org/projects/kde/workspace/bluez-qt
Owners: dvratil ltinkl jgrulich rdieter kkofler
Branches: f22
InitialCC: group::kde-sig

Comment 8 Gwyn Ciesla 2015-04-23 12:40:59 UTC
Git done (by process-git-requests).

Comment 9 Rex Dieter 2015-05-05 15:43:57 UTC
imported


Note You need to log in before you can comment on or make changes to this bug.