Bug 12143 - shm: no such module
Summary: shm: no such module
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: modutils   
(Show other bugs)
Version: 7.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Michael K. Johnson
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-06-12 18:39 UTC by Hans de Goede
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-06-22 10:05:40 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Hans de Goede 2000-06-12 18:39:24 UTC
The attemp to mount /var/shm causes modprobe to complain that there is no
shm module (on 2.2.x kernels), since shm will be hard compiled into 2.4
afaik, i suggest adding "alias shm off" to /etc/conf.modules, so that new
users won't be scared by this message.

On a related note the mounting of /var/shm at this point also causes an
error that modules.dep doesn't exist on the first boot after a new kernel
install, so maybe do this mount after runnign depmod, before that shm is
probably not needed anyways.

Comment 1 Pekka Savola 2000-06-22 10:05:38 UTC
This also happens with beta2.

Comment 2 Bill Nottingham 2000-07-06 20:51:11 UTC
Should be fixed as of beta3.


Note You need to log in before you can comment on or make changes to this bug.