Bug 1214318 - Copy and paste from gnome-terminal not working in wayland session
Summary: Copy and paste from gnome-terminal not working in wayland session
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-terminal
Version: 22
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
Assignee: Matthias Clasen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: WaylandRelated
TreeView+ depends on / blocked
 
Reported: 2015-04-22 12:28 UTC by evgenymarkov
Modified: 2016-05-10 20:07 UTC (History)
16 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2016-05-10 20:07:28 UTC


Attachments (Terms of Use)

Description evgenymarkov 2015-04-22 12:28:22 UTC
Description of problem:
Copy/paste not working with gnome-terminal in wayland session.

Version-Release number of selected component (if applicable):
3.16.1

Steps to Reproduce:
1. Run gnome in wayland-session.
2. Open gnome-terminal window.
3. Try ctrl + shift + c, ctrl + shift + v and copy and paste with context menu.

Comment 1 Mike FABIAN 2015-04-23 09:56:42 UTC
This works for me on Fedora 22 Beta (with all current updates 
installed by “sudo dnf update”). It works for me both  with the
context menu and the key bindings.

Versions:

[mfabian@Fedora-Live-Workstation-x86_64-2 ~]$ rpm -q gnome-shell  gnome-terminal
gnome-shell-3.16.1-1.fc22.x86_64
gnome-terminal-3.16.1-1.fc22.x86_64
[mfabian@Fedora-Live-Workstation-x86_64-2 ~]$

Comment 2 Mike FABIAN 2015-04-23 12:10:13 UTC
But see: https://bugzilla.redhat.com/show_bug.cgi?id=1214655
(cut and past in Gnome Wayland still does not work by using the mouse
only, one has to use Control-c and Control-v)

Comment 3 davidzgumberg 2015-07-19 05:04:37 UTC
I am experiencing the same bug with the latest packages in fedora 22.

Comment 4 Johnny Robeson 2015-10-30 02:48:47 UTC
Somebody should test if this is fixed on Fedora 23. It should hopefully be fixed there.

Comment 5 Olivier Fourdan 2015-10-30 09:31:07 UTC
(In reply to Johnny Robeson from comment #4)
> Somebody should test if this is fixed on Fedora 23. It should hopefully be
> fixed there.

Could you clarify what the bug is about exactly?

 - If this bug is about middle mouse paste, this is normal and by design, there is no primary buffer in Wayland so the X11 method of select/paste with middle mouse button won't work in Wayland. See bug 1214655#c7

 - If this bug is about Ctrl-C/Ctrl-V not working between GNOME/GTK+ apps running under Wayland (e.g. between gnome-terminal and gedit), I cannot reproduce this is F23 so this works in my case.

 - If this bug is about copy/paste between X11/Xwayland apps and GNOME/GTK+ apps (e.g. copy from Firefox and paste in gedit), this works as well in F23 as far as I can tell.

Comment 6 Johnny Robeson 2015-10-30 10:25:05 UTC
the last one is what I'm referring to, because this bug was filed against fedora 22

Comment 7 Mike FABIAN 2015-11-01 02:14:25 UTC
(In reply to Johnny Robeson from comment #4)
> Somebody should test if this is fixed on Fedora 23. It should hopefully be
> fixed there.

It works for me in Fedora 23 RC3.

Comment 8 bodhi.zazen 2015-11-06 16:45:40 UTC
I am having problems on Fedora 23 in gnome-shell / Gnome Wayland with all of this.

copy-paste only works from the menus and not with mouse select -> middle click or with select Ctrl-C Ctrl-V

Seems to be a problem with both Wayland apps (gnome-terminal / gedit) and XWayland (firefox to gnome terminal)

Comment 9 Frank Ansari 2015-11-09 18:49:37 UTC
This is a bad bug. I just noticed this when I noticed that suddenly copy & paste from keepass did not work anymore.

Until this is fixed Wayland is unusuable for me.

Sorry - but copy & paste is really a basic feature.

Comment 10 Frank Ansari 2015-11-09 20:20:26 UTC
I use gnome-terminal-3.18.1-1.fc23.x86_64.

When I try to copy & paste from the Gnome terminal into this window or e.g. into the Atom editor this is working.

Also I use keepass-2.30-2.fc23.x86_64.

When I try to copy & pase from keepass into the Gnome terminal this does *not* work.

As a workaround I can copy the password from keepass into an editor and from there into the Gnome terminal.

For this reason I will stop using Wayland.

Comment 11 Frank Ansari 2015-11-21 14:13:31 UTC
Is there any progress here? This issue is really annoying.

Comment 12 Olivier Fourdan 2015-11-23 14:38:36 UTC
(In reply to Frank Ansari from comment #11)
> Is there any progress here? This issue is really annoying.

Middle mouse paste is another issue being discussed in bug 1214655.

But for Ctrl-C/Ctrl-V it's weird, as a test, on two different systems, I installed "keepass" on F23 and I can copy/paste passwords between keepass and gnome-terminal in Wayland - I checked with xsel that the X11 selection is set by keepass and it works. I wonder why it doesn't work in your case.

Comment 13 Frank Ansari 2015-11-24 19:36:24 UTC
Yes it is strange and I have now idea about the reason.

A test on another machine with Fedora 23 it worked.

I have now reinstalled my gonme-terminal package and now it works.

Comment 14 Martin Vysny 2015-11-27 14:28:17 UTC
This issue also bugs me on Fedora 23. I can reproduce it any time - just view any text file using the Krusader's built-in viewer, copy the text and paste it into Gedit - the result is that the old clipboard contents (or nothing at all) is pasted into Gedit. Yet, if you open, say, Firefox, the text can be pasted without any problem into Firefox URL bar.

Comment 15 Frank Ansari 2015-11-27 20:42:03 UTC
I want to revert my opinion that this issue is fixed for me. Today I worked a lot with keepass and it was really no fun. Sometime it works and sometime not.

Only workaround is to take some editor ("atom" in my case) and paste the password there and then paste it from there into to gnome terminal.

Even worse is the other way round: try to copy something from the terminal and paste it into keepass. keepass is hanging - you even cannot close the current entry. You only can close the application.

So Wayland seems to be still experimental.

Comment 16 Frank Ansari 2016-01-03 15:44:19 UTC
I stopped again trying Wayland. The experience is unacceptable for normal usage. Chrome browser is hanging and as describes keepass is near to unusable and now I found out the next issue:

In the Evolution mail client when I drag an email to another folder it is not moved there but copied. When I want to copy it I can either move and and delete the original mail from the inbox or I can use the menu. From the menu when I select "move" it works.

Another issue: while in wayland when I log off it is not possible to login again. When I do so the gdm comes again after login.

This means there I so many issues that I can only hope that Wayland will work in Fedora 24.

Comment 17 Tomasz Torcz 2016-01-03 15:56:20 UTC
c#16, This issue is about middle-click paste. Please keep it that way, open another bugs for other issues.

Comment 18 Kamil Páral 2016-01-04 09:17:00 UTC
(In reply to Tomasz Torcz from comment #17)
> c#16, This issue is about middle-click paste.

According to comment 12, this is not about middle-click. This is about standard clipboard shortcuts not working properly.

> open another bugs for other issues.

Yes please.

Comment 19 Frank Ansari 2016-01-04 18:43:42 UTC
I have opened now two additional bugs:

evolution issue: 1295210
gdm issue:       1295211


Note You need to log in before you can comment on or make changes to this bug.