Bug 1214341 - Diamond package fails to install on minion nodes during state.highstate
Summary: Diamond package fails to install on minion nodes during state.highstate
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: Calamari
Version: 1.2.3
Hardware: All
OS: Linux
unspecified
high
Target Milestone: rc
: 1.2.4
Assignee: ceph-eng-bugs
QA Contact: ceph-qe-bugs
URL:
Whiteboard:
: 1214399 (view as bug list)
Depends On:
Blocks: 1215802
TreeView+ depends on / blocked
 
Reported: 2015-04-22 13:38 UTC by Christina Meno
Modified: 2019-09-12 08:24 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1215802 (view as bug list)
Environment:
Last Closed: 2015-06-11 18:51:07 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 1407943 0 Troubleshoot None Cluster Updates Are Stale. The Cluster isn't updating Calamari. Please contact Administrator. Why ? 2019-06-13 08:25:45 UTC
Red Hat Knowledge Base (Solution) 1492513 0 None None None Never
Red Hat Product Errata RHBA-2015:1093 0 normal SHIPPED_LIVE Ceph Storage: calamari-server package bug-fix update 2015-06-11 22:50:59 UTC

Description Christina Meno 2015-04-22 13:38:34 UTC
Description of problem:
# salt '*' state.highstate
<host>:
    Data failed to compile:
----------
    No function declared in state "cmd" in sls diamond

Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1. issue command "salt '*' pkg.install diamond" from calamari node
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Ken Dreyer (Red Hat) 2015-04-22 21:34:11 UTC
Gregory, does this bug affect Calamari 1.3? If so we'll need to clone this to RHCS 1.3.0.

Comment 2 Vikhyat Umrao 2015-05-04 14:10:29 UTC
*** Bug 1214399 has been marked as a duplicate of this bug. ***

Comment 4 Christina Meno 2015-05-08 16:13:18 UTC
fixed upstream in https://github.com/ceph/calamari/commit/80890d9657c06402c9e036d4382532c2839f947d

Comment 14 Warren 2015-06-10 04:31:35 UTC
Looks good.

I assume that salt '*' pkg.install diamond with no output and a successful return code is what we want.

Comment 16 errata-xmlrpc 2015-06-11 18:51:07 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2015:1093


Note You need to log in before you can comment on or make changes to this bug.